# Kibana logs

**URL:** <https://discuss.elastic.co/t/kibana-logs/39163>\
**Category:** Kibana\
**Created:** [January 13, 2016, 10:30pm UTC](https://discuss.elastic.co/t/kibana-logs/39163 "2016-01-13T22:30:28Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![sripri](https://avatars.discourse-cdn.com/v4/letter/s/43a26b/32.png) [@sripri](https://discuss.elastic.co/u/sripri)\
**Post date:** [January 13, 2016, 10:30pm UTC](https://discuss.elastic.co/t/kibana-logs/39163/1 "2016-01-13T22:30:28Z")

</div>

Hi All  
I am trying to run Kibana and externalize logging with no success. The additional complexity I am dealing with is Docker. I am able to run the dockerized image of Kibana with an external config file.

logging.dest: /opt/kibana/log/kibana.log --\> I have volume mapped the destination folder to the host

When I start Kibana it errors out with the following error:

```
events.js:85
      throw er; // Unhandled 'error' event
            ^
Error: EACCES, open '/opt/kibana/log/kibana.log'
    at Error (native)

```

Any ideas what is happening?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 13, 2016, 10:31pm UTC](https://discuss.elastic.co/t/kibana-logs/39163/2 "2016-01-13T22:31:24Z")

</div>

Looks like it doesn't have access to that file.  
Can you check that it's mounted and you can write to it when the container is up?

---

<div class="post-metadata">

**Author:** ![sripri](https://avatars.discourse-cdn.com/v4/letter/s/43a26b/32.png) [@sripri](https://discuss.elastic.co/u/sripri)\
**Post date:** [January 13, 2016, 11:00pm UTC](https://discuss.elastic.co/t/kibana-logs/39163/3 "2016-01-13T23:00:11Z")

</div>

Thanks for your response. Yes the directory is on the host where kibana is running. And there seems to be some permissions issue. Not sure why. May be I should explicitly give it a :rw ? in the docker-compose script? I checked and could'nt find an example for docker. Any ideas?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 14, 2016, 12:43am UTC](https://discuss.elastic.co/t/kibana-logs/39163/4 "2016-01-14T00:43:10Z")

</div>

Sounds like you need to give it rw, yes.

---

<div class="post-metadata">

**Author:** ![sripri](https://avatars.discourse-cdn.com/v4/letter/s/43a26b/32.png) [@sripri](https://discuss.elastic.co/u/sripri)\
**Post date:** [January 14, 2016, 7:19pm UTC](https://discuss.elastic.co/t/kibana-logs/39163/5 "2016-01-14T19:19:26Z")

</div>

Tried. Still no luck. Is there any documentation on how to? The elastic search doc site mentions in settings to set logging.dest. But can you give me an example?  
I was able to set the logging.dest from within the docker container to write to the host using **the -l option**  
but got the following error  
FATAL { [Error: listen EADDRINUSE]  
cause: { [Error: listen EADDRINUSE] code: 'EADDRINUSE', errno: 'EADDRINUSE', syscall: 'listen' },  
isOperational: true,  
code: 'EADDRINUSE',  
errno: 'EADDRINUSE',  
syscall: 'listen' }  
But it created the log file. Any clues?

---

<div class="post-metadata">

**Author:** ![Bargs](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bargs/32/5429_2.png) [@Bargs](https://discuss.elastic.co/u/Bargs)\
**Post date:** [January 14, 2016, 7:54pm UTC](https://discuss.elastic.co/t/kibana-logs/39163/6 "2016-01-14T19:54:00Z")

</div>

This sounds like it's really a docker setup issue, so I don't think we can offer a ton of guidance. In my experience with docker, permissions issues tended to crop up when you have a mismatch between the users inside the container vs the host. You probably want to figure out what user Kibana is running as inside the container, and what user/group owns the directory you're trying to write to on the host. What matters here is that the UID and GID match inside and outside of the container, it's not enough for just the names to match.

That said, it's just my gut reaction and I haven't worked with docker in awhile, so my recommendations could be out of date.

---

<div class="post-metadata">

**Author:** ![antonking](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/antonking/32/16009_2.png) [@antonking](https://discuss.elastic.co/u/antonking)\
**Post date:** [March 2, 2017, 9:53am UTC](https://discuss.elastic.co/t/kibana-logs/39163/7 "2017-03-02T09:53:49Z")

</div>

I actually had the same problem and i commented out the line logging.dest: in my kibana.yaml file. Then my kibana started but with some errors on the dashboard related to elasticsearch. And ofcourse now i have to figure out where the logs are redirected by kibana.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:32pm UTC](https://discuss.elastic.co/t/kibana-logs/39163/8 "2017-07-06T13:32:54Z")

</div>


