# kibanaでエラー「Monitoring: Error 429」が出る件

**URL:** <https://discuss.elastic.co/t/kibana-monitoring-error-429/195132>\
**Category:** 日本語による質問・議論はこちら\
**Created:** [August 14, 2019, 3:36am UTC](https://discuss.elastic.co/t/kibana-monitoring-error-429/195132 "2019-08-14T03:36:24Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![yn2018](https://avatars.discourse-cdn.com/v4/letter/y/898d66/32.png) [@yn2018](https://discuss.elastic.co/u/yn2018)\
**Post date:** [August 14, 2019, 3:36am UTC](https://discuss.elastic.co/t/kibana-monitoring-error-429/195132/1 "2019-08-14T03:36:24Z")

</div>

kibanaのmonitoringを触っていると以下のようにエラーが出ます。

 ![13](https://us1.discourse-cdn.com/elastic/original/3X/a/d/ade7b1721eff44b7c3ffe68518ecf00cf091976c.png)

エラーメッセージは以下のような感じです。

> Monitoring: Error 429 : [es\_rejected\_execution\_exception] rejected execution of org.elasticsearch.transport.TransportService$7@c2f8810 on EsThreadPoolExecutor[search, queue capacity = 1000, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@3b56da80[Running, pool size = 13, active threads = 13, queued tasks = 1024, completed tasks = 3058713]]

ざっと調べましたが、明確な解決方法が見つからないので、こちらで質問させていただきました。

どなたか知恵をお貸しいただければ幸いです。

---

<div class="post-metadata">

**Author:** ![tsgkdt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsgkdt/32/39151_2.png) [@tsgkdt](https://discuss.elastic.co/u/tsgkdt)\
**Post date:** [August 14, 2019, 5:45am UTC](https://discuss.elastic.co/t/kibana-monitoring-error-429/195132/2 "2019-08-14T05:45:59Z")

</div>

es\_rejected\_execution\_exceptionは、大量のリクエストがElasticsearchクラスタに届いて処理しきれなくなっているときに、よく見かけます。  
（Elasticsearch側でもエラーログが出ていませんか？）

まずElasticsearchクラスタを立てている環境が十分なハードウェアを積んで、Heapのサイズなど正しく指定できているかを確認したいところです。

次に構成や設置に問題がないなら、ノード追加が検討されるのではないかと思います。

---

<div class="post-metadata">

**Author:** ![yn2018](https://avatars.discourse-cdn.com/v4/letter/y/898d66/32.png) [@yn2018](https://discuss.elastic.co/u/yn2018)\
**Post date:** [August 15, 2019, 10:31am UTC](https://discuss.elastic.co/t/kibana-monitoring-error-429/195132/3 "2019-08-15T10:31:25Z")

</div>

ありがとうございます。

確かにelasticsearch側で以下のようなエラー（エラーの一部を抜粋）が出続けていますね。

> org.elasticsearch.transport.RemoteTransportException: [jde7JlA][127.0.0.1:9300][indices:data/read/search[can\_match]]  
> Caused by: org.elasticsearch.common.util.concurrent.EsRejectedExecutionException: rejected execution of org.elasticsearch.transport.TransportService$7@f1e8e73 on EsThreadPoolExecutor[search, queue capacity = 1000, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@3b56da80[Running, pool size = 13, active threads = 13, queued tasks = 5756, completed tasks = 7252449]]

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 12, 2019, 10:37am UTC](https://discuss.elastic.co/t/kibana-monitoring-error-429/195132/4 "2019-09-12T10:37:35Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
