# Kibana monitoring page timeout

**URL:** <https://discuss.elastic.co/t/kibana-monitoring-page-timeout/166498>\
**Category:** Kibana\
**Created:** [January 31, 2019, 8:34am UTC](https://discuss.elastic.co/t/kibana-monitoring-page-timeout/166498 "2019-01-31T08:34:59Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Hari\_Prasad](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hari_prasad/32/56784_2.png) [@Hari\_Prasad](https://discuss.elastic.co/u/Hari_Prasad)\
**Post date:** [January 31, 2019, 8:34am UTC](https://discuss.elastic.co/t/kibana-monitoring-page-timeout/166498/1 "2019-01-31T08:34:59Z")

</div>

The monitoring page in Kibana UI times out with the following error

{"type":"error","@timestamp":"2019-01-31T05:47:02Z","tags":["error","monitoring-ui"],"pid":20709,"level":"error","error":{"message":"Request Timeout after 30000ms","name":"Error","stack":"Error: Request Timeout after 30000ms\n at /usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:354:15\n at Timeout. (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:383:7)\n at ontimeout (timers.js:498:11)\n at tryOnTimeout (timers.js:323:5)\n at Timer.listOnTimeout (timers.js:290:5)"},"message":"Request Timeout after 30000ms"}

Increasing the timeout value didn't help either

I am able to access other pages also able to run queries in Dev Tools window, including queries on monitoring indices

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [January 31, 2019, 9:08pm UTC](https://discuss.elastic.co/t/kibana-monitoring-page-timeout/166498/2 "2019-01-31T21:08:16Z")

</div>

Hrm, I'm not sure what would be causing that. Have you checked the log output from Elasticsearch or Kibana to see if there are any error messages there?

---

<div class="post-metadata">

**Author:** ![Hari\_Prasad](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hari_prasad/32/56784_2.png) [@Hari\_Prasad](https://discuss.elastic.co/u/Hari_Prasad)\
**Post date:** [February 1, 2019, 10:43am UTC](https://discuss.elastic.co/t/kibana-monitoring-page-timeout/166498/3 "2019-02-01T10:43:09Z")

</div>

There were no errors in the Elasticsearch logs

But I soled it. This was due to the X-pack licence issues. Updating the licence solved the issue

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 1, 2019, 10:43am UTC](https://discuss.elastic.co/t/kibana-monitoring-page-timeout/166498/4 "2019-03-01T10:43:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
