# Kibana not found elasticsearch host

**URL:** <https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839>\
**Category:** Kibana\
**Created:** [November 10, 2021, 4:20am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839 "2021-11-10T04:20:44Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![mehmood1](https://avatars.discourse-cdn.com/v4/letter/m/2acd7d/32.png) [@mehmood1](https://discuss.elastic.co/u/mehmood1)\
**Post date:** [November 10, 2021, 4:20am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/1 "2021-11-10T04:20:44Z")

</div>

when i run kibana.bat on windows os it is showing error. Both are running in same machine.

FATAL Error: [config validation of [server].host]: types that failed validation:

- [config validation of [server].host.0]: value must be a valid hostname (see RFC 1123).
- [config validation of [server].host.1]: expected value to equal [0]

below url i add in kibana.yml

Elasticsearch.host: ["[http://172.xx.xx.x:9200](http://172.xx.xx.x:9200)"]

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 10, 2021, 4:22am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/2 "2021-11-10T04:22:59Z")

</div>

Can you please post your entire Kibana config.

---

<div class="post-metadata">

**Author:** ![mehmood1](https://avatars.discourse-cdn.com/v4/letter/m/2acd7d/32.png) [@mehmood1](https://discuss.elastic.co/u/mehmood1)\
**Post date:** [November 10, 2021, 4:24am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/3 "2021-11-10T04:24:34Z")

</div>

```auto
# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "172.16.0.61:5601"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# Specifies the public URL at which Kibana is available for end users. If
# `server.basePath` is configured this URL should end with the same basePath.
#server.publicBaseUrl: ""

# The maximum payload size in bytes for incoming server requests.
#server.maxPayload: 1048576

# The Kibana server's name. This is used for display purposes.
#server.name: "your-hostname"

# The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.host: ["http://172.xx.xx.x:9200"]

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
#elasticsearch.username: "kibana_system"
#elasticsearch.password: "pass"

# Kibana can also authenticate to Elasticsearch via "service account tokens".
# If may use this token instead of a username/password.
# elasticsearch.serviceAccountToken: "my_token"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files are used to verify the identity of Kibana to Elasticsearch and are required when
# xpack.security.http.ssl.client_authentication in Elasticsearch is set to required.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: ["/path/to/your/CA.pem"]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [authorization]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 30000

# Logs queries sent to Elasticsearch. Requires logging.verbose set to true.
#elasticsearch.logQueries: false

# Specifies the path where Kibana creates the process ID file.
#pid.file: /run/kibana/kibana.pid

# Enables you to specify a file where Kibana stores log output.
#logging.dest: stdout

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
#logging.verbose: false

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# Specifies locale to be used for all localizable strings, dates and number formats.
# Supported languages are the following: English - en , by default , Chinese - zh-CN .
#i18n.locale: "en"`Preformatted text`

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 10, 2021, 4:26am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/4 "2021-11-10T04:26:08Z")

</div>

That looks valid.

> [@mehmood1](#):
>
> FATAL Error: [config validation of [server].host]: types that failed validation:

Where did you see this?

---

<div class="post-metadata">

**Author:** ![mehmood1](https://avatars.discourse-cdn.com/v4/letter/m/2acd7d/32.png) [@mehmood1](https://discuss.elastic.co/u/mehmood1)\
**Post date:** [November 10, 2021, 4:28am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/5 "2021-11-10T04:28:32Z")

</div>

when i run kibana.bat in windows then its failed due to this error

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 10, 2021, 4:30am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/6 "2021-11-10T04:30:38Z")

</div>

Can you post the entire output you are running and seeing please.

---

<div class="post-metadata">

**Author:** ![mehmood1](https://avatars.discourse-cdn.com/v4/letter/m/2acd7d/32.png) [@mehmood1](https://discuss.elastic.co/u/mehmood1)\
**Post date:** [November 10, 2021, 4:33am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/7 "2021-11-10T04:33:59Z")

</div>

```auto
C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\bin>kibana.bat
  log [20:14:37.216] [fatal][root] ValidationError: [config validation of [server].host]: types that failed validation:
- [config validation of [server].host.0]: value must be a valid hostname (see RFC 1123).
- [config validation of [server].host.1]: expected value to equal [0]
    at ObjectType.validate (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\@kbn\config-schema\target_node\types\type.js:88:13)
    at ConfigService.validateAtPath (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\@kbn\config\target_node\config_service.js:232:19)
    at MapSubscriber.project (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\@kbn\config\target_node\config_service.js:240:169)
    at MapSubscriber._next (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\rxjs\internal\operators\map.js:49:35)
    at MapSubscriber.Subscriber.next (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\rxjs\internal\Subscriber.js:66:18)
    at DistinctUntilChangedSubscriber._next (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\rxjs\internal\operators\distinctUntilChanged.js:69:30)
    at DistinctUntilChangedSubscriber.Subscriber.next (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\rxjs\internal\Subscriber.js:66:18)
    at MapSubscriber._next (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\rxjs\internal\operators\map.js:55:26)
    at MapSubscriber.Subscriber.next (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\rxjs\internal\Subscriber.js:66:18)
    at ReplaySubject._subscribe (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\rxjs\internal\ReplaySubject.js:80:28) {
  cause: SchemaTypesError: types that failed validation:
      at UnionType.handleError (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\@kbn\config-schema\target_node\types\union_type.js:41:16)
      at UnionType.onError (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\@kbn\config-schema\target_node\types\type.js:121:36)
      at Object.error (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\@kbn\config-schema\target_node\types\type.js:72:47)
      at Object.internals.finalize (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\joi\lib\validator.js:472:36)
      at Object.exports.validate (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\joi\lib\validator.js:333:38)
      at internals.Base.$_validate (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\joi\lib\base.js:773:26)
      at Object.validate (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\joi\lib\types\keys.js:108:45)
      at Object.exports.validate (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\joi\lib\validator.js:325:26)
      at Object.internals.entry (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\joi\lib\validator.js:142:28)
      at Object.exports.entry (C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\node_modules\joi\lib\validator.js:27:30) {
    cause: undefined,
    path: ['host'],
    errors: [[SchemaTypeError], [SchemaTypeError] ]
  }
}

 FATAL Error: [config validation of [server].host]: types that failed validation:
- [config validation of [server].host.0]: value must be a valid hostname (see RFC 1123).
- [config validation of [server].host.1]: expected value to equal [0]

C:\Users\MEHMOODULHASSAN\Downloads\ELK Metrics\kibana-7.15.1-windows-x86_64\bin>

```

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [November 10, 2021, 4:47am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/8 "2021-11-10T04:47:24Z")

</div>

> [@mehmood1](#):
>
> `server.host: "172.16.0.61:5601"`

Should not include the port as it is defined in the line above

`server.host: "172.16.0.61"`

---

<div class="post-metadata">

**Author:** ![mehmood1](https://avatars.discourse-cdn.com/v4/letter/m/2acd7d/32.png) [@mehmood1](https://discuss.elastic.co/u/mehmood1)\
**Post date:** [November 10, 2021, 4:56am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/9 "2021-11-10T04:56:03Z")

</div>

After removing port

` FATAL Error: [config validation of [elasticsearch].host]: definition for this key is missing`

---

<div class="post-metadata">

**Author:** ![mehmood1](https://avatars.discourse-cdn.com/v4/letter/m/2acd7d/32.png) [@mehmood1](https://discuss.elastic.co/u/mehmood1)\
**Post date:** [November 10, 2021, 4:58am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/10 "2021-11-10T04:58:03Z")

</div>

Wait a moment i guess, i forgot something

---

<div class="post-metadata">

**Author:** ![mehmood1](https://avatars.discourse-cdn.com/v4/letter/m/2acd7d/32.png) [@mehmood1](https://discuss.elastic.co/u/mehmood1)\
**Post date:** [November 10, 2021, 5:00am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/11 "2021-11-10T05:00:19Z")

</div>

same

definition for this key is missing

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [November 10, 2021, 5:08am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/12 "2021-11-10T05:08:12Z")

</div>

that is a yml syntax error post your kibana.yml again

---

<div class="post-metadata">

**Author:** ![mehmood1](https://avatars.discourse-cdn.com/v4/letter/m/2acd7d/32.png) [@mehmood1](https://discuss.elastic.co/u/mehmood1)\
**Post date:** [November 10, 2021, 5:10am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/13 "2021-11-10T05:10:13Z")

</div>

```auto
# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "172.16.0.61"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# Specifies the public URL at which Kibana is available for end users. If
# `server.basePath` is configured this URL should end with the same basePath.
#server.publicBaseUrl: ""

# The maximum payload size in bytes for incoming server requests.
#server.maxPayload: 1048576

# The Kibana server's name. This is used for display purposes.
#server.name: "your-hostname"

# The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.host: ["http://localhost:9200"]

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
#elasticsearch.username: "kibana_system"
#elasticsearch.password: "pass"

# Kibana can also authenticate to Elasticsearch via "service account tokens".
# If may use this token instead of a username/password.
# elasticsearch.serviceAccountToken: "my_token"

# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# Optional settings that provide the paths to the PEM-format SSL certificate and key files.
# These files are used to verify the identity of Kibana to Elasticsearch and are required when
# xpack.security.http.ssl.client_authentication in Elasticsearch is set to required.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Optional setting that enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: ["/path/to/your/CA.pem"]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [authorization]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 30000

# Logs queries sent to Elasticsearch. Requires logging.verbose set to true.
#elasticsearch.logQueries: false

# Specifies the path where Kibana creates the process ID file.
#pid.file: /run/kibana/kibana.pid

# Enables you to specify a file where Kibana stores log output.
#logging.dest: stdout

# Set the value of this setting to true to suppress all logging output.
#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.
#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information
# and all requests.
#logging.verbose: false

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# Specifies locale to be used for all localizable strings, dates and number formats.
# Supported languages are the following: English - en , by default , Chinese - zh-CN .
#i18n.locale: "en"

```

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [November 10, 2021, 5:10am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/14 "2021-11-10T05:10:24Z")

</div>

> [@mehmood1](#):
>
> `elasticsearch.host: ["http://172.xx.xx.x:9200"]`

typo... it should be `hosts` with an `s`... it is code, you need to be careful / exact

From the reference yml  
`elasticsearch.hosts: ["http://localhost:9200"]`

---

<div class="post-metadata">

**Author:** ![mehmood1](https://avatars.discourse-cdn.com/v4/letter/m/2acd7d/32.png) [@mehmood1](https://discuss.elastic.co/u/mehmood1)\
**Post date:** [November 10, 2021, 5:15am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/15 "2021-11-10T05:15:02Z")

</div>

@stephenb you are great...its working thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 8, 2021, 5:15am UTC](https://discuss.elastic.co/t/kibana-not-found-elasticsearch-host/288839/16 "2021-12-08T05:15:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
