# Kibana not found error when accessing Fleet on 8.0.0

**URL:** https://discuss.elastic.co/t/kibana-not-found-error-when-accessing-fleet-on-8-0-0/297827
**Category:** Kibana
**Created:** [February 22, 2022, 2:17am UTC](https://discuss.elastic.co/t/kibana-not-found-error-when-accessing-fleet-on-8-0-0/297827 "2022-02-22T02:17:40Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![samiusan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/samiusan/32/26120_2.png) [@samiusan](https://discuss.elastic.co/u/samiusan)
#### Post date: [February 22, 2022, 2:17am UTC](https://discuss.elastic.co/t/kibana-not-found-error-when-accessing-fleet-on-8-0-0/297827/1 "2022-02-22T02:17:40Z")

</div>

Hi,

I’ve recently started to upgrade my lab environment to 8.0.0.

After the upgrade I can no longer access the Fleet console under Kibana (Kibana -\> Management -\> Fleet). When accessing it I receive an error message of ‘Unable to initialise fleet - Kibana not found”

Below are some of the log messages I receive when looking at the server. Am stuck on how to progress here. Given I’m attempting to access the console via Kibana I’m not certain why it’s telling me Kibana is not found.

Pre upgrade the environment (Elasticsearch, Kibana, elastic-agent & beats) were all at 7.17. Elasticsearch, Kibana and Beats were all installed via Ubuntu App with Elasticsearch installed via TGZ archives. Fleet was deployed and accessible via Kibana pre-upgrade. Everything is running on self managed instances.

Elasticsearch was initially upgraded to 8.0.0 using apt and didn’t report any issues. Kibana was upgraded using the same method but then refused to start. Resolving the issue required doing a full clean followed by a fresh install of kibana. Kibana now starts and I can see logs being ingested from the elastic-agents - I just can’t access the console to continue the upgrade.

Interested in any suggestions on where to go next.

```auto
{"ecs":{"version":"8.0.0"},"@timestamp":"2022-02-19T01:41:31.352+00:00","message":"kibana not found","error":{"message":"kibana not found","type":"PackageNotFoundError","stack_trace":"PackageNotFoundError: kibana not found\n at Object.fetchFindLatestPackage (/usr/share/kibana/x-pack/plugins/fleet/server/services/epm/registry/index.js:86:11)\n at runMicrotasks (<anonymous>)\n at processTicksAndRejections (node:internal/process/task_queues:96:5)\n at async Promise.all (index 1)\n at getPackageInfo (/usr/share/kibana/x-pack/plugins/fleet/server/services/epm/packages/get.js:167:40)\n at upgradeManagedPackagePolicies (/usr/share/kibana/x-pack/plugins/fleet/server/services/managed_package_policies.js:41:25)\n at ensurePreconfiguredPackagesAndPolicies (/usr/share/kibana/x-pack/plugins/fleet/server/services/preconfiguration.js:339:39)\n at createSetupSideEffects (/usr/share/kibana/x-pack/plugins/fleet/server/services/setup.js:88:7)\n at awaitIfPending (/usr/share/kibana/x-pack/plugins/fleet/server/services/setup_utils.js:38:20)\n at /usr/share/kibana/x-pack/plugins/fleet/server/plugin.js:243:9"},"log":{"level":"WARN","logger":"plugins.fleet"},"process":{"pid":804}}
{"ecs":{"version":"8.0.0"},"@timestamp":"2022-02-19T01:41:34.113+00:00","message":"kibana not found","log":{"level":"ERROR","logger":"plugins.fleet"},"process":{"pid":804}}

```

Michael

---

<div class="post-metadata">

### Author: ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)
#### Post date: [February 22, 2022, 5:06pm UTC](https://discuss.elastic.co/t/kibana-not-found-error-when-accessing-fleet-on-8-0-0/297827/2 "2022-02-22T17:06:45Z")

</div>

You need to use the Fleet API to remove the packages Elasticsearch, Kibana and Logstash. They were experimental and not rolled out with 8.0

> [@Unable to initialize Fleet in v8.0.0](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968):
>
> I've just update a cluster from 7.17 to 8.0.0 and the Fleet app in Kibana doesn't work anymore. I'm running OnPrem on Linux/aarch64. Is this a known issue? Logs below: {"ecs":{"version":"8.0.0"},"@timestamp":"2022-02-11T11:34:08.907+01:00","message":"There is already an integration policy with the same name","log":{"level":"ERROR","logger":"plugins.fleet"},"process":{"pid":3542038}} {"ecs":{"version":"8.0.0"},"@timestamp":"2022-02-11T11:34:09.211+01:00","message":"Fleet setup failed","log":{…

---

<div class="post-metadata">

### Author: ![samiusan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/samiusan/32/26120_2.png) [@samiusan](https://discuss.elastic.co/u/samiusan)
#### Post date: [February 22, 2022, 9:10pm UTC](https://discuss.elastic.co/t/kibana-not-found-error-when-accessing-fleet-on-8-0-0/297827/3 "2022-02-22T21:10:45Z")

</div>

Thank you for that - that fixed the issue.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 22, 2022, 9:11pm UTC](https://discuss.elastic.co/t/kibana-not-found-error-when-accessing-fleet-on-8-0-0/297827/4 "2022-03-22T21:11:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
