# Kibana not IPv6 ready

**URL:** <https://discuss.elastic.co/t/kibana-not-ipv6-ready/45537>\
**Category:** Kibana\
**Created:** [March 27, 2016, 12:09pm UTC](https://discuss.elastic.co/t/kibana-not-ipv6-ready/45537 "2016-03-27T12:09:30Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![sspreitzer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sspreitzer/32/8711_2.png) [@sspreitzer](https://discuss.elastic.co/u/sspreitzer)\
**Post date:** [March 27, 2016, 12:09pm UTC](https://discuss.elastic.co/t/kibana-not-ipv6-ready/45537/1 "2016-03-27T12:09:31Z")

</div>

To me it looks like Kibana is not IPv6 ready.

The node im running elasticsearch and kibana on only has ipv6 addresses and kibana is failing while all ports are reachable.

```auto
Error: unhandled courier request error: No Living connections
handleError@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/kibana.bundle.js?v=9732:78871:23
AbstractReqProvider/AbstractReq.prototype.handleFailure@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/kibana.bundle.js?v=9732:78791:15
callClient/</<@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/kibana.bundle.js?v=9732:78685:14
callClient/<@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/kibana.bundle.js?v=9732:78683:10
processQueue@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/commons.bundle.js?v=9732:42357:29
scheduleProcessQueue/<@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/commons.bundle.js?v=9732:42373:28
$RootScopeProvider/this.$get</Scope.prototype.$eval@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/commons.bundle.js?v=9732:43601:17
$RootScopeProvider/this.$get</Scope.prototype.$digest@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/commons.bundle.js?v=9732:43412:16
$RootScopeProvider/this.$get</Scope.prototype.$evalAsync/<@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/commons.bundle.js?v=9732:43640:16
completeOutstandingRequest@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/commons.bundle.js?v=9732:33119:8
Browser/self.defer/timeoutId<@http://[2a02:168:7a0e:6:5054:ff:fe20:c1b8]:5601/bundles/commons.bundle.js?v=9732:33396:8

```

Open ports:

```auto
[root@elk ~]# lsof -i -n -P|grep java
java 5885 elasticsearch 92u IPv6 53666 0t0 TCP [::1]:9300 (LISTEN)
java 5885 elasticsearch 94u IPv6 53669 0t0 TCP 127.0.0.1:9300 (LISTEN)
java 5885 elasticsearch 95u IPv6 53670 0t0 TCP [2a02:168:7a0e:6:5054:ff:fe20:c1b8]:9300 (LISTEN)
java 5885 elasticsearch 112u IPv6 53761 0t0 TCP [::1]:9200 (LISTEN)
java 5885 elasticsearch 113u IPv6 53762 0t0 TCP 127.0.0.1:9200 (LISTEN)
java 5885 elasticsearch 114u IPv6 53763 0t0 TCP [2a02:168:7a0e:6:5054:ff:fe20:c1b8]:9200 (LISTEN)
[root@elk ~]# lsof -i -n -P|grep node
node 5943 kibana 10u IPv6 53745 0t0 TCP *:5601 (LISTEN)

```

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [March 28, 2016, 2:28pm UTC](https://discuss.elastic.co/t/kibana-not-ipv6-ready/45537/2 "2016-03-28T14:28:57Z")

</div>

Can you provide some of the logging from Elasticsearch and Kibana as they start up?

And what versions they are.

For Elasticsearch the logging that shows the listening info like;

```auto
[INFO][node] [Rancor] starting ...
[INFO][transport] [Rancor] publish_address {127.0.0.1:9300}, bound_addresses {127.0.0.1:9300}, {[::1]:9300}
[INFO][discovery] [Rancor] elasticsearch/p_QmNH9uTgaYWMDY4pNNwg
[INFO][cluster.service] [Rancor] new_master {Rancor}{p_QmNH9uTgaYWMDY4pNNwg}{127.0.0.1}{127.0.0.1:9300}, reason: zen-disco-join(elected_as_master, [0] joins received)
[INFO][http] [Rancor] publish_address {127.0.0.1:9200}, bound_addresses {127.0.0.1:9200}, {[::1]:9200}
[INFO][node] [Rancor] started
[INFO][license.plugin.core] [Rancor] license [f6efe33d-059b-43f4-b5ac-80a600a7696f] - valid
[ERROR][license.plugin.core] [Rancor]

```

And for Kibana (I stopped my Elasticsearch instance in this case);

```auto
 [info][listening] Server running at http://0.0.0.0:5601
 [error][elasticsearch] Request error, retrying -- connect ECONNREFUSED 127.0.0.1:9200
 [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
 [warning][elasticsearch] No living connections
 [error][status][plugin:elasticsearch] Status changed from yellow to red - Unable to connect to Elasticsearch at http://localhost:9200.
 [warning][elasticsearch] Unable to revive connection: http://localhost:9200/
 [warning][elasticsearch] No living connections

```

Thanks,  
Lee

---

<div class="post-metadata">

**Author:** ![tipene](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tipene/32/12715_2.png) [@tipene](https://discuss.elastic.co/u/tipene)\
**Post date:** [October 25, 2016, 2:02pm UTC](https://discuss.elastic.co/t/kibana-not-ipv6-ready/45537/3 "2016-10-25T14:02:52Z")

</div>

I'm using IPv6 exclusively for my setup:

ElasticSearch:

network.host: ::1

Kibana:

server.host: "localhost6"  
elasticsearch.url: "[http://localhost6:9200](http://localhost6:9200)"

Works fine.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:35pm UTC](https://discuss.elastic.co/t/kibana-not-ipv6-ready/45537/4 "2017-07-06T13:35:45Z")

</div>


