# Kibana Not Loading Results -- TypeError: Cannot read property 'length' of undefined

**URL:** <https://discuss.elastic.co/t/kibana-not-loading-results-typeerror-cannot-read-property-length-of-undefined/21824>\
**Category:** Elasticsearch\
**Created:** [January 26, 2015, 4:45am UTC](https://discuss.elastic.co/t/kibana-not-loading-results-typeerror-cannot-read-property-length-of-undefined/21824 "2015-01-26T04:45:58Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shawn\_Nicholas\_Stark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shawn_nicholas_stark/32/58516_2.png) [@Shawn\_Nicholas\_Stark](https://discuss.elastic.co/u/Shawn_Nicholas_Stark)\
**Post date:** [January 26, 2015, 4:45am UTC](https://discuss.elastic.co/t/kibana-not-loading-results-typeerror-cannot-read-property-length-of-undefined/21824/1 "2015-01-26T04:45:58Z")

</div>

Using kibana-3.0.0milestone4  
Cannot Load Data from elasticsearch with queries that work from shell  
Receive Error : TypeError: Cannot read property 'length' of undefined  
(Attached)  
ElasticSearch can be queried via the browser URL bar and terminal

The gist that shows exactly what data I am using and recreates the query  
from kibana.  
The query showed in the gist is working in the terminal localy and remotely  
(Attached with Results)

> <https://gist.github.com/anonymous/3f07f1bd9f0598bb5a0b>

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/8107baa4-83b6-42b4-a47d-a26cdba27baa%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/8107baa4-83b6-42b4-a47d-a26cdba27baa%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Shawn\_Nicholas\_Stark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shawn_nicholas_stark/32/58516_2.png) [@Shawn\_Nicholas\_Stark](https://discuss.elastic.co/u/Shawn_Nicholas_Stark)\
**Post date:** [January 26, 2015, 6:01am UTC](https://discuss.elastic.co/t/kibana-not-loading-results-typeerror-cannot-read-property-length-of-undefined/21824/2 "2015-01-26T06:01:04Z")

</div>

After simply opening the developer console in the browser my suspicions  
were qualified that there was a problem due to HTTPS.  
I am wondering why my browser did not give me a pop up as a warning that  
the page was attempting to request over an insecure connection.  
Steps I will take to correct this is : Check settings in browser in attempt  
to allow this request, add a new site in apache on a subdomain without a  
certificate,  
I will also have to bind elasticsearch to the IP dedicated to the  
subdomain. A couple more configuration setting and everything is a go.  
When in doubt check the development console. Error from console listed  
below .

Mixed Content: The page at

> ''[https://mysite.int/kibana/kibana-3.0.0milestone4/index.html#/dashboard/file/logstash.json](https://mysite.int/kibana/kibana-3.0.0milestone4/index.html#/dashboard/file/logstash.json)'  
> was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint  
> '[http://mysite.in:9200/\_nodes](http://mysite.in:9200/_nodes)'. This request has been blocked; the content  
> must be served over HTTPS.app.js?r=928332b:8 (anonymous function)

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/01b84757-fb76-4609-9672-445613aa2c66%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/01b84757-fb76-4609-9672-445613aa2c66%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Shital\_Patel](https://avatars.discourse-cdn.com/v4/letter/s/94ad74/32.png) [@Shital\_Patel](https://discuss.elastic.co/u/Shital_Patel)\
**Post date:** [February 17, 2015, 10:01pm UTC](https://discuss.elastic.co/t/kibana-not-loading-results-typeerror-cannot-read-property-length-of-undefined/21824/3 "2015-02-17T22:01:39Z")

</div>

What was the solution. I have the same issue. I am running a nginx proxy  
which redirects all http traffic to https and then kibana is complaining  
that the request was https and we are trying to get elasticsearch over http.

thanks

On Sunday, January 25, 2015 at 8:45:58 PM UTC-8, Shawn Nicholas Stark wrote:

> Using kibana-3.0.0milestone4  
> Cannot Load Data from elasticsearch with queries that work from shell  
> Receive Error : TypeError: Cannot read property 'length' of undefined  
> (Attached)  
> Elasticsearch can be queried via the browser URL bar and terminal
> 
> The gist that shows exactly what data I am using and recreates the query  
> from kibana.  
> The query showed in the gist is working in the terminal localy and  
> remotely (Attached with Results)  
> [Kibana is giving the error -- TypeError: Cannot read property 'length' of undefined -- This is a search generated by kibana for the panel receiving error, it is working for me in the terminal for both remote and local curl requests generating the expected results. · GitHub](https://gist.github.com/anonymous/3f07f1bd9f0598bb5a0b)

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/3d3b1461-650d-4e70-af93-5f73d89b1b0b%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3d3b1461-650d-4e70-af93-5f73d89b1b0b%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Shawn\_Nicholas\_Stark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shawn_nicholas_stark/32/58516_2.png) [@Shawn\_Nicholas\_Stark](https://discuss.elastic.co/u/Shawn_Nicholas_Stark)\
**Post date:** [February 20, 2015, 6:05pm UTC](https://discuss.elastic.co/t/kibana-not-loading-results-typeerror-cannot-read-property-length-of-undefined/21824/4 "2015-02-20T18:05:09Z")

</div>

An easy work around is to request Elasticsearch under a sub-domain that is  
not configured for https. If there is a documented way to change the  
request from kibana from http to https I as of yet have not found it,  
however it could be as simple as changing the base url structure somewhere  
in kibana and setting up a reverse proxy from apache or nginx to the  
elasticsearch server, that should allow you to setup client certificates  
and https as per usual with apache or nginx.

On Tuesday, February 17, 2015 at 4:01:40 PM UTC-6, Shital Patel wrote:

> What was the solution. I have the same issue. I am running a nginx proxy  
> which redirects all http traffic to https and then kibana is complaining  
> that the request was https and we are trying to get elasticsearch over http.
> 
> thanks
> 
> On Sunday, January 25, 2015 at 8:45:58 PM UTC-8, Shawn Nicholas Stark  
> wrote:
> 
> > Using kibana-3.0.0milestone4  
> > Cannot Load Data from elasticsearch with queries that work from shell  
> > Receive Error : TypeError: Cannot read property 'length' of undefined  
> > (Attached)  
> > Elasticsearch can be queried via the browser URL bar and terminal
> > 
> > The gist that shows exactly what data I am using and recreates the query  
> > from kibana.  
> > The query showed in the gist is working in the terminal localy and  
> > remotely (Attached with Results)  
> > [Kibana is giving the error -- TypeError: Cannot read property 'length' of undefined -- This is a search generated by kibana for the panel receiving error, it is working for me in the terminal for both remote and local curl requests generating the expected results. · GitHub](https://gist.github.com/anonymous/3f07f1bd9f0598bb5a0b)

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/922d3fc9-9518-44ac-82d4-4bbf970c4657%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/922d3fc9-9518-44ac-82d4-4bbf970c4657%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Shawn\_Nicholas\_Stark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shawn_nicholas_stark/32/58516_2.png) [@Shawn\_Nicholas\_Stark](https://discuss.elastic.co/u/Shawn_Nicholas_Stark)\
**Post date:** [February 20, 2015, 6:08pm UTC](https://discuss.elastic.co/t/kibana-not-loading-results-typeerror-cannot-read-property-length-of-undefined/21824/5 "2015-02-20T18:08:15Z")

</div>

An easy work around is to request kibana under a sub-domain that is not  
configured for https. If there is a documented way to change the request  
from kibana from http to https I as of yet have not found it, however it  
could be as simple as changing the base url structure somewhere in kibana  
and setting up a reverse proxy from apache or nginx to the elasticsearch  
server (you would also have to serve kibana under https), that should allow  
you to setup client certificates and https as per usual with apache or  
nginx.

On Tuesday, February 17, 2015 at 4:01:40 PM UTC-6, Shital Patel wrote:

> What was the solution. I have the same issue. I am running a nginx proxy  
> which redirects all http traffic to https and then kibana is complaining  
> that the request was https and we are trying to get elasticsearch over http.
> 
> thanks
> 
> On Sunday, January 25, 2015 at 8:45:58 PM UTC-8, Shawn Nicholas Stark  
> wrote:
> 
> > Using kibana-3.0.0milestone4  
> > Cannot Load Data from elasticsearch with queries that work from shell  
> > Receive Error : TypeError: Cannot read property 'length' of undefined  
> > (Attached)  
> > Elasticsearch can be queried via the browser URL bar and terminal
> > 
> > The gist that shows exactly what data I am using and recreates the query  
> > from kibana.  
> > The query showed in the gist is working in the terminal localy and  
> > remotely (Attached with Results)  
> > [Kibana is giving the error -- TypeError: Cannot read property 'length' of undefined -- This is a search generated by kibana for the panel receiving error, it is working for me in the terminal for both remote and local curl requests generating the expected results. · GitHub](https://gist.github.com/anonymous/3f07f1bd9f0598bb5a0b)

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/563ac3e3-cabb-42f7-86a6-ae402fbe0573%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/563ac3e3-cabb-42f7-86a6-ae402fbe0573%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:31am UTC](https://discuss.elastic.co/t/kibana-not-loading-results-typeerror-cannot-read-property-length-of-undefined/21824/6 "2017-07-06T00:31:10Z")

</div>


