# Kibana not starting up

**URL:** <https://discuss.elastic.co/t/kibana-not-starting-up/113365>\
**Category:** Kibana\
**Created:** [December 27, 2017, 9:15pm UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365 "2017-12-27T21:15:57Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![robov](https://avatars.discourse-cdn.com/v4/letter/r/9dc877/32.png) [@robov](https://discuss.elastic.co/u/robov)\
**Post date:** [December 27, 2017, 9:15pm UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/1 "2017-12-27T21:15:57Z")

</div>

I am trying to run a stack on my ubuntu docker system, and I tried many different containers but I simply cannot get it to work.  
The last one i tried,,, hence this discussion is :elastic/stack-docker  
When I run that.. I cannot even het kibana to showup on the port 5601  
It was suggested to increase the memory, but how do I do that on an ubuntu machine ? I thought docker had to complete memory

Any ideas why kibana does not show its dashboard ?

{"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["status","plugin:kibana@6.1.0","info"],"pid":1,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":" uninitialized","prevMsg":"uninitialized"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["status","plugin:elasticsearch@6.1.0","info"],"pid":1,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["error","elasticsearch","admin"],"pid":1,"message":"Request error, retrying\nHEAD [http://elasticsearch:9200/](http://elasticsearch:9200/) =\> connect ECONNREFUSED 172.21 .0.2:9200"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["status","plugin:xpack\_main@6.1.0","info"],"pid":1,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for El asticsearch","prevState":"uninitialized","prevMsg":"uninitialized"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"Unable to revive connection: [http://elasticsearch:9200/](http://elasticsearch:9200/)"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"No living connections"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["status","plugin:graph@6.1.0","info"],"pid":1,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elastic search","prevState":"uninitialized","prevMsg":"uninitialized"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["status","plugin:xpack\_main@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from yellow to red - Unable to connect to Elast icsearch at [http://elasticsearch:9200](http://elasticsearch:9200).","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["status","plugin:graph@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from yellow to red - Unable to connect to Elasticsea rch at [http://elasticsearch:9200](http://elasticsearch:9200).","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["status","plugin:elasticsearch@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from yellow to red - Unable to connect to El asticsearch at [http://elasticsearch:9200](http://elasticsearch:9200).","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["error","elasticsearch","data"],"pid":1,"message":"Request error, retrying\nGET [http://elasticsearch:9200/\_xpack](http://elasticsearch:9200/_xpack) =\> connect ECONNREFUSED 17 2.21.0.2:9200"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["status","plugin:monitoring@6.1.0","info"],"pid":1,"state":"green","message":"Status changed from uninitialized to green - Ready","prevStat e":"uninitialized","prevMsg":"uninitialized"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["warning","elasticsearch","data"],"pid":1,"message":"Unable to revive connection: [http://elasticsearch:9200/](http://elasticsearch:9200/)"} {"type":"log","@timestamp":"2017-12-26T09:28:05Z","tags":["warning","elasticsearch","data"],"pid":1,"message":"No living connections"} {"type":"log","@timestamp":"2017-12-26T09:28:13Z","tags":["reporting","warning"],"pid":1,"message":"Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failin g on restart, please set xpack.reporting.encryptionKey in kibana.yml"} {"type":"log","@timestamp":"2017-12-26T09:28:13Z","tags":["status","plugin:reporting@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from uninitialized to red - Unable to connect to Elasticsearch at [http://elasticsearch:9200](http://elasticsearch:9200).","prevState":"uninitialized","prevMsg":"uninitialized"} {"type":"log","@timestamp":"2017-12-26T09:28:13Z","tags":["license","warning","xpack"],"pid":1,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. Error: No Living connections"} {"type":"log","@timestamp":"2017-12-26T09:28:13Z","tags":["status","plugin:xpack\_main@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from red to red - No Living connections","prevS tate":"red","prevMsg":"Unable to connect to Elasticsearch at [http://elasticsearch:9200](http://elasticsearch:9200)."} {"type":"log","@timestamp":"2017-12-26T09:28:13Z","tags":["status","plugin:graph@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from red to red - No Living connections","prevState" :"red","prevMsg":"Unable to connect to Elasticsearch at [http://elasticsearch:9200](http://elasticsearch:9200)."} {"type":"log","@timestamp":"2017-12-26T09:28:13Z","tags":["status","plugin:reporting@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from red to red - No Living connections","prevSt ate":"red","prevMsg":"Unable to connect to Elasticsearch at [http://elasticsearch:9200](http://elasticsearch:9200)."} {"type":"log","@timestamp":"2017-12-26T09:28:13Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"Unable to revive connection: [http://elasticsearch:9200/](http://elasticsearch:9200/)"} {"type":"log","@timestamp":"2017-12-26T09:28:13Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"No living connections"} {"type":"log","@timestamp":"2017-12-26T09:28:19Z","tags":["status","plugin:xpack\_main@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from red to red - Request Timeout after 3000ms" ,"prevState":"red","prevMsg":"No Living connections"} {"type":"log","@timestamp":"2017-12-26T09:28:19Z","tags":["status","plugin:graph@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from red to red - Request Timeout after 3000ms","pre vState":"red","prevMsg":"No Living connections"} {"type":"log","@timestamp":"2017-12-26T09:28:19Z","tags":["status","plugin:reporting@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from red to red - Request Timeout after 3000ms", "prevState":"red","prevMsg":"No Living connections"} {"type":"log","@timestamp":"2017-12-26T09:28:19Z","tags":["status","plugin:elasticsearch@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from red to red - Request Timeout after 3000 ms","prevState":"red","prevMsg":"Unable to connect to Elasticsearch at [http://elasticsearch:9200](http://elasticsearch:9200)."} {"type":"log","@timestamp":"2017-12-26T09:28:21Z","tags":

---

<div class="post-metadata">

**Author:** ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)\
**Post date:** [December 27, 2017, 9:22pm UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/2 "2017-12-27T21:22:20Z")

</div>

Kibana's trying to connect to elasticsearch but it can't find it. Do you have elasticsearch running in a container too and can you share your docker network config?

Can you share your install steps, I can try and reproduce it. Memory should be fine, the docker images come pre-bundled so you'll only need ~200mb to run the server.

---

<div class="post-metadata">

**Author:** ![robov](https://avatars.discourse-cdn.com/v4/letter/r/9dc877/32.png) [@robov](https://discuss.elastic.co/u/robov)\
**Post date:** [December 28, 2017, 7:30am UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/3 "2017-12-28T07:30:12Z")

</div>

I am using exactly this set: [https://github.com/elastic/stack-docker](https://github.com/elastic/stack-docker)

Your assistance is greatly appreciated.... as trying to setup the elk stack is driving me nuts now....

---

<div class="post-metadata">

**Author:** ![robov](https://avatars.discourse-cdn.com/v4/letter/r/9dc877/32.png) [@robov](https://discuss.elastic.co/u/robov)\
**Post date:** [December 28, 2017, 7:37am UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/4 "2017-12-28T07:37:29Z")

</div>

This is also in the kibana logs :  
{"type":"log","@timestamp":"2017-12-28T07:32:59Z","tags":["error","elasticsearch","admin"],"pid":1,"message":"Request error, retrying\nHEAD [http://elasticsearch:9200/](http://elasticsearch:9200/) =\> connect ECONNREFUSED 172.21.0.2:9200"}

---

<div class="post-metadata">

**Author:** ![robov](https://avatars.discourse-cdn.com/v4/letter/r/9dc877/32.png) [@robov](https://discuss.elastic.co/u/robov)\
**Post date:** [December 28, 2017, 8:17am UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/5 "2017-12-28T08:17:36Z")

</div>

When I do this from outside my docker containers

`curl -u elastic:changeme http://elasticsearch:9200`  
I get :  
`curl: (6) Could not resolve host: elasticsearch`

when I do  
`curl -u elastic:changeme http://172.21.0.2:9200`  
then I get the version information back

maybe this helps....

---

<div class="post-metadata">

**Author:** ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)\
**Post date:** [December 28, 2017, 7:07pm UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/6 "2017-12-28T19:07:04Z")

</div>

I was able to reproduce this, looks like a bug. I filed [https://github.com/elastic/stack-docker/issues/21](https://github.com/elastic/stack-docker/issues/21).

---

<div class="post-metadata">

**Author:** ![xeraa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xeraa/32/48181_2.png) [@xeraa](https://discuss.elastic.co/u/xeraa)\
**Post date:** [December 28, 2017, 8:46pm UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/7 "2017-12-28T20:46:38Z")

</div>

This is how [user-defined networks work in Docker](https://docs.docker.com/engine/userguide/networking/#user-defined-networks). You can actually take a look at the networking setup created by the _docker-compose_ file:

- Run `docker network ls`
- Copy the ID of the network `stackdocker_stack`
- Run `docker network inspect <ID>`

From your host you can access Elasticsearch and Kibana on 127.0.0.1 or localhost (with the respective port). Inside the Docker network, you can access them with the [internal DNS names](https://docs.docker.com/engine/userguide/networking/configure-dns/), which comes down to _elasticsearch_ and _kibana_.

Now coming back to your original issue:

1. You only need to [increase the memory allocated to the Docker daemon on Mac and Windows](https://github.com/elastic/stack-docker#prerequisites). Since you're on Linux, you don't have to do anything, but you need to have enough memory available. **Do you have 4GB of memory just for the containers?** Lack of RAM is the most common reason we see for Kibana not coming up correctly.
2. The logs you're showing are for 25s or so. I doubt this is enough for the entire stack to come up, configure itself, and reach a stable status. **Please show enough logs until the stack has finished starting up (I'd estimate at least 2min)** if Elasticsearch is running fine; otherwise we'd have to start with Elasticsearch.

PS: Docker looks very simple to get started with, however it adds a lot of complexity that is initially hidden. If you are not too familiar with Docker, I would try to get started without it, since it will double the learning curve.

---

<div class="post-metadata">

**Author:** ![robov](https://avatars.discourse-cdn.com/v4/letter/r/9dc877/32.png) [@robov](https://discuss.elastic.co/u/robov)\
**Post date:** [December 29, 2017, 2:33pm UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/8 "2017-12-29T14:33:56Z")

</div>

Great that it worked for you.... can you assist me in getting to to work on my ubuntu ?

---

<div class="post-metadata">

**Author:** ![xeraa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xeraa/32/48181_2.png) [@xeraa](https://discuss.elastic.co/u/xeraa)\
**Post date:** [December 30, 2017, 12:12am UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/9 "2017-12-30T00:12:29Z")

</div>

See my post directly above. The 2 points about memory and logs are for your problem.

---

<div class="post-metadata">

**Author:** ![robov](https://avatars.discourse-cdn.com/v4/letter/r/9dc877/32.png) [@robov](https://discuss.elastic.co/u/robov)\
**Post date:** [December 30, 2017, 8:01am UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/10 "2017-12-30T08:01:51Z")

</div>

I dove a little deeper... even though I have 3.8G of memory... there is not alot of free mem left... let me test releasing some mem

---

<div class="post-metadata">

**Author:** ![robov](https://avatars.discourse-cdn.com/v4/letter/r/9dc877/32.png) [@robov](https://discuss.elastic.co/u/robov)\
**Post date:** [December 31, 2017, 1:07pm UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/11 "2017-12-31T13:07:49Z")

</div>

After killing all my existing containers I now have 3G free mem...  
Kibana is still not coming up  
First 5 min Error logs are below  
First 5 min complete log... how can I send that to you ?

{"type":"log","@timestamp":"2017-12-31T12:09:11Z","tags":["error","elasticsearch","admin"],"pid":1,"message":"Request error, retrying\nHEAD [http://elasticsearch:9200/](http://elasticsearch:9200/) =\> connect ECONNREFUSED 172.21.0.2:9200"}  
{"type":"log","@timestamp":"2017-12-31T12:09:11Z","tags":["status","plugin:xpack\_main@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from yellow to red - Unable to connect to Elasticsearch at [http://elasticsearch:9200](http://elasticsearch:9200).","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}  
{"type":"log","@timestamp":"2017-12-31T12:09:11Z","tags":["status","plugin:graph@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from yellow to red - Unable to connect to Elasticsearch at [http://elasticsearch:9200](http://elasticsearch:9200).","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}  
{"type":"log","@timestamp":"2017-12-31T12:09:11Z","tags":["status","plugin:elasticsearch@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from yellow to red - Unable to connect to Elasticsearch at [http://elasticsearch:9200](http://elasticsearch:9200).","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}  
{"type":"log","@timestamp":"2017-12-31T12:09:11Z","tags":["error","elasticsearch","data"],"pid":1,"message":"Request error, retrying\nGET [http://elasticsearch:9200/\_xpack](http://elasticsearch:9200/_xpack) =\> connect ECONNREFUSED 172.21.0.2:9200"}  
{"type":"log","@timestamp":"2017-12-31T12:09:11Z","tags":["status","plugin:xpack\_main@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from red to red - No Living connections","prevState":"red","prevMsg":"Unable to connect to Elasticsearch at [http://elasticsearch:9200](http://elasticsearch:9200)."}  
{"type":"log","@timestamp":"2017-12-31T12:09:11Z","tags":["status","plugin:graph@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from red to red - No Living connections","prevState":"red","prevMsg":"Unable to connect to Elasticsearch at [http://elasticsearch:9200](http://elasticsearch:9200)."}  
{"type":"log","@timestamp":"2017-12-31T12:09:19Z","tags":["status","plugin:reporting@6.1.0","error"],"pid":1,"state":"red","message":"Status changed from uninitialized to red - No Living connections","prevState":"uninitialized","prevMsg":"uninitialized"}

---

<div class="post-metadata">

**Author:** ![robov](https://avatars.discourse-cdn.com/v4/letter/r/9dc877/32.png) [@robov](https://discuss.elastic.co/u/robov)\
**Post date:** [December 31, 2017, 3:24pm UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/12 "2017-12-31T15:24:18Z")

</div>

brainwave...  
The official docker elk stack sepb/elk (or something like that) runs even when all my containers are there.. so with very little memory... So I guess it is not just the memory

---

<div class="post-metadata">

**Author:** ![robov](https://avatars.discourse-cdn.com/v4/letter/r/9dc877/32.png) [@robov](https://discuss.elastic.co/u/robov)\
**Post date:** [January 10, 2018, 7:14am UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/13 "2018-01-10T07:14:09Z")

</div>

any updates on this one ?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 7, 2018, 7:14am UTC](https://discuss.elastic.co/t/kibana-not-starting-up/113365/14 "2018-02-07T07:14:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
