# Kibana not working properly

**URL:** <https://discuss.elastic.co/t/kibana-not-working-properly/346028>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [October 30, 2023, 11:13am UTC](https://discuss.elastic.co/t/kibana-not-working-properly/346028 "2023-10-30T11:13:28Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![chatim](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chatim/32/78696_2.png) [@chatim](https://discuss.elastic.co/u/chatim)\
**Post date:** [October 30, 2023, 11:13am UTC](https://discuss.elastic.co/t/kibana-not-working-properly/346028/1 "2023-10-30T11:13:28Z")

</div>

Hello,  
I'm running a dockerized elastic cluster composed of 3 master and 3 data nodes on AWS instances, using rsyslog and logstash, i collect and store syslog events on elasticsearch index.  
till now everything was good until trying to build a vizualization dashboard on kibana.  
working on kibana i notice that the request take too much time (even on a small number of syslog message 'less than 5000 records').  
The following error 'Loading chunk 20 failed.' is repeated a lot.

 ![kibana-error](https://us1.discourse-cdn.com/elastic/original/3X/e/6/e6aca0a255611e4074ce4239a00752ab3a9518ab.png)

The dashboard shows data once, and throws errors many times.

 ![dash-error](https://us1.discourse-cdn.com/elastic/original/3X/2/d/2db3c5ad40cc7740fb265779690bdec8c4e58d68.png)

and

 ![dash-error-2](https://us1.discourse-cdn.com/elastic/original/3X/3/2/3261d048f897c42d620b9888506dee7da84988a5.png)

syslog event are stored as the following schema :

 ![record](https://us1.discourse-cdn.com/elastic/original/3X/3/f/3ff894ff0228746507a37fc1fb48b1a2a2834d72.png)

No error logs on both side, kibana and elastic server.  
I tried many suggestion found on the internet :

- index re-create.
- re-deploy kibana on new EC2 instance.
- re-configure kibana.

i'm ready to provide any other further info could help to resolve this issue.

I appreciate any help from you. Thanks in advance.

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [October 31, 2023, 11:25am UTC](https://discuss.elastic.co/t/kibana-not-working-properly/346028/2 "2023-10-31T11:25:17Z")

</div>

Hi @chatim,

Which version of Elasticsearch and Kibana are you using?

---

<div class="post-metadata">

**Author:** ![chatim](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chatim/32/78696_2.png) [@chatim](https://discuss.elastic.co/u/chatim)\
**Post date:** [October 31, 2023, 1:34pm UTC](https://discuss.elastic.co/t/kibana-not-working-properly/346028/3 "2023-10-31T13:34:28Z")

</div>

Hi @carly.richmond ,  
currently i'm using the following version :

- ES : **8.10.0**
- Logstash : 8.10.0
- Kibana : **8.10.0-1**

P.S : same issue was also with version **8.9.0**.

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [November 2, 2023, 2:45pm UTC](https://discuss.elastic.co/t/kibana-not-working-properly/346028/4 "2023-11-02T14:45:02Z")

</div>

Thanks for confirming. Are you using any plugins at all?

---

<div class="post-metadata">

**Author:** ![chatim](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chatim/32/78696_2.png) [@chatim](https://discuss.elastic.co/u/chatim)\
**Post date:** [November 2, 2023, 3:43pm UTC](https://discuss.elastic.co/t/kibana-not-working-properly/346028/5 "2023-11-02T15:43:03Z")

</div>

No plugin used till now, fresh deployement.

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [November 3, 2023, 8:46am UTC](https://discuss.elastic.co/t/kibana-not-working-properly/346028/6 "2023-11-03T08:46:31Z")

</div>

> [@chatim](#):
>
> No plugin used till now, fresh deployement.

It sounds like you're recently installed a plugin? Did the issues start when you installed a particular plugin? Which plugin have you installed?

---

<div class="post-metadata">

**Author:** ![chatim](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chatim/32/78696_2.png) [@chatim](https://discuss.elastic.co/u/chatim)\
**Post date:** [November 4, 2023, 2:51pm UTC](https://discuss.elastic.co/t/kibana-not-working-properly/346028/7 "2023-11-04T14:51:22Z")

</div>

@carly.richmond no plugin installed.i really appreciate your help.  
the good news is that the issue fixed, and cannot believe that the cause of all this pain was Nginx 😕 even (basic nginx config), after setting header "connection" to "upgrade" everything works nice.

```auto
proxy_set_header Connection 'upgrade';

```

unset header, issue return.  
Hope that help others suffering same issue.

---

<div class="post-metadata">

**Author:** ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)\
**Post date:** [November 6, 2023, 9:56am UTC](https://discuss.elastic.co/t/kibana-not-working-properly/346028/8 "2023-11-06T09:56:03Z")

</div>

Thanks for sharing the solution for others @chatim! Glad you got things working.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 4, 2023, 9:56am UTC](https://discuss.elastic.co/t/kibana-not-working-properly/346028/9 "2023-12-04T09:56:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
