# Kibana on localhost still requires an active Internet connection?

**URL:** <https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749>\
**Category:** Kibana\
**Created:** [March 17, 2016, 6:06pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749 "2016-03-17T18:06:38Z")\
**Posts on this page:** 16\
**Page:** 1

<div class="post-metadata">

**Author:** ![johncst](https://avatars.discourse-cdn.com/v4/letter/j/8baadc/32.png) [@johncst](https://discuss.elastic.co/u/johncst)\
**Post date:** [March 17, 2016, 6:06pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/1 "2016-03-17T18:06:38Z")

</div>

I'm new and trying to install Elasticsearch and Kibana on the same Windows 10 computer without an active Internet connection. Elasticsearch seems to work OK, but Kibana can't find Elasticsearch on the same host without an active Internet connection. Is this correct? If so, why should the Internet be needed if both Elasticsearch and Kibana are on the same host, and both configured to use "localhost"?

Below is output from Kibana showing that it cannot connect to Elasticsearch, and then at the bottom an Internet connection is activated, and Kibana connects to Elasticsearch. Any thoughts?

C:\kibana\>bin\kibana  
log [10:59:13.981] [info][status][plugin:kibana] Status changed from uninitialized to green - Ready  
log [10:59:14.012] [info][status][plugin:elasticsearch] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [10:59:14.028] [info][status][plugin:kbn\_vislib\_vis\_types] Status changed from uninitialized to green - Ready  
log [10:59:14.028] [error][elasticsearch] Request error, retrying -- getaddrinfo ENOENT localhost:9200  
log [10:59:14.028] [info][status][plugin:markdown\_vis] Status changed from uninitialized to green - Ready  
log [10:59:14.043] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [10:59:14.043] [warning][elasticsearch] No living connections  
log [10:59:14.043] [error][status][plugin:elasticsearch] Status changed from yellow to red - Unable to connect to Elasticsearch at [http://localhost:9200](http://localhost:9200).  
log [10:59:14.043] [info][status][plugin:metric\_vis] Status changed from uninitialized to green - Ready  
log [10:59:14.059] [info][status][plugin:spyModes] Status changed from uninitialized to green - Ready  
log [10:59:14.059] [info][status][plugin:statusPage] Status changed from uninitialized to green - Ready  
log [10:59:14.059] [info][status][plugin:table\_vis] Status changed from uninitialized to green - Ready  
log [10:59:14.074] [info][listening] Server running at [http://localhost:5601](http://localhost:5601)  
log [10:59:16.552] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [10:59:16.552] [warning][elasticsearch] No living connections  
log [10:59:19.051] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [10:59:19.051] [warning][elasticsearch] No living connections  
log [10:59:21.551] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [10:59:21.551] [warning][elasticsearch] No living connections  
log [10:59:24.059] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [10:59:24.059] [warning][elasticsearch] No living connections  
log [10:59:26.560] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [10:59:26.560] [warning][elasticsearch] No living connections  
log [10:59:29.071] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [10:59:29.071] [warning][elasticsearch] No living connections  
log [10:59:31.578] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [10:59:31.578] [warning][elasticsearch] No living connections  
log [10:59:34.090] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [10:59:34.090] [warning][elasticsearch] No living connections  
log [10:59:36.597] [warning][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [10:59:36.597] [warning][elasticsearch] No living connections  
log [10:59:39.183] [info][status][plugin:elasticsearch] Status changed from red to green - Kibana index ready

---

<div class="post-metadata">

**Author:** ![Court](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/court/32/6640_2.png) [@Court](https://discuss.elastic.co/u/Court)\
**Post date:** [March 17, 2016, 6:43pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/2 "2016-03-17T18:43:59Z")

</div>

That's a strange one! If your internet connection is disabled, can you access [http://localhost:9200](http://localhost:9200) in your browser?

---

<div class="post-metadata">

**Author:** ![johncst](https://avatars.discourse-cdn.com/v4/letter/j/8baadc/32.png) [@johncst](https://discuss.elastic.co/u/johncst)\
**Post date:** [March 17, 2016, 8:41pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/3 "2016-03-17T20:41:16Z")

</div>

Yes, everything I do to Elasticsearch seems to operate normally. [http://localhost:9200](http://localhost:9200) returns the expected json record.

I've played with it a bit, and it is very reproducible. If the Internet connection is disabled, you get "no living connections" from Kibana. Activate an Internet connection, Kibana works fine. As I said, this is under Windows 10. I've not tried it under Linux yet, however if this were a Windows TCP/IP stack issue, I would expect [http://localhost:9200](http://localhost:9200) from a browser to fail also.

An interesting problem, but if anyone wants to air-gap sensitive data, this might be an issue.

---

<div class="post-metadata">

**Author:** ![Court](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/court/32/6640_2.png) [@Court](https://discuss.elastic.co/u/Court)\
**Post date:** [March 17, 2016, 8:51pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/4 "2016-03-17T20:51:54Z")

</div>

That is so strange... I definitely run Kibana all of the time without an internet connection (albeit not on Windows). Complete shot in the dark, but does it work if you point to an IP instead of a hostname? Something like:

elasticsearch.url: "[http://127.0.0.1:9200](http://127.0.0.1:9200)"

---

<div class="post-metadata">

**Author:** ![johncst](https://avatars.discourse-cdn.com/v4/letter/j/8baadc/32.png) [@johncst](https://discuss.elastic.co/u/johncst)\
**Post date:** [March 17, 2016, 9:19pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/5 "2016-03-17T21:19:00Z")

</div>

Yes, [http://127.0.0.1:9200](http://127.0.0.1:9200) works fine. I'm assuming when you say you run without an Internet connection, you are running under Linux? My Linux box is in a different location, so if you've already done that test, I don't need to repeat it. Strange...

---

<div class="post-metadata">

**Author:** ![Court](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/court/32/6640_2.png) [@Court](https://discuss.elastic.co/u/Court)\
**Post date:** [March 17, 2016, 9:24pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/6 "2016-03-17T21:24:47Z")

</div>

Correct, I've run it on both linux and darwin without internet connections without issue. I wonder if Windows 10 is doing some sort of forced DNS lookup even when using localhost...

---

<div class="post-metadata">

**Author:** ![yahoo](https://avatars.discourse-cdn.com/v4/letter/y/898d66/32.png) [@yahoo](https://discuss.elastic.co/u/yahoo)\
**Post date:** [March 19, 2016, 7:09pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/7 "2016-03-19T19:09:30Z")

</div>

I have kibana running on two windows 10 machines locally.  
(2 different projects).  
One of them decided two days ago that it can't reach elastic url localhost:9200 unless the internet connection is active.  
The other one still connects without internet connection!  
Any clue?

---

<div class="post-metadata">

**Author:** ![yahoo](https://avatars.discourse-cdn.com/v4/letter/y/898d66/32.png) [@yahoo](https://discuss.elastic.co/u/yahoo)\
**Post date:** [March 24, 2016, 8:17pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/8 "2016-03-24T20:17:35Z")

</div>

Hi @johncst @Court  
I still have this problem.  
in the configure yml file of kibana I changed the url to 127.0.0.1 ,  
however the problem persists.  
Did you figure out how to solve it?

---

<div class="post-metadata">

**Author:** ![yahoo](https://avatars.discourse-cdn.com/v4/letter/y/898d66/32.png) [@yahoo](https://discuss.elastic.co/u/yahoo)\
**Post date:** [March 30, 2016, 6:52pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/9 "2016-03-30T18:52:01Z")

</div>

Any solution please.

---

<div class="post-metadata">

**Author:** ![johncst](https://avatars.discourse-cdn.com/v4/letter/j/8baadc/32.png) [@johncst](https://discuss.elastic.co/u/johncst)\
**Post date:** [March 31, 2016, 12:38am UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/10 "2016-03-31T00:38:19Z")

</div>

I have not solved the problem. I had to get moving on the remaining ELK work, so I simply connected to the Internet to get Kibana working. I do plan to get back to this issue. Sorry I couldn't be of more immediate help.

---

<div class="post-metadata">

**Author:** ![Vlad\_L](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vlad_l/32/14495_2.png) [@Vlad\_L](https://discuss.elastic.co/u/Vlad_L)\
**Post date:** [January 15, 2017, 8:24pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/11 "2017-01-15T20:24:10Z")

</div>

Any solution here? I have the latest ES and Kibana 5.1.2 and have exactly the same issue. I am on the go and there is no internet in the plane or in some airports.  
I run on latest Windows 10 x64

---

<div class="post-metadata">

**Author:** ![Ocean](https://avatars.discourse-cdn.com/v4/letter/o/13edae/32.png) [@Ocean](https://discuss.elastic.co/u/Ocean)\
**Post date:** [June 8, 2017, 6:42pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/12 "2017-06-08T18:42:52Z")

</div>

I am facing same problem; anyone found solution yet. I cannot connect to internet while on the go with laptop.

---

<div class="post-metadata">

**Author:** ![devprakash](https://avatars.discourse-cdn.com/v4/letter/d/bcef8e/32.png) [@devprakash](https://discuss.elastic.co/u/devprakash)\
**Post date:** [June 16, 2017, 4:04pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/13 "2017-06-16T16:04:55Z")

</div>

I am also getting the same issue as mentioned above.. could you please give the solution..

---

<div class="post-metadata">

**Author:** ![Court](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/court/32/6640_2.png) [@Court](https://discuss.elastic.co/u/Court)\
**Post date:** [September 6, 2017, 1:24pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/14 "2017-09-06T13:24:01Z")

</div>

I'm not sure what the issue is, exactly, but you should be able to get Kibana running locally in that setup by setting the following in your kibana.yml:

```auto
elasticsearch.url: "http://127.0.0.1:9200"

```

---

<div class="post-metadata">

**Author:** ![devprakash](https://avatars.discourse-cdn.com/v4/letter/d/bcef8e/32.png) [@devprakash](https://discuss.elastic.co/u/devprakash)\
**Post date:** [September 6, 2017, 1:41pm UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/15 "2017-09-06T13:41:52Z")

</div>

Thanks for your response. I will check and let you know.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 4, 2022, 4:16am UTC](https://discuss.elastic.co/t/kibana-on-localhost-still-requires-an-active-internet-connection/44749/17 "2022-11-04T04:16:45Z")

</div>


