# Kibana only working over local

**URL:** <https://discuss.elastic.co/t/kibana-only-working-over-local/182421>\
**Category:** Kibana\
**Created:** [May 23, 2019, 11:57am UTC](https://discuss.elastic.co/t/kibana-only-working-over-local/182421 "2019-05-23T11:57:59Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Junx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/junx/32/46718_2.png) [@Junx](https://discuss.elastic.co/u/Junx)\
**Post date:** [May 23, 2019, 11:57am UTC](https://discuss.elastic.co/t/kibana-only-working-over-local/182421/1 "2019-05-23T11:57:59Z")

</div>

> Content Security Policy: The page's settings blocked the loading of a resource at inline ("script-src").

Constantly get this error and cannot solve it, this happens whenever i try to access from a reverse proxy

---

<div class="post-metadata">

**Author:** ![LeeDr](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leedr/32/9289_2.png) [@LeeDr](https://discuss.elastic.co/u/LeeDr)\
**Post date:** [May 23, 2019, 2:30pm UTC](https://discuss.elastic.co/t/kibana-only-working-over-local/182421/2 "2019-05-23T14:30:24Z")

</div>

What version of Kibana are you on?

And what browser are you using? What does the browser window show? Blank screen?

---

<div class="post-metadata">

**Author:** ![Junx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/junx/32/46718_2.png) [@Junx](https://discuss.elastic.co/u/Junx)\
**Post date:** [May 24, 2019, 10:19am UTC](https://discuss.elastic.co/t/kibana-only-working-over-local/182421/3 "2019-05-24T10:19:10Z")

</div>

I fixed this now. Its because nginx has strict security settings by default.

---

<div class="post-metadata">

**Author:** ![K\_Chaitanya](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/k_chaitanya/32/46387_2.png) [@K\_Chaitanya](https://discuss.elastic.co/u/K_Chaitanya)\
**Post date:** [May 24, 2019, 10:40am UTC](https://discuss.elastic.co/t/kibana-only-working-over-local/182421/4 "2019-05-24T10:40:57Z")

</div>

hi,  
I'm having the same error `Content Security Policy: the page’s settings blocked the loading of a resource at inline (“script-src”).`

and also an additional error `Content Security Policy: the page’s settings blocked the loading of a resource at https://local.website.com/link ("child-src")`

I'm running kibana version 6.8.0, and errors remain in both mozilla and chrome,  
Error is being thrown when I load a kibana plugin which tries to embed jupyterhub inside an `iframe`.

plugin used to work okay in 6.5.4 and 6.4.2 versions of kibana, recently when migrated to kibana 6.8.0, the error popped up.

---

<div class="post-metadata">

**Author:** ![Junx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/junx/32/46718_2.png) [@Junx](https://discuss.elastic.co/u/Junx)\
**Post date:** [May 24, 2019, 11:11am UTC](https://discuss.elastic.co/t/kibana-only-working-over-local/182421/5 "2019-05-24T11:11:19Z")

</div>

if ur using cloudflare you need to disable some stuff on there

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 21, 2019, 11:11am UTC](https://discuss.elastic.co/t/kibana-only-working-over-local/182421/6 "2019-06-21T11:11:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
