# Kibana parse\_exception: No processor type exists with name \[inference\]

**URL:** <https://discuss.elastic.co/t/kibana-parse-exception-no-processor-type-exists-with-name-inference/380929>\
**Category:** Kibana\
**Created:** [August 11, 2025, 7:02am UTC](https://discuss.elastic.co/t/kibana-parse-exception-no-processor-type-exists-with-name-inference/380929 "2025-08-11T07:02:00Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![msconsults](https://avatars.discourse-cdn.com/v4/letter/m/74df32/32.png) [@msconsults](https://discuss.elastic.co/u/msconsults)\
**Post date:** [August 11, 2025, 7:02am UTC](https://discuss.elastic.co/t/kibana-parse-exception-no-processor-type-exists-with-name-inference/380929/1 "2025-08-11T07:02:00Z")

</div>

I often get Kibana errors when accessing e.g. fleet or observability.  
Browser then shows:

```auto
Unable to initialize Fleet

<html> <head><title>502 Bad Gateway</title></head> <body> <center><h1>502 Bad Gateway</h1></center> <hr><center>nginx</center> </body> </html> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page -->

```

in the log:

```auto
[2025-08-11T06:48:48.629+00:00][ERROR][plugins.observabilityAIAssistant.service] Failed to initialize service: parse_exception
	Root causes:
		parse_exception: No processor type exists with name [inference]
[2025-08-11T06:48:48.630+00:00][ERROR][plugins.observabilityAIAssistant.service] Could not index 7 entries because of an initialisation error
[2025-08-11T06:48:48.630+00:00][ERROR][plugins.observabilityAIAssistant.service] ResponseError: parse_exception
	Root causes:
		parse_exception: No processor type exists with name [inference]
    at KibanaTransport.request (/usr/share/kibana/node_modules/@elastic/transport/lib/Transport.js:479:27)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at KibanaTransport.request (/usr/share/kibana/node_modules/@kbn/core-elasticsearch-client-server-internal/src/create_transport.js:51:16)
    at Ingest.putPipeline (/usr/share/kibana/node_modules/@elastic/elasticsearch/lib/api/api/ingest.js:139:16)
    at ObservabilityAIAssistantService.<anonymous> (/usr/share/kibana/node_modules/@kbn/observability-ai-assistant-plugin/server/service/index.js:123:9)

```

After the error has occurred once, everything works flawlessly again for a while.

Setup:  
Kibana / Elastic for Kubernetes. 2 Kibana instances behind Loadbalancer.  
Version 8.10.4

---

<div class="post-metadata">

**Author:** ![Tortoise](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tortoise/32/147587_2.png) [@Tortoise](https://discuss.elastic.co/u/Tortoise)\
**Post date:** [August 12, 2025, 3:15am UTC](https://discuss.elastic.co/t/kibana-parse-exception-no-processor-type-exists-with-name-inference/380929/2 "2025-08-12T03:15:47Z")

</div>

Hello @msconsults

Could you please review below post and confirm if you also receive same error about “Kibana is shutting down” in the logs?

> [@Kibana stuck in a crash loop](https://discuss.elastic.co/t/kibana-stuck-in-a-crash-loop/364834/14):
>
> Not sure what is the issue, I don't think Kibana would crash for this error as it is not a FATAL error. But the following lines suggests that something in your system requested a shutdown of the Kibana service and not the service itself crashing. I do not use Kubernetes EKS or Helm, but how does it health check the service? Can it be killing it because of an error in the logs?

Thanks!!
