# Kibana : plugin:xpack\_main@5.6.6 status Red

**URL:** <https://discuss.elastic.co/t/kibana-plugin-xpack-main-5-6-6-status-red/133713>\
**Category:** Discussions en français\
**Created:** [May 29, 2018, 3:38pm UTC](https://discuss.elastic.co/t/kibana-plugin-xpack-main-5-6-6-status-red/133713 "2018-05-29T15:38:02Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![IT\_DBA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/it_dba/32/27834_2.png) [@IT\_DBA](https://discuss.elastic.co/u/IT_DBA)\
**Post date:** [May 29, 2018, 3:38pm UTC](https://discuss.elastic.co/t/kibana-plugin-xpack-main-5-6-6-status-red/133713/1 "2018-05-29T15:38:02Z")

</div>

Bonjour,

J'ai installé Kibana et Xpack (monitoring).  
Lors du démarrage de Kibana, j'obtiens les erreurs suivantes :

root@lnxbiportailrecbdd001:/home/kibana/kibana-5.6.6-linux-x86\_64/bin# ./kibana  
log [15:05:39.272] [info][status][plugin:kibana@5.6.6] Status changed from uninitialized to green - Ready  
log [15:05:39.353] [info][status][plugin:elasticsearch@5.6.6] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [15:05:39.365] [info][status][plugin:xpack\_main@5.6.6] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [15:05:39.603] [info][status][plugin:monitoring@5.6.6] Status changed from uninitialized to green - Ready  
log [15:05:39.608] [info][status][plugin:searchprofiler@5.6.6] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [15:05:39.622] [info][status][plugin:tilemap@5.6.6] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [15:05:39.634] [info][status][plugin:grokdebugger@5.6.6] Status changed from uninitialized to green - Ready  
log [15:05:39.638] [info][status][plugin:upgrade@5.6.6] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [15:05:39.672] [info][status][plugin:console@5.6.6] Status changed from uninitialized to green - Ready  
log [15:05:39.681] [info][status][plugin:metrics@5.6.6] Status changed from uninitialized to green - Ready  
log [15:05:39.888] [info][status][plugin:timelion@5.6.6] Status changed from uninitialized to green - Ready  
log [15:05:39.895] [info][listening] Server running at [http://0.0.0.0:5656](http://0.0.0.0:5656)  
log [15:05:39.898] [info][status][ui settings] Status changed from uninitialized to yellow - Elasticsearch plugin is yellow  
log [15:05:39.947] [info][status][plugin:elasticsearch@5.6.6] Status changed from yellow to green - Kibana index ready  
log [15:05:39.949] [info][status][ui settings] Status changed from yellow to green - Ready  
log [15:05:39.969] [error][status][plugin:xpack\_main@5.6.6] Status changed from yellow to red - Red  
log [15:05:39.971] [error][status][plugin:searchprofiler@5.6.6] Status changed from yellow to red - Red  
log [15:05:39.974] [error][status][plugin:tilemap@5.6.6] Status changed from yellow to red - Red  
log [15:05:39.975] [error][status][plugin:upgrade@5.6.6] Status changed from yellow to red - Red

Ma configuration est la suivante:

root@lnxbiportailrecbdd001:/etc/elasticsearch# egrep -v "^#" elasticsearch.yml | egrep -v "^$"  
cluster.name: Elasticsearch\_BiPortail\_Recette\_Cluster  
node.name: lnxbiportailrecbdd001  
path.data: /var/lib/elasticsearch/  
path.logs: /var/log/elasticsearch/  
bootstrap.memory\_lock: true  
network.host: 0.0.0.0  
http.port: 9200  
transport.tcp.port: 9300  
discovery.zen.ping.unicast.hosts: ["10.xxx.xxx.xx2:9300", "10.xxx.xxx.xx3:9300", "10.xxx.xxx.xx4:9300"]  
xpack.graph.enabled : false  
xpack.ml.enabled : false  
xpack.monitoring.enabled : true  
xpack.watcher.enabled : false  
xpack.security.enabled : false  
action.auto\_create\_index : true  
root@lnxbiportailrecbdd001:/etc/elasticsearch#

lnxbiportailrecbdd001:kibana:$ egrep -v "^#" kibana.yml | egrep -v "^$"  
server.port: 5656  
xpack.reporting.encryptionKey: "something\_secret"  
xpack.graph.enabled : false  
xpack.ml.enabled : false  
xpack.monitoring.enabled : true  
xpack.reporting.enabled : false  
xpack.security.enabled : false  
xpack.watcher.enabled : false  
server.host: 0.0.0.0  
elasticsearch.username: "elastic"  
elasticsearch.password: "changeme"  
lnxbiportailrecbdd001:kibana:$

root@lnxbiportailrecbdd001:/etc/elasticsearch# curl -XGET "[http://localhost:9200/\_xpack?categories=license&pretty](http://localhost:9200/_xpack?categories=license&pretty)"  
{  
"license" : null,  
"tagline" : "You know, for X"  
}

J'ai tenté de résoudre le problème seul mais sans succès. Pouvez-vous m'aider dans la résolution de ces erreurs svp?  
Merci.

---

<div class="post-metadata">

**Author:** ![JKhondhu](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@JKhondhu](https://discuss.elastic.co/u/JKhondhu)\
**Post date:** [May 31, 2018, 3:33pm UTC](https://discuss.elastic.co/t/kibana-plugin-xpack-main-5-6-6-status-red/133713/2 "2018-05-31T15:33:46Z")

</div>

Do you not want to use x-pack security? I see it is set to `false`?  
In the `kibana.yml` you will want to use not the:

```auto
elasticsearch.username: "elastic"
elasticsearch.password: "changeme"

```

but:

```auto
elasticsearch.username: "kibana"
elasticsearch.password: "changeme"

```

and if xpack monitoring:

```auto
xpack.monitoring.elasticsearch.url: "https://xxxxxx:92xx"
xpack.monitoring.elasticsearch.username: "kibana-monitor"
xpack.monitoring.elasticsearch.password: "changeme"
xpack.monitoring.elasticsearch.ssl.certificateAuthorities: xx/xx/ca.crt

```

see more here: [https://www.elastic.co/guide/en/kibana/6.2/monitoring-xpack-kibana.html](https://www.elastic.co/guide/en/kibana/6.2/monitoring-xpack-kibana.html)

---

<div class="post-metadata">

**Author:** ![IT\_DBA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/it_dba/32/27834_2.png) [@IT\_DBA](https://discuss.elastic.co/u/IT_DBA)\
**Post date:** [June 1, 2018, 1:33pm UTC](https://discuss.elastic.co/t/kibana-plugin-xpack-main-5-6-6-status-red/133713/3 "2018-06-01T13:33:58Z")

</div>

Hello,

Thanks for your answer.  
I have installed X-Pack only for monitoring (marvel), I don't want to use x-pack security.  
I have tested it without "certificateAuthorities", I have exactly the same error.  
I will study this documentation: [https://www.elastic.co/guide/en/kibana/6.2/monitoring-xpack-kibana.html](https://www.elastic.co/guide/en/kibana/6.2/monitoring-xpack-kibana.html) and see..

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 29, 2018, 1:34pm UTC](https://discuss.elastic.co/t/kibana-plugin-xpack-main-5-6-6-status-red/133713/4 "2018-06-29T13:34:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
