# Kibana query to remote cluster causes null pointer exception

**URL:** <https://discuss.elastic.co/t/kibana-query-to-remote-cluster-causes-null-pointer-exception/258024>\
**Category:** Kibana\
**Created:** [December 8, 2020, 4:02pm UTC](https://discuss.elastic.co/t/kibana-query-to-remote-cluster-causes-null-pointer-exception/258024 "2020-12-08T16:02:43Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![bwink](https://avatars.discourse-cdn.com/v4/letter/b/65b543/32.png) [@bwink](https://discuss.elastic.co/u/bwink)\
**Post date:** [December 8, 2020, 4:02pm UTC](https://discuss.elastic.co/t/kibana-query-to-remote-cluster-causes-null-pointer-exception/258024/1 "2020-12-08T16:02:44Z")

</div>

Cluster#1 7.10.0  
Kibana#1 7.10.0

Cluster#2 7.9.2  
Kibana#2 7.9.2

Problem#1  
I have a local Kibana (kibana#1) to a local cluster (cluster#1) and everything works perfectly on querying an index pattern. I set up a different cluster (cluster#2) and an instance of Kibana (kibana#2) not on the same network, added the remote cluster (cluster#1) to the kibana (kibana#2). Create an index pattern for an index on (cluster#1) every query comes back with shards failed and a null\_pointer\_exception error. Neither the remote ES cluster#1 or the local cluster#2 to the remote kibana#2 throws any errors in their respective cluster logs or gc logs. Kibana#2 standard out throws no errors either as well as kibana.stderr. I have stopped Kibana#2, deleted every ".kibana\*" indice on the cluster#2, restarted kibana#2, reset up the remote index pattern to cluster#1and same thing, shards fail with null\_pointer\_exception. Cluster#1 is healthy with zero realocating, initializing, unassigned and delayed\_unassigned shards. The same for Cluster #2.

Additionally after the index pattern is created, I killed my browser session with kibana#2 and setup tcpdump to watch traffic flows on port 9300 between cluster#1 & cluster#2. Relaunch my browser connection to kibana#2 and I get the same failure with NO traffic flow on 9300 between the two clusters.

Problem#2  
I upgraded Cluster#2 & Kibana#2 to see if would fix the issue and it created another issue, cannot create any new remote cluster index patterns on kibana#2 to cluster#1 because system has unending "Looking for matching indices". I had this problem before problem#1 and the only thing that fixed with was starting over with a backup of another vm that works and changing the IPs and deleting all indices, but after completion I encountered problem#1.

Help....

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 5, 2021, 4:03pm UTC](https://discuss.elastic.co/t/kibana-query-to-remote-cluster-causes-null-pointer-exception/258024/2 "2021-01-05T16:03:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
