# Kibana: random error "Request Timeout after 30000ms"

**URL:** https://discuss.elastic.co/t/kibana-random-error-request-timeout-after-30000ms/73105
**Category:** Elasticsearch
**Created:** [January 28, 2017, 10:57pm UTC](https://discuss.elastic.co/t/kibana-random-error-request-timeout-after-30000ms/73105 "2017-01-28T22:57:19Z")
**Posts on this page:** 1
**Showing post:** 4

<div class="post-metadata">

### Author: ![simonlucalandi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/simonlucalandi/32/14990_2.png) [@simonlucalandi](https://discuss.elastic.co/u/simonlucalandi)
#### Post date: [January 30, 2017, 1:55pm UTC](https://discuss.elastic.co/t/kibana-random-error-request-timeout-after-30000ms/73105/4 "2017-01-30T13:55:45Z")

</div>

Hello.

At the end I solved the connecivities issues following the instructions in this link: [http://logz.io/blog/elasticsearch-cluster-disconnects/](http://logz.io/blog/elasticsearch-cluster-disconnects/)

To make a short recap: there is a bug in the ubuntu network driver that causes some random packets loss. In the syslog of the server I got messages like this:

`xen_netfront: xennet: skb rides the rocket: 19 slots`

The procedure to solve the problem is to disable the the Scatter / Gather ability in the network interface.

```
//To see if scatter-gather is ON on eth0:
ethtool -k eth0 |grep sca
//to set it to off:
ethtool -K eth0 sg off

```

@Christian_Dahlqvist: I will follow the recommendation regarding the allocated java heap, thank you for noting it.

---

_[View the full topic](https://discuss.elastic.co/t/kibana-random-error-request-timeout-after-30000ms/73105)._
