# Kibana Reflecting error to connect with elasticsearch

**URL:** <https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728>\
**Category:** Elasticsearch\
**Created:** [February 28, 2017, 7:04am UTC](https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728 "2017-02-28T07:04:04Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Post date:** [February 28, 2017, 7:04am UTC](https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728/1 "2017-02-28T07:04:04Z")

</div>

Hi ,  
I'm using new version of elasticsearch(5.2.1) and kibana (5.2.1) and i'm try to start elasticsearch as cluster mode. Elasticsearch is up and running when i start kibana im getting error status : red and please find the below error description,

Status Breakdown  
ID Status  
ui settings Elasticsearch plugin is red  
plugin:kibana@5.2.1 Ready  
plugin:elasticsearch@5.2.1 Unable to connect to Elasticsearch at [http://xxxx:9200/](http://xxxx:9200/).  
plugin:console@5.2.1 Ready  
plugin:timelion@5.2.1 Ready

Plz help to resolve this asap and i have to finish poc before Mar 10th.

---

<div class="post-metadata">

**Author:** ![rulanitee](https://avatars.discourse-cdn.com/v4/letter/r/b5e925/32.png) [@rulanitee](https://discuss.elastic.co/u/rulanitee)\
**Post date:** [February 28, 2017, 7:25am UTC](https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728/2 "2017-02-28T07:25:59Z")

</div>

Hi Ganesh2303,

If you do the following what do you get:

curl -XGET [http://xxxx:9200/](http://xxxx:9200/) -\> this gives you details on your ES cluster

Or using postman or any tool or even curl

curl -XGET [http://xxxx:9200/\_cluster/health](http://xxxx:9200/_cluster/health) -\> this gives you more details on your ES cluster, for instance number of nodes, etc.

This is a start to see if your ES cluster is configured correctly.

Hope it helps

---

<div class="post-metadata">

**Author:** ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Post date:** [February 28, 2017, 7:33am UTC](https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728/3 "2017-02-28T07:33:14Z")

</div>

@rulanitee  
please find the reply of the above command which you mentioned,

curl -XGET [http://xxxx:9200](http://xxxx:9200)

```
{
  "name" : "node1",
  "cluster_name" : "sub_prod_cluster",
  "cluster_uuid" : "_na_",
  "version" : {
    "number" : "5.2.1",
    "build_hash" : "db0d481",
    "build_date" : "2017-02-09T22:05:32.386Z",
    "build_snapshot" : false,
    "lucene_version" : "6.4.1"
  },
  "tagline" : "You Know, for Search"
}

```

curl -XGET [http://xxxxx:9200/\_cluster/health](http://xxxxx:9200/_cluster/health)  
`{"cluster_name":"sub_prod_cluster","status":"red","timed_out":false,"number_of_nodes":1,"number_of_data_nodes":1,"active_primary_shards":0,"active_shards":0,"relocating_shards":0,"initializing_shards":0,"unassigned_shards":0,"delayed_unassigned_shards":0,"number_of_pending_tasks":0,"number_of_in_flight_fetch":0,"task_max_waiting_in_queue_millis":0,"active_shards_percent_as_number":"NaN"}`

---

<div class="post-metadata">

**Author:** ![rulanitee](https://avatars.discourse-cdn.com/v4/letter/r/b5e925/32.png) [@rulanitee](https://discuss.elastic.co/u/rulanitee)\
**Post date:** [February 28, 2017, 9:16am UTC](https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728/4 "2017-02-28T09:16:20Z")

</div>

Hi Ganesh,

Thanks for the response. If I am not mistaken, this is a cluster with just one node. Can you do the following in the elasticsearch.yml config:

node.local=true

restart elasticsearch service and check the health again.

You can check here for more info:

> <https://stackoverflow.com/questions/16432300/how-to-config-single-node-for-single-cluster-standalone-cluster-elasticsearch>

Hope it works

---

<div class="post-metadata">

**Author:** ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Post date:** [March 2, 2017, 1:02pm UTC](https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728/5 "2017-03-02T13:02:09Z")

</div>

Sorry for late reply when i try with node.local: true i faced issue to startup elastisearch itself,

```
 in 'reader', line 53, column 1:
    node.local= true
    ^
could not find expected ':'
 in 'reader', line 54, column 1:
    # You can exploit these settings ...
    ^
];
Likely root cause: while scanning a simple key
 in 'reader', line 53, column 1:
    node.local= true
    ^
could not find expected ':'
 in 'reader', line 54, column 1:
    # You can exploit these settings ...

```

And one more thing now i started with cluster eventhough its showing same error in kibana.  
Is that any setting have set false for xpack, bcoz i read one article by default it was set to true am i wrong mean please correct me

---

<div class="post-metadata">

**Author:** ![rulanitee](https://avatars.discourse-cdn.com/v4/letter/r/b5e925/32.png) [@rulanitee](https://discuss.elastic.co/u/rulanitee)\
**Post date:** [March 13, 2017, 9:17am UTC](https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728/6 "2017-03-13T09:17:48Z")

</div>

Hi Ganesh,

Sorry for the late response, did you manage to get this resolved?

Regards

---

<div class="post-metadata">

**Author:** ![Ganesh2303](https://avatars.discourse-cdn.com/v4/letter/g/57b2e6/32.png) [@Ganesh2303](https://discuss.elastic.co/u/Ganesh2303)\
**Post date:** [March 13, 2017, 9:30am UTC](https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728/7 "2017-03-13T09:30:36Z")

</div>

HI rulanitee,  
No still facing the issue, thank you for your response

---

<div class="post-metadata">

**Author:** ![rulanitee](https://avatars.discourse-cdn.com/v4/letter/r/b5e925/32.png) [@rulanitee](https://discuss.elastic.co/u/rulanitee)\
**Post date:** [March 14, 2017, 6:50am UTC](https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728/8 "2017-03-14T06:50:59Z")

</div>

Hi Ganesh,

If you are still having issues, can you try the following:

restart elasticsearch

check the logs and see if all is good

-\> /var/log/elasticsearch/your\_cluster\_name.log and /var/log/elasticsearch/elasticsearch.log

Let me know if there is an error or issue logged

Regards

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 11, 2017, 6:51am UTC](https://discuss.elastic.co/t/kibana-reflecting-error-to-connect-with-elasticsearch/76728/9 "2017-04-11T06:51:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
