# Kibana says "Unable to revive connection" but curl says "No problem"

**URL:** <https://discuss.elastic.co/t/kibana-says-unable-to-revive-connection-but-curl-says-no-problem/85157>\
**Category:** Kibana\
**Created:** [May 9, 2017, 8:44pm UTC](https://discuss.elastic.co/t/kibana-says-unable-to-revive-connection-but-curl-says-no-problem/85157 "2017-05-09T20:44:49Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![erikstephens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/erikstephens/32/5430_2.png) [@erikstephens](https://discuss.elastic.co/u/erikstephens)\
**Post date:** [May 9, 2017, 8:44pm UTC](https://discuss.elastic.co/t/kibana-says-unable-to-revive-connection-but-curl-says-no-problem/85157/1 "2017-05-09T20:44:49Z")

</div>

I've tried 5.4.0, 5.3.2, and 5.3.1 (both stock elasticsearch & kibana docker images). I'm getting the common "Unable to revive connection":

```
kibana | {"type":"log","@timestamp":"2017-05-09T20:24:11Z","tags":["warning","elasticsearch","admin"],"pid":7,"message":"Unable to revive connection: http://es-client:9200/"}

```

even though from that same container, I get positive responses using curl:

```
docker exec -it kibana curl http://es-client:9200
{
  "name" : "client3",
  "cluster_name" : "HiMom",
  "cluster_uuid" : "ZfxhGljwSPCZ0oP0dLbLfQ",
  "version" : {
    "number" : "5.3.2",
    "build_hash" : "3068195",
    "build_date" : "2017-04-24T16:15:59.481Z",
    "build_snapshot" : false,
    "lucene_version" : "6.4.2"
  },
  "tagline" : "You Know, for Search"
}

```

I've got a really basic config (no ssl). Anyone know why kibana can't establish connection when it can clearly connect via curl? Thanks!

---

<div class="post-metadata">

**Author:** ![erikstephens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/erikstephens/32/5430_2.png) [@erikstephens](https://discuss.elastic.co/u/erikstephens)\
**Post date:** [May 9, 2017, 11:02pm UTC](https://discuss.elastic.co/t/kibana-says-unable-to-revive-connection-but-curl-says-no-problem/85157/2 "2017-05-09T23:02:20Z")

</div>

Searching the source for 'revive' (both via github search and local grep) yields nothing. Can someone point me to the right source repo (some plugin) I should dive into? Thanks!

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [May 10, 2017, 11:19pm UTC](https://discuss.elastic.co/t/kibana-says-unable-to-revive-connection-but-curl-says-no-problem/85157/3 "2017-05-10T23:19:29Z")

</div>

> [@erikstephens](#):
>
> "Unable to revive connection":

This happens when Kibana can't communicate with elasticsearch. Can you try pinging elasticsearch with curl from the box that kibana is running on?

```auto
curl -i http://localhost:9200

```

---

<div class="post-metadata">

**Author:** ![erikstephens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/erikstephens/32/5430_2.png) [@erikstephens](https://discuss.elastic.co/u/erikstephens)\
**Post date:** [May 11, 2017, 4:53pm UTC](https://discuss.elastic.co/t/kibana-says-unable-to-revive-connection-but-curl-says-no-problem/85157/4 "2017-05-11T16:53:28Z")

</div>

Thanks, rashmi. The problem was user error on my part.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 8, 2017, 5:06pm UTC](https://discuss.elastic.co/t/kibana-says-unable-to-revive-connection-but-curl-says-no-problem/85157/5 "2017-06-08T17:06:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
