# Kibana sending "docvalue\_fields" that break ES?

**URL:** <https://discuss.elastic.co/t/kibana-sending-docvalue-fields-that-break-es/92139>\
**Category:** Kibana\
**Created:** [July 6, 2017, 3:59pm UTC](https://discuss.elastic.co/t/kibana-sending-docvalue-fields-that-break-es/92139 "2017-07-06T15:59:57Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jwalton](https://avatars.discourse-cdn.com/v4/letter/j/edb3f5/32.png) [@jwalton](https://discuss.elastic.co/u/jwalton)\
**Post date:** [July 6, 2017, 3:59pm UTC](https://discuss.elastic.co/t/kibana-sending-docvalue-fields-that-break-es/92139/1 "2017-07-06T15:59:57Z")

</div>

I've been using ES and Kibana for quite a while now, but this morning ES started failing with "Courier Fetch: 5 of 5 shards failed". I started digging into this, and there's nothing in the logs, but if I query older records everything works fine. If I query recent records, looking at the request actually going from Kibana I see:

```
{
    "size": 500,
    "sort": [{"@timestamp": {"order": "desc", "unmapped_type": "boolean"}}],
    "query": {...},
    "highlight": {...},
    "_source": {"excludes": []},
    "aggs": {...},
    "stored_fields": ["*"],
    "script_fields": {},
    "docvalue_fields": [
        ...
        "data.schedule",
        ...
    ]
}

```

And then in the reply:

```
"reason":{
    "type":"illegal_argument_exception",
    "reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [data.schedule] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory."
}

```

Wat? Why is Kibana sending "data.schedule" in "docvalue\_fields"? And why is this suddenly breaking now? Kibana/ES version is 5.1.1.

---

<div class="post-metadata">

**Author:** ![jwalton](https://avatars.discourse-cdn.com/v4/letter/j/edb3f5/32.png) [@jwalton](https://discuss.elastic.co/u/jwalton)\
**Post date:** [July 6, 2017, 4:15pm UTC](https://discuss.elastic.co/t/kibana-sending-docvalue-fields-that-break-es/92139/2 "2017-07-06T16:15:40Z")

</div>

Ok, I know why it's failing now and not before - it's because this 'schedule' field is one that gets logged by an obscure error. But why is Kibana sending data.schedule in docvalue\_fields, and is there a way to stop it?

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [July 11, 2017, 12:53pm UTC](https://discuss.elastic.co/t/kibana-sending-docvalue-fields-that-break-es/92139/3 "2017-07-11T12:53:16Z")

</div>

@jwalton if you look at your Index Pattern in Kibana, what do you see in the "type" column for the "data.schedule" field? Kibana is automatically requesting `docvalue_fields` for fields with type 'date'.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 8, 2017, 12:53pm UTC](https://discuss.elastic.co/t/kibana-sending-docvalue-fields-that-break-es/92139/4 "2017-08-08T12:53:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
