# Kibana server is not ready yet - 6.3 to 6.5

**URL:** <https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-6-3-to-6-5/162396>\
**Category:** Elasticsearch\
**Created:** [December 29, 2018, 6:38am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-6-3-to-6-5/162396 "2018-12-29T06:38:42Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![akhisar](https://avatars.discourse-cdn.com/v4/letter/a/f9ae1b/32.png) [@akhisar](https://discuss.elastic.co/u/akhisar)\
**Post date:** [December 29, 2018, 6:38am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-6-3-to-6-5/162396/1 "2018-12-29T06:38:42Z")

</div>

Hello,

I have tried upgrade of Kibana from 6.3 to 6.5 and am getting "Kibana server is not ready yet" on Kibana.

I have also tried removing the .kibana index but still the error persisit. Any help in here will be much appreciated.

Below Error found on the kibana logs.

{"type":"log","@timestamp":"2018-12-29T06:37:00Z","tags":["debug","legacy","proxy"],"pid":27677,"message":"Event is being forwarded: clientError"}  
{"type":"error","@timestamp":"2018-12-29T06:37:00Z","tags":["connection","client","error"],"pid":27677,"level":"error","error":{"message":"socket hang up","name":"Error","stack":"Error: socket hang up\n at TLSSocket. (\_tls\_wrap.js:890:25)\n at emitOne (events.js:121:20)\n at TLSSocket.emit (events.js:211:7)\n at \_handle.close (net.js:561:12)\n at Socket.done (\_tls\_wrap.js:360:7)\n at Object.onceWrapper (events.js:315:30)\n at emitOne (events.js:116:13)\n at Socket.emit (events.js:211:7)\n at TCP.\_handle.close [as \_onclose] (net.js:561:12)","code":"ECONNRESET"},"message":"socket hang up"}

Rgds,  
-Akhil

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [December 29, 2018, 8:46am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-6-3-to-6-5/162396/2 "2018-12-29T08:46:56Z")

</div>

Did you also upgrade Elasticsearch to 6.5? How are you securing the stack? Can you share your config?

---

<div class="post-metadata">

**Author:** ![akhisar](https://avatars.discourse-cdn.com/v4/letter/a/f9ae1b/32.png) [@akhisar](https://discuss.elastic.co/u/akhisar)\
**Post date:** [December 30, 2018, 7:35am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-6-3-to-6-5/162396/3 "2018-12-30T07:35:12Z")

</div>

Hello Christian,

It is resolved!!

I had done an apt upgrade. Initially it was not even creating the .kibana index. I tried stopping my apt instance of the kibana and brought up the downloaded tar version in one of the elastic nodes with basic config file.It was able to connect successfully to the elastic search with .kibana1 index created.

Later I could see that apt kibana instance was starting but experiencing the OOM error at optimizing bundles. Thanks to the new feature I was able to add the NODE\_OPTION to the default directory.

$ cat /etc/default/kibana | grep -i NODE\_OPTIONS  
NODE\_OPTIONS="--max-old-space-size=8192"

Thanks again for your time..

Rgds,  
-Akhil

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 27, 2019, 7:41am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-6-3-to-6-5/162396/4 "2019-01-27T07:41:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
