# Kibana server is not ready yet in v 7.2

**URL:** https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-in-v-7-2/192889
**Category:** Kibana
**Created:** [July 30, 2019, 12:11pm UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-in-v-7-2/192889 "2019-07-30T12:11:10Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)
#### Post date: [July 30, 2019, 12:11pm UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-in-v-7-2/192889/1 "2019-07-30T12:11:10Z")

</div>

when I try to access kibana from the following URL I got "Kibana server is not ready yet"

[http://172.24.36.204:5601/](http://172.24.36.204:5601/)

kibana.log

```auto
{"type":"log","@timestamp":"2019-07-30T12:10:52Z","tags":["reporting","browser-driver","error"],"pid":97200,"message":"Error code EACCES: Insufficient permissions for extracting the browser archive. Make sure the Kibana data directory (path.data) is owned by the same user that is running Kibana."}
{"type":"log","@timestamp":"2019-07-30T12:10:52Z","tags":["fatal","root"],"pid":97200,"message":"{ ExtractError: Failed to extract the browser archive\n at err (/usr/share/kibana/x-pack/plugins/reporting/server/browsers/extract/unzip.js:14:23)\n at /usr/share/kibana/node_modules/extract-zip/index.js:52:20\n at WriteStream.<anonymous> (/usr/share/kibana/node_modules/extract-zip/index.js:143:24)\n at WriteStream.emit (events.js:194:15)\n at lazyFs.open (internal/fs/streams.js:272:12)\n at FSReqWrap.oncomplete (fs.js:141:20)\n name: 'ExtractError',\n cause:\n { Error: EACCES: permission denied, open '/var/lib/kibana/headless_shell-linux/headless_shell'\n errno: -13,\n code: 'EACCES',\n syscall: 'open',\n path: '/var/lib/kibana/headless_shell-linux/headless_shell' },\n isBoom: true,\n isServer: true,\n data: null,\n output:\n { statusCode: 500,\n payload:\n { statusCode: 500,\n error: 'Internal Server Error',\n message: 'An internal server error occurred' },\n headers: {} },\n reformat: [Function],\n [Symbol(SavedObjectsClientErrorCode)]: 'SavedObjectsClient/generalError' }"}

```

---

<div class="post-metadata">

### Author: ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)
#### Post date: [July 30, 2019, 12:37pm UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-in-v-7-2/192889/2 "2019-07-30T12:37:49Z")

</div>

The first line in the message seems to say that the linux userid running Kibana doesn't have the proper permissions to write to the kibana data directory.

Do a net search on:"Insufficient permissions for extracting the browser archive. Make sure the Kibana data directory (path.data) is owned by the same user that is running Kibana."}

There are several ideas

---

<div class="post-metadata">

### Author: ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)
#### Post date: [July 30, 2019, 1:19pm UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-in-v-7-2/192889/3 "2019-07-30T13:19:34Z")

</div>

Kibana version: 7.2.0

Elasticsearch version: 7.2.0

Server OS version: Centos 7.4.1708

Original install method : yum from official repos

Kibana 7.2.0 installed from rpm package does not start with error:

```auto
"message":"Error code EACCES: Insufficient permissions for extracting the browser archive. Make sure the Kibana data directory (path.data) is owned by the same user that is running Kibana."}
"message":"{ ExtractError: Failed to extract the browser archive\n at err (/usr/share/kibana/x-pack/plugins/reporting/server/browsers/extract/unzip.js:14:23)\n at /usr/share/kibana/node_modules/extract-zip/index.js:52:20\n

```

It seems to be default data path directory missing in kibana-7.2.0-1 rpm package - /usr/share/kibana/data is not created when rpm is installed.

Manually creating folder /usr/share/kibana/data and setting appropriate rights resolves the issue:

```auto
mkdir /usr/share/kibana/data
chown kibana:kibana /usr/share/kibana/data
systemctl restart kibana

```

---

<div class="post-metadata">

### Author: ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)
#### Post date: [July 30, 2019, 1:25pm UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-in-v-7-2/192889/4 "2019-07-30T13:25:45Z")

</div>

Thank you all issue fixed

---

<div class="post-metadata">

### Author: ![nuwan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nuwan/32/42325_2.png) [@nuwan](https://discuss.elastic.co/u/nuwan)
#### Post date: [July 30, 2019, 1:26pm UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-in-v-7-2/192889/5 "2019-07-30T13:26:16Z")

</div>

Thank you mate . Appreciate your support

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 27, 2019, 1:26pm UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-in-v-7-2/192889/6 "2019-08-27T13:26:17Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
