# Kibana server is not ready

**URL:** <https://discuss.elastic.co/t/kibana-server-is-not-ready/181803>\
**Category:** Kibana\
**Created:** [May 20, 2019, 11:31am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready/181803 "2019-05-20T11:31:34Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![abhishek\_Shetty](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abhishek_shetty/32/46284_2.png) [@abhishek\_Shetty](https://discuss.elastic.co/u/abhishek_Shetty)\
**Post date:** [May 20, 2019, 11:31am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready/181803/1 "2019-05-20T11:31:34Z")

</div>

Hi all,

I have installed latest version of Elastic search and Kibana on red hat 7.6, both services are running but I am unable to connect to kibana from browser which is giving Kibana server is not ready yet. I saw error and checked instances but no instance was found.

Can someone help in fixing the issue  
**Service Status:**  
sudo systemctl status kibana.service  
● kibana.service - Kibana  
Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)  
Active: active (running) since Mon 2019-05-20 04:26:48 PDT; 4s ago  
Main PID: 18508 (node)  
Tasks: 11  
CGroup: /system.slice/kibana.service  
└─18508 /usr/share/kibana/bin/../node/bin/node --no-warnings --max-http-header-size=65536 /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml

May 20 04:26:48 scdl-sduipa-001 systemd[1]: Started Kibana.

**ERROR LOG:**  
cat kibana.stdout  
{"type":"log","@timestamp":"2019-05-20T05:57:13Z","tags":["fatal","root"],"pid":681,"message":"Error: Port 5601 is already in use. Another instance of Kibana may be running!\n at Root.shutdown (/usr/share/kibana/src/core/server/root/index.js:53:26)\n at Root.start (/usr/share/kibana/src/core/server/root/index.js:45:24)\n at process.\_tickCallback (internal/process/next\_tick.js:68:7)\n at Function.Module.runMain (internal/modules/cjs/loader.js:745:11)\n at startup (internal/bootstrap/node.js:283:19)\n at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)"}

ps -ef | grep kibana  
kibana 13724 1 99 03:52 ? 00:00:06 /usr/share/kibana/bin/../node/bin/node --no-warnings --max-http-header-size=65536 /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml  
root 13737 7105 0 03:52 pts/0 00:00:00 grep --color=auto kibana

curl -X GET "localhost:9200"  
{  
"name" : "scdl-sduipa-001",  
"cluster\_name" : "elasticsearch",  
"cluster\_uuid" : "JkwpFVIkSs2-bo8vXey\_jw",  
"version" : {  
"number" : "7.0.1",  
"build\_flavor" : "default",  
"build\_type" : "rpm",  
"build\_hash" : "e4efcb5",  
"build\_date" : "2019-04-29T12:56:03.145736Z",  
"build\_snapshot" : false,  
"lucene\_version" : "8.0.0",  
"minimum\_wire\_compatibility\_version" : "6.7.0",  
"minimum\_index\_compatibility\_version" : "6.0.0-beta1"  
},  
"tagline" : "You Know, for Search"

curl -X GET "localhost:9200/\_cat/indices/.kib\*?v&s=index"  
health status index uuid pri rep docs.count docs.deleted store.size pri.store.size

curl -X GET "localhost:5601"  
curl: (7) Failed connect to localhost:5601; Connection refused

---

<div class="post-metadata">

**Author:** ![tiagocosta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tiagocosta/32/40045_2.png) [@tiagocosta](https://discuss.elastic.co/u/tiagocosta)\
**Post date:** [May 20, 2019, 4:48pm UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready/181803/2 "2019-05-20T16:48:22Z")

</div>

@abhishek_Shetty according to logs, another process is already running into the port 5601.

Try to find what is the process running on that port with

```auto
lsof -i :5601

```

Then kill it and restart the kibana service. It should work then

---

<div class="post-metadata">

**Author:** ![abhishek\_Shetty](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abhishek_shetty/32/46284_2.png) [@abhishek\_Shetty](https://discuss.elastic.co/u/abhishek_Shetty)\
**Post date:** [May 21, 2019, 4:42am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready/181803/3 "2019-05-21T04:42:07Z")

</div>

Hi Tiagocosta,

I did checked the port and found one kibana process is running but frequently its PDI is changing and I am unable to kill the process. Is their any command or method we can fix this issue.

root@scdl-sduipa-001:/var/log/kibana# cat kibana.stderr

FATAL Error: Port 5601 is already in use. Another instance of Kibana may be running!

root@scdl-sduipa-001:/var/log/kibana# cat kibana.stdout  
{"type":"log","@timestamp":"2019-05-20T05:57:13Z","tags":["fatal","root"],"pid":681,"message":"Error: Port 5601 is already in use. Another instance of Kibana may be running!\n at Root.shutdown (/usr/share/kibana/src/core/server/root/index.js:53:26)\n at Root.start (/usr/share/kibana/src/core/server/root/index.js:45:24)\n at process.\_tickCallback (internal/process/next\_tick.js:68:7)\n at Function.Module.runMain (internal/modules/cjs/loader.js:745:11)\n at startup (internal/bootstrap/node.js:283:19)\n at bootstrapNodeJSCore (internal/bootstrap/node.js:743:3)"}  
root@scdl-sduipa-001:/var/log/kibana# lsof -i :5601  
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME  
node 6253 kibana 18u IPv4 1939985 0t0 TCP [scdl-sduipa-001.fhlbsf-i.com](http://scdl-sduipa-001.fhlbsf-i.com):esmagent (LISTEN)

root@scdl-sduipa-001:/var/log/kibana# lsof -i :5601  
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME  
node 6281 kibana 18u IPv4 1941176 0t0 TCP [scdl-sduipa-001.fhlbsf-i.com](http://scdl-sduipa-001.fhlbsf-i.com):esmagent (LISTEN)

root@scdl-sduipa-001:/var/log/kibana# lsof -i :5601  
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME  
node 6494 kibana 18u IPv4 1943812 0t0 TCP [scdl-sduipa-001.fhlbsf-i.com](http://scdl-sduipa-001.fhlbsf-i.com):esmagent (LISTEN)

root@scdl-sduipa-001:/var/log/kibana# kill -9 6494  
bash: kill: (6494) - No such process

---

<div class="post-metadata">

**Author:** ![pathri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pathri/32/54484_2.png) [@pathri](https://discuss.elastic.co/u/pathri)\
**Post date:** [May 21, 2019, 5:05am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready/181803/4 "2019-05-21T05:05:24Z")

</div>

i hope you are running kibana not as a service

Try killing kibana PID with below command and restart it

ps -ef | grep '.\*node/bin/node.\*src/cli'

Output:  
root 6297 1 1 May18 ? 00:18:50 ../bin/../node/bin/node --no-warnings --max-http-header-size=65536 ../bin/../src/cli

kill -9 6297

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 18, 2019, 5:05am UTC](https://discuss.elastic.co/t/kibana-server-is-not-ready/181803/5 "2019-06-18T05:05:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
