# Kibana server not ready after update (cause of mapper\_parsing\_exception)

**URL:** https://discuss.elastic.co/t/kibana-server-not-ready-after-update-cause-of-mapper-parsing-exception/195161
**Category:** Kibana
**Created:** [August 14, 2019, 8:20am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-after-update-cause-of-mapper-parsing-exception/195161 "2019-08-14T08:20:04Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![sotor\_nien](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sotor_nien/32/51529_2.png) [@sotor\_nien](https://discuss.elastic.co/u/sotor_nien)
#### Post date: [August 14, 2019, 8:20am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-after-update-cause-of-mapper-parsing-exception/195161/1 "2019-08-14T08:20:04Z")

</div>

Hi all,

I'm quite new to ELK, did my first Update and instant run into the first issue I cannot address.

What I did:

- Updated all Elasticsearch Nodes from 6.5 to 6.8
- Cluster is green
- Updated Kibana from 6.5 to 6.8

Current State:

- Kibana HTTP Error: Kibana server is not ready yet
- Kibana Startup Logs:

> Aug 14 07:35:52 kibana-server kibana[32209]: {"type":"log","@timestamp":"2019-08-14T07:35:52Z","tags":["info","migrations"],"pid":32209,"message":"Creating index .kibana\_3."}

> Aug 14 07:35:52 kibana-server kibana[32209]: {"type":"log","@timestamp":"2019-08-14T07:35:52Z","tags":["debug","upgrade\_assistant","reindex\_worker"],"pid":32209,"message":"Could not fetch riendex operations from Elasticsearch"}

> Aug 14 07:35:52 kibana-server kibana[32209]: {"type":"log","@timestamp":"2019-08-14T07:35:52Z","tags":["debug","upgrade\_assistant","reindex\_worker"],"pid":32209,"message":"Stopping worker..."}  
> Aug 14 07:35:52 kibana-server kibana[32209]: FATAL [mapper\_parsing\_exception] Mapping definition for [url] has unsupported parameters: [properties : {accessCount={type=long}, accessDate={type=date}, url={type=text, fields={keyword={ignore\_above=2048, type=keyword}}}, createDate={type=date}}]"}},"status":400}"}

At this Point I'm stuck:  
It seems there is a problem with the .kibana\_N Index

- This is working: curl -XPUT [http://localhost:9200/test-index](http://localhost:9200/test-index)
- **This fails with the same error (mapper\_parsing\_error)**: curl -XPUT [http://localhost:9200/.kibana-testtryXYZ](http://localhost:9200/.kibana-testtryXYZ)

Therefore I conclude that there must be an issue with the .kibana template which applies to all indicies containing the name _kibana_.

The big question is:  
What is wrong with the [url] mapping definition and how to repair it?

Thanks to everyone who takes the time for my issue

---

<div class="post-metadata">

### Author: ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)
#### Post date: [August 16, 2019, 5:00pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-after-update-cause-of-mapper-parsing-exception/195161/2 "2019-08-16T17:00:00Z")

</div>

It's possible there's a conflict between the old kibana template and the new upgrade system. In 6.6+ there's an upgrade step that will push mappings (as opposed to using a template). You should be able to safely delete any kibana templates, and then let's try a server restart

Can you share which .kibana indices exist? It's probably worth checking if there's any partial upgrades in place too

---

<div class="post-metadata">

### Author: ![sotor\_nien](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sotor_nien/32/51529_2.png) [@sotor\_nien](https://discuss.elastic.co/u/sotor_nien)
#### Post date: [August 21, 2019, 7:00am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-after-update-cause-of-mapper-parsing-exception/195161/3 "2019-08-21T07:00:30Z")

</div>

Hi jbudz and thanks for your and sorry for my late reply. I deleted all templates and started the Service but the Error remains.

About the indices:  
There is .kibana\_1 and .kibana\_2. The Alias is mapped to .kibana\_2. It stills loggs Mapping definition for [url] has unsupported parameters for .kibana\_3 when starting the Kibana Service.

![kibana_indices](https://us1.discourse-cdn.com/elastic/original/3X/a/b/abcd0f7c69b88f18c6dceae92716f573313315ce.png)  
/usr/share/kibana/bin/kibana --version tells me 6.8.2. This is not conform with the upgraded version from my indices Screenshot above. Is this normal?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 18, 2019, 7:00am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-after-update-cause-of-mapper-parsing-exception/195161/4 "2019-09-18T07:00:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
