# KIbana server not ready yet. Update from 7.5.2 to 7.6.2

**URL:** <https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100>\
**Category:** Kibana\
**Created:** [April 15, 2020, 11:30am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100 "2020-04-15T11:30:00Z")\
**Posts on this page:** 18\
**Page:** 1

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 15, 2020, 11:30am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/1 "2020-04-15T11:30:00Z")

</div>

Hi, dear community!

I updated Kibana and Elasticsearch from version 7.5.2 to 7.6.2 and received an error - KIbana server not ready yet. I do not see anything suspicious in the logs except that the Kibana service is restarted every four minutes by unknown reason. I will very appreciate some help, thank you.

kibana log - [https://pastebin.com/meBySpE9](https://pastebin.com/meBySpE9)  
elastic log - [https://pastebin.com/vrRkVf92](https://pastebin.com/vrRkVf92)  
netstat, nodes and cluster health screenshot: [https://imgur.com/a/JdzGaX7](https://imgur.com/a/JdzGaX7)

---

<div class="post-metadata">

**Author:** ![majagrubic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/majagrubic/32/74459_2.png) [@majagrubic](https://discuss.elastic.co/u/majagrubic)\
**Post date:** [April 15, 2020, 12:25pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/2 "2020-04-15T12:25:40Z")

</div>

I don't see anything weird in any of the logs. If I understand the issue correctly - the Kibana server starts but it restarts itself every 4 minutes? Are you self-hosting Kibana server? Or somewhere in the cloud?

---

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 15, 2020, 12:32pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/3 "2020-04-15T12:32:04Z")

</div>

Hello, @majagrubic, thank you for the reply!

Yes, we're have self-hosted Kibana and Elastic. Yes, Kibana starts correctly, as far as i know, but web-interface doesn't load properly and show error.

---

<div class="post-metadata">

**Author:** ![majagrubic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/majagrubic/32/74459_2.png) [@majagrubic](https://discuss.elastic.co/u/majagrubic)\
**Post date:** [April 15, 2020, 12:55pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/4 "2020-04-15T12:55:39Z")

</div>

What error is the interface showing?

---

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 15, 2020, 12:56pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/5 "2020-04-15T12:56:29Z")

</div>

> [@majagrubic](#):
>
> What error is the interface showing?

![1](https://us1.discourse-cdn.com/elastic/original/3X/c/a/cab09bd721af2bf8e25ac039b49097868806adf7.png)

---

<div class="post-metadata">

**Author:** ![majagrubic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/majagrubic/32/74459_2.png) [@majagrubic](https://discuss.elastic.co/u/majagrubic)\
**Post date:** [April 15, 2020, 1:04pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/6 "2020-04-15T13:04:56Z")

</div>

Ok, can you try the following things:

1. Check that Elasticsearch instance is running correctly `curl -X GET "localhost:9200/_cluster/health?pretty"`
2. Check that you accidentally don't have a previous Kibana instance running
3. Verify that kibana is not trying to load some plugins which are not installed on the master node
4. Restart Kibana server
5. If none of that doesn't help, delete `.kibana*` indices from Elasticsearch. Note that this will delete your Kibana data (dashboards, visualizations etc).

---

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 15, 2020, 1:42pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/7 "2020-04-15T13:42:44Z")

</div>

1. Elastic cluster is yellow, but i know why, that's not depend on Kibana node. Elastic is working, i checked it.
2. Looks like no.
3. I have only one plugin and it loads properly, as far as i know by logs.
4. Done, doesn't help.
5. Done, doesn't help.

![1](https://us1.discourse-cdn.com/elastic/original/3X/1/8/18e7368f7afed63192c3562c4a43a5afecb766db.png)

 ![2](https://us1.discourse-cdn.com/elastic/original/3X/4/5/45a14e6515697b89150e95f010b01d48333e776c.png)

---

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 15, 2020, 3:13pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/8 "2020-04-15T15:13:32Z")

</div>

I found interesting thing: Kibana restarts cause to failing - system is restart it due to fail. Investigating reason.

---

<div class="post-metadata">

**Author:** ![majagrubic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/majagrubic/32/74459_2.png) [@majagrubic](https://discuss.elastic.co/u/majagrubic)\
**Post date:** [April 15, 2020, 3:19pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/9 "2020-04-15T15:19:27Z")

</div>

I'm a bit surprised deleting the `.kibana` indices didn't solve the problem.

---

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 16, 2020, 8:24am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/10 "2020-04-16T08:24:17Z")

</div>

Hello, @majagrubic! Problem is still here, i have no idea, what to do. Maybe you do?

---

<div class="post-metadata">

**Author:** ![majagrubic](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/majagrubic/32/74459_2.png) [@majagrubic](https://discuss.elastic.co/u/majagrubic)\
**Post date:** [April 16, 2020, 10:45am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/11 "2020-04-16T10:45:29Z")

</div>

In your `kibana.yml` file could you please update the following setting:  
`logging.verbose: true` (notice you'll need to uncomment it if commented out now), restart Kibana and paste the logs again?

---

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 16, 2020, 11:17am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/12 "2020-04-16T11:17:12Z")

</div>

Thank you for the reply.  
Sure, let me check

---

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 16, 2020, 11:34am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/13 "2020-04-16T11:34:39Z")

</div>

Here is log with debug enabled:  
[https://pastebin.com/2FdhjHyQ](https://pastebin.com/2FdhjHyQ)

I see nothing suspicious.

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [April 16, 2020, 12:15pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/14 "2020-04-16T12:15:24Z")

</div>

Looks like it runs the optimizer, but that shouldn't fail. What happens if you remove the /optimize folder from the Kibana install dir? Maybe something got corrupted there and it messing with the optimizer service.

---

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 16, 2020, 12:22pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/15 "2020-04-16T12:22:53Z")

</div>

Hello, @Marius_Dragomir, thank you for the reply.  
Now it failed with the next errors:

```auto
апр 16 12:20:20 kibana kibana[21025]: {"type":"log","@timestamp":"2020-04-16T12:20:20Z","tags":["fatal","root"],"pid":21025,"message":"{ [Error: ENOENT: no such file or directory, mkdir] errno: -2, code: 'ENOENT', syscall: 'mkdir' }"}

```

```auto
апр 16 12:20:20 kibana kibana[21025]: FATAL Error: ENOENT: no such file or directory, mkdir
апр 16 12:20:21 kibana systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE

```

Then I made `/optimize` folder manually and set it owner to kibana. It returns to the beginning of all.

---

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 16, 2020, 1:53pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/16 "2020-04-16T13:53:18Z")

</div>

Maybe some permissions are wrong? I checked all refer to this manual: [https://documentation.wazuh.com/3.12/upgrade-guide/upgrading-elastic-stack/elastic\_server\_minor\_upgrade.html](https://documentation.wazuh.com/3.12/upgrade-guide/upgrading-elastic-stack/elastic_server_minor_upgrade.html)

Also i try clean install, doesn't help.

---

<div class="post-metadata">

**Author:** ![MichaelA](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michaela/32/66353_2.png) [@MichaelA](https://discuss.elastic.co/u/MichaelA)\
**Post date:** [April 16, 2020, 3:14pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/17 "2020-04-16T15:14:36Z")

</div>

Hi again, @Marius_Dragomir, @majagrubic 🙂  
I have found a solution. I increased `NODE_OPTIONS="--max_old_space_size=2048"` in `/etc/default/kibana` to `4096` and started the kibana in manual mode, not as a service. Optimization took place in 4 minutes and the service started up successfully.

```auto
/usr/share/kibana/bin/kibana --optimize --allow-root --verbose -e "http://kibana_ip:9200"

```

Thank you for the help

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 14, 2020, 3:14pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-update-from-7-5-2-to-7-6-2/228100/18 "2020-05-14T15:14:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
