# Kibana server not ready yet: ValidationError: child "elasticsearch" fails because \[child "hosts" fails because \["hosts" at position 0 fails because \["0" must be a string\]\]\]

**URL:** <https://discuss.elastic.co/t/kibana-server-not-ready-yet-validationerror-child-elasticsearch-fails-because-child-hosts-fails-because-hosts-at-position-0-fails-because-0-must-be-a-string/168925>\
**Category:** Kibana\
**Created:** [February 19, 2019, 4:12am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-validationerror-child-elasticsearch-fails-because-child-hosts-fails-because-hosts-at-position-0-fails-because-0-must-be-a-string/168925 "2019-02-19T04:12:04Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![amin.nugroho](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amin.nugroho/32/41077_2.png) [@amin.nugroho](https://discuss.elastic.co/u/amin.nugroho)\
**Post date:** [February 19, 2019, 4:12am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-validationerror-child-elasticsearch-fails-because-child-hosts-fails-because-hosts-at-position-0-fails-because-0-must-be-a-string/168925/1 "2019-02-19T04:12:04Z")

</div>

Hi,  
I am setting up a production cluster with version 6.6.0.1 as follows:  
3 elastic nodes all as master, ingest, data  
1 kibana node with elastic in it as elastic load balancer (master,ingest,data: false)  
1 apm, 1 logstash

I am getting: Kibana server is not ready yet

Kibana Log:  
Feb 14 12:10:04 kibana.bps.go.id systemd[1]: Started Kibana.  
Feb 14 12:10:19 kibana.bps.go.id kibana[7720]: {"type":"log","@timestamp":"2019-02-14T05:10:19Z","tags":["plugin","warning"],"pid":7720,"path":"/usr/share/kibana/src/legacy/core\_plugins/ems\_util","message":"Skipping non-plugin directory at /usr/share/kibana/src/legacy/core\_plugins/ems\_util"}  
Feb 14 12:10:21 kibana.bps.go.id kibana[7720]: {"type":"log","@timestamp":"2019-02-14T05:10:21Z","tags":["fatal","root"],"pid":7720,"message":"{ ValidationError: child "elasticsearch" fails because [child "hosts" fails because ["hosts" at position 0 fails because ["0" must be a string]]]\n at Object.exports.process (/usr/share/kibana/node\_modules/joi/lib/errors.js:196:19)\n at internals.Object.\_validateWithOptions (/usr/share/kibana/node\_modules/joi/lib/types/any/index.js:675:31)\n at module.exports.internals.Any.root.validate (/usr/share/kibana/node\_modules/joi/lib/index.js:146:23)\n at Config.\_commit (/usr/share/kibana/src/server/config/config.js:139:35)\n at Config.set (/usr/share/kibana/src/server/config/config.js:108:10)\n at Config.extendSchema (/usr/share/kibana/src/server/config/config.js:81:10)\n at extendConfigService (/usr/share/kibana/src/plugin\_discovery/plugin\_config/extend\_config\_service.js:45:10) name: 'ValidationError' }"}  
Feb 14 12:10:21 kibana.bps.go.id kibana[7720]: FATAL ValidationError: child "elasticsearch" fails because [child "hosts" fails because ["hosts" at position 0 fails because ["0" must be a string]]]  
Feb 14 12:10:21 kibana.bps.go.id systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE  
Feb 14 12:10:21 kibana.bps.go.id systemd[1]: Unit kibana.service entered failed state.  
Feb 14 12:10:21 kibana.bps.go.id systemd[1]: kibana.service failed.  
Feb 14 12:10:22 kibana.bps.go.id systemd[1]: kibana.service holdoff time over, scheduling restart.  
Feb 14 12:10:22 kibana.bps.go.id systemd[1]: Stopped Kibana.  
Feb 14 12:10:22 kibana.bps.go.id systemd[1]: Started Kibana.

Elasticsearch cluster health:  
[https://gist.githubusercontent.com/sinunk/e8a14a72fc52a861dd76aabe74502086/raw/47d306e881a132253afae1b904cca705c22ca99e/elastic-cluster-health.md](https://gist.githubusercontent.com/sinunk/e8a14a72fc52a861dd76aabe74502086/raw/47d306e881a132253afae1b904cca705c22ca99e/elastic-cluster-health.md)

Thank you for your help

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [February 21, 2019, 5:50pm UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-validationerror-child-elasticsearch-fails-because-child-hosts-fails-because-hosts-at-position-0-fails-because-0-must-be-a-string/168925/2 "2019-02-21T17:50:44Z")

</div>

Hi, this error message is self explanatory and indicates you need to check your kibana.yml settings.

`ValidationError: child "elasticsearch" fails because [child "hosts" fails because ["hosts" at position 0 fails because ["0" must be a string]]]`

See the documentation for `elasticsearch.hosts` in [https://www.elastic.co/guide/en/kibana/current/settings.html](https://www.elastic.co/guide/en/kibana/current/settings.html). The value type is a list of strings

---

<div class="post-metadata">

**Author:** ![amin.nugroho](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amin.nugroho/32/41077_2.png) [@amin.nugroho](https://discuss.elastic.co/u/amin.nugroho)\
**Post date:** [February 22, 2019, 7:22am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-validationerror-child-elasticsearch-fails-because-child-hosts-fails-because-hosts-at-position-0-fails-because-0-must-be-a-string/168925/3 "2019-02-22T07:22:25Z")

</div>

Thanks, it turns out elastic.url is deperecated in 6.6  
Now it's elasticsearch.hosts

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 22, 2019, 7:22am UTC](https://discuss.elastic.co/t/kibana-server-not-ready-yet-validationerror-child-elasticsearch-fails-because-child-hosts-fails-because-hosts-at-position-0-fails-because-0-must-be-a-string/168925/4 "2019-03-22T07:22:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
