# Kibana service does not start with no error message (while /usr/share/bin/kibana/kibana does not have any problem)

**URL:** <https://discuss.elastic.co/t/kibana-service-does-not-start-with-no-error-message-while-usr-share-bin-kibana-kibana-does-not-have-any-problem/189809>\
**Category:** Kibana\
**Created:** [July 10, 2019, 3:14pm UTC](https://discuss.elastic.co/t/kibana-service-does-not-start-with-no-error-message-while-usr-share-bin-kibana-kibana-does-not-have-any-problem/189809 "2019-07-10T15:14:11Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![patimothe](https://avatars.discourse-cdn.com/v4/letter/p/45deac/32.png) [@patimothe](https://discuss.elastic.co/u/patimothe)\
**Post date:** [July 10, 2019, 3:14pm UTC](https://discuss.elastic.co/t/kibana-service-does-not-start-with-no-error-message-while-usr-share-bin-kibana-kibana-does-not-have-any-problem/189809/1 "2019-07-10T15:14:11Z")

</div>

Hello,

This morning my kibana service worked well but now without any apparent reason it stopped working, and no error message nor logs (path log is configured already) abd the error code that returns the command is 0 so apparently everything is well.

When I try to launch kibana service with:

```
sudo systemctl start kibana.service

```

When I check the status it tells me it's not running, and if I check with

```
ps -ef |grep kibana 

```

nothing is there

This command was perfectly working this morning and days before.  
What is weird is that if I launch :

```
/usr/share/kibana/bin/kibana

```

It works perfectly.

I did not change anything in:

```
/etc/systemd/system/kibana.service

```

The action I've made before it starts to stop working:

- In elasticsearch.yml I uncommented the line :

- Then I uncommented in kibana.yml (and change the value ofc)

I restarted elasticsearch and kibana

After that it was still working, then I change password on kibana.yml, restarted kibana and it was over, the service couldn't work, then i Undo my modification on elasticsearch.yml and on kibana.yml and the problem was still here

my kibana.yml looks like that:

```
server.host: "192.168.14.200"
elasticsearch.hosts: ["http://192.168.14.200:9200"]
pid.file: /var/log/kibana/kibana.log

```

Thanks for your time!

---

<div class="post-metadata">

**Author:** ![Nathan\_Reese](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nathan_reese/32/84829_2.png) [@Nathan\_Reese](https://discuss.elastic.co/u/Nathan_Reese)\
**Post date:** [July 10, 2019, 8:10pm UTC](https://discuss.elastic.co/t/kibana-service-does-not-start-with-no-error-message-while-usr-share-bin-kibana-kibana-does-not-have-any-problem/189809/2 "2019-07-10T20:10:42Z")

</div>

Can you provide the kibana logs for the failed start up

---

<div class="post-metadata">

**Author:** ![patimothe](https://avatars.discourse-cdn.com/v4/letter/p/45deac/32.png) [@patimothe](https://discuss.elastic.co/u/patimothe)\
**Post date:** [July 10, 2019, 8:33pm UTC](https://discuss.elastic.co/t/kibana-service-does-not-start-with-no-error-message-while-usr-share-bin-kibana-kibana-does-not-have-any-problem/189809/3 "2019-07-10T20:33:32Z")

</div>

That's part of the problem no logs are produced (I configured it but nothing happens) and when I launch it with

```
/usr/share/kibana/bin/kibana

```

Logs are produced.

I just don't have any information produced

---

<div class="post-metadata">

**Author:** ![patimothe](https://avatars.discourse-cdn.com/v4/letter/p/45deac/32.png) [@patimothe](https://discuss.elastic.co/u/patimothe)\
**Post date:** [August 1, 2019, 2:08pm UTC](https://discuss.elastic.co/t/kibana-service-does-not-start-with-no-error-message-while-usr-share-bin-kibana-kibana-does-not-have-any-problem/189809/4 "2019-08-01T14:08:04Z")

</div>

Ok I've find it.

by making copy of the kibana.yml and changing from kibana.yml.old to kibana.yml, The right changed and the user kibana was not allowed to read kibana.yml

I juts did a chmod and everythong went well

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 29, 2019, 2:22pm UTC](https://discuss.elastic.co/t/kibana-service-does-not-start-with-no-error-message-while-usr-share-bin-kibana-kibana-does-not-have-any-problem/189809/5 "2019-08-29T14:22:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
