# Kibana Service Failed to start

**URL:** https://discuss.elastic.co/t/kibana-service-failed-to-start/191702
**Category:** Kibana
**Created:** [July 22, 2019, 7:06pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702 "2019-07-22T19:06:32Z")
**Posts on this page:** 14
**Page:** 1

<div class="post-metadata">

### Author: ![userR](https://avatars.discourse-cdn.com/v4/letter/u/22d042/32.png) [@userR](https://discuss.elastic.co/u/userR)
#### Post date: [July 22, 2019, 7:06pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/1 "2019-07-22T19:06:32Z")

</div>

```
 kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Mon 2019-07-22 11:56:13 PDT; 9min ago
  Process: 25855 ExecStart=/usr/share/kibana/bin/kibana -c /etc/kibana/kibana.yml (code=exited, status=1/FAILURE)
 Main PID: 25855 (code=exited, status=1/FAILURE)

Jul 22 11:56:13 systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
Jul 22 11:56:13 systemd[1]: Unit kibana.service entered failed state.
Jul 22 11:56:13 systemd[1]: kibana.service failed.
Jul 22 11:56:13 systemd[1]: kibana.service holdoff time over, scheduling restart.
Jul 22 11:56:13 systemd[1]: start request repeated too quickly for kibana.service
Jul 22 11:56:13 systemd[1]: Failed to start Kibana.
Jul 22 11:56:13 systemd[1]: Unit kibana.service entered failed state.
Jul 22 11:56:13 systemd[1]: kibana.service failed.

```

This is the following error I am receiving when starting up Kibana. I believe it has to something to do with permissions, however I am unsure how to go about fixing this.

---

<div class="post-metadata">

### Author: ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)
#### Post date: [July 22, 2019, 7:13pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/2 "2019-07-22T19:13:54Z")

</div>

Hello,

You can't start Kibana service as root.

Can you please check how you are doing it?

Thanks,  
Bhavya

---

<div class="post-metadata">

### Author: ![LizaD](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lizad/32/51074_2.png) [@LizaD](https://discuss.elastic.co/u/LizaD)
#### Post date: [July 22, 2019, 7:14pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/3 "2019-07-22T19:14:09Z")

</div>

Hi @userR

Which OS and version of Kibana are you running?

Thanks,  
Liza

---

<div class="post-metadata">

### Author: ![userR](https://avatars.discourse-cdn.com/v4/letter/u/22d042/32.png) [@userR](https://discuss.elastic.co/u/userR)
#### Post date: [July 22, 2019, 8:17pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/4 "2019-07-22T20:17:46Z")

</div>

@LizaD  
Version 7.2 and GNU/Linux 64

---

<div class="post-metadata">

### Author: ![userR](https://avatars.discourse-cdn.com/v4/letter/u/22d042/32.png) [@userR](https://discuss.elastic.co/u/userR)
#### Post date: [July 22, 2019, 8:18pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/5 "2019-07-22T20:18:25Z")

</div>

Kibana is on a server where root access is necessary to accessing the folder. Is there any other way to go about starting it?

---

<div class="post-metadata">

### Author: ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)
#### Post date: [July 22, 2019, 8:30pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/6 "2019-07-22T20:30:29Z")

</div>

@jbudz can we please get some help here?

Thanks,  
Bhavya

---

<div class="post-metadata">

### Author: ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)
#### Post date: [July 22, 2019, 8:38pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/7 "2019-07-22T20:38:11Z")

</div>

Hello userR,

Did you install Kibana as root?

Thanks,  
Bhavya

---

<div class="post-metadata">

### Author: ![userR](https://avatars.discourse-cdn.com/v4/letter/u/22d042/32.png) [@userR](https://discuss.elastic.co/u/userR)
#### Post date: [July 22, 2019, 8:51pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/8 "2019-07-22T20:51:53Z")

</div>

Yes, it looks like I did. Will I have to reinstall it?

---

<div class="post-metadata">

### Author: ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)
#### Post date: [July 22, 2019, 8:57pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/9 "2019-07-22T20:57:13Z")

</div>

A fresh purge and install will help, by resetting the permissions if you want the quick fix. We can debug if you want too - can you share the output of `journalctl -fu kibana.service` and if there's any log files at `/var/log/kibana`?

---

<div class="post-metadata">

### Author: ![userR](https://avatars.discourse-cdn.com/v4/letter/u/22d042/32.png) [@userR](https://discuss.elastic.co/u/userR)
#### Post date: [July 22, 2019, 9:58pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/10 "2019-07-22T21:58:51Z")

</div>

```
journalctl -fu kibana.service

-- Logs begin at Mon 2019-07-08 07:33:17 PDT. --

Jul 22 11:56:13 kibana[25855]: fs.js:115

Jul 22 11:56:13 systemd[1]: **kibana.service: main process exited, code=exited, status=1/FAILURE**

Jul 22 11:56:13 systemd[1]: **Unit kibana.service entered failed state.**

Jul 22 11:56:13 systemd[1]: **kibana.service failed.**

Jul 22 11:56:13 systemd[1]: kibana.service holdoff time over, scheduling restart.

Jul 22 11:56:13 systemd[1]: **start request repeated too quickly for kibana.service**

Jul 22 11:56:13 systemd[1]: **Failed to start Kibana.**

Jul 22 11:56:13 systemd[1]: **Unit kibana.service entered failed state.**

Jul 22 11:56:13 systemd[1]: **kibana.service failed.**

Jul 22 13:33:27 systemd[1]: Stopped Kibana.

```

I do not see any kibana log files.

---

<div class="post-metadata">

### Author: ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)
#### Post date: [July 22, 2019, 10:31pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/11 "2019-07-22T22:31:20Z")

</div>

> [@userR](#):
>
> Jul 22 11:56:13 elkproj kibana[25855]: fs.js:115

Can you scroll up a little, we caught just the tail end of the error, but it does look like it's permissions related 🙂

```auto
Jul 22 11:56:13 elkproj kibana[25855]: fs.js:115

```

---

<div class="post-metadata">

### Author: ![userR](https://avatars.discourse-cdn.com/v4/letter/u/22d042/32.png) [@userR](https://discuss.elastic.co/u/userR)
#### Post date: [July 22, 2019, 10:38pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/12 "2019-07-22T22:38:04Z")

</div>

```
Jul 22 15:02:08 kibana[519]: Error: EACCES: permission denied, open '/usr/share/kibana/optimize/.babelcache.json'

Jul 22 15:02:08 kibana[519]: at Object.openSync (fs.js:439:3)

Jul 22 15:02:08 kibana[519]: at Object.writeFileSync (fs.js:1190:35)

Jul 22 15:02:08 kibana[519]: at save (/usr/share/kibana/node_modules/@babel/register/lib/cache.js:52:15)

Jul 22 15:02:08 kibana[519]: at process._tickCallback (internal/process/next_tick.js:61:11)

Jul 22 15:02:08 systemd[1]: **kibana.service: main process exited, code=exited, status=1/FAILURE**

```

@jbudz my bad! It's outputted above.

---

<div class="post-metadata">

### Author: ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)
#### Post date: [July 23, 2019, 5:38pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/13 "2019-07-23T17:38:56Z")

</div>

cool. this is usually caused by installing a plugin as root. it's a tough fix on the kibana side and something we're working on.

in the interim we usually recommend installing plugins as the kibana user `sudo -u kibana bin/kibana-plugin install...`

you can fix this in the meantime with `sudo chmown kibana:kibana /usr/share/kibana/optimize/.babelcache.json`

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 20, 2019, 5:38pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/14 "2019-08-20T17:38:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
