# Kibana service failed to start

**URL:** <https://discuss.elastic.co/t/kibana-service-failed-to-start/296334>\
**Category:** Kibana\
**Created:** [February 4, 2022, 6:16pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/296334 "2022-02-04T18:16:33Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![gabal007](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabal007/32/101392_2.png) [@gabal007](https://discuss.elastic.co/u/gabal007)\
**Post date:** [February 4, 2022, 6:16pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/296334/1 "2022-02-04T18:16:34Z")

</div>

Hi all, I hope that message finds you well.

I have installed elk version 7.17 on CentOS Linux release 7.9.2009.  
I've tried to install kibana as a service, and it's failing to start.  
Based on what I'm reading on other threads, it seems it's because I've started the service as root.  
I'd appreciate some help on how to fix this please.

```auto
[root@BNH-ELK-LOG yum.repos.d]# sudo systemctl status kibana.service 
● kibana.service - Kibana
   Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Fri 2022-02-04 12:09:36 EST; 6min ago
     Docs: https://www.elastic.co
 Main PID: 25452 (code=exited, status=1/FAILURE)

Feb 04 12:09:33 BNH-ELK-LOG.binuh.dpko.un.org systemd[1]: kibana.service: main process exited, code=exited, status=1/FAILURE
Feb 04 12:09:33 BNH-ELK-LOG.binuh.dpko.un.org systemd[1]: Unit kibana.service entered failed state.
Feb 04 12:09:33 BNH-ELK-LOG.binuh.dpko.un.org systemd[1]: kibana.service failed.
Feb 04 12:09:36 BNH-ELK-LOG.binuh.dpko.un.org systemd[1]: kibana.service holdoff time over, scheduling restart.
Feb 04 12:09:36 BNH-ELK-LOG.binuh.dpko.un.org systemd[1]: Stopped Kibana.
Feb 04 12:09:36 BNH-ELK-LOG.binuh.dpko.un.org systemd[1]: start request repeated too quickly for kibana.service
Feb 04 12:09:36 BNH-ELK-LOG.binuh.dpko.un.org systemd[1]: Failed to start Kibana.
Feb 04 12:09:36 BNH-ELK-LOG.binuh.dpko.un.org systemd[1]: Unit kibana.service entered failed state.
Feb 04 12:09:36 BNH-ELK-LOG.binuh.dpko.un.org systemd[1]: kibana.service failed.

```

---

<div class="post-metadata">

**Author:** ![gabal007](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabal007/32/101392_2.png) [@gabal007](https://discuss.elastic.co/u/gabal007)\
**Post date:** [February 21, 2022, 5:28pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/296334/2 "2022-02-21T17:28:45Z")

</div>

@jbudz I hope you don't mind me tagging you on this. You provided some very useful help on the thread below: [Kibana Service Failed to start - #13 by jbudz](https://discuss.elastic.co/t/kibana-service-failed-to-start/191702/13)

I was hoping you could give me some feedback on how to fix my issue 🙂

---

<div class="post-metadata">

**Author:** ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)\
**Post date:** [February 22, 2022, 4:26pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/296334/3 "2022-02-22T16:26:50Z")

</div>

Hey,

Can you share any error logs in `/var/log/kibana/kibana.log`?

---

<div class="post-metadata">

**Author:** ![gabal007](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabal007/32/101392_2.png) [@gabal007](https://discuss.elastic.co/u/gabal007)\
**Post date:** [February 22, 2022, 4:48pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/296334/4 "2022-02-22T16:48:36Z")

</div>

Thank yo u for the quick reply.  
Let me know if you need anything else.

```auto
[netadmin@BNH-ELK-LOG ~]$ sudo cat /var/log/kibana/kibana.log
[sudo] password for netadmin: 
{"type":"log","@timestamp":"2022-02-04T12:17:01-05:00","tags":["info","plugins-service"],"pid":27647,"message":"Plugin \"metricsEntities\" is disabled."}
{"type":"log","@timestamp":"2022-02-04T12:18:21-05:00","tags":["info","plugins-service"],"pid":28069,"message":"Plugin \"metricsEntities\" is disabled."}
{"type":"log","@timestamp":"2022-02-04T12:41:26-05:00","tags":["info","plugins-service"],"pid":1334,"message":"Plugin \"metricsEntities\" is disabled."}
{"type":"log","@timestamp":"2022-02-21T12:18:24-05:00","tags":["info","plugins-service"],"pid":14830,"message":"Plugin \"metricsEntities\" is disabled."}
{"type":"log","@timestamp":"2022-02-22T11:46:27-05:00","tags":["info","plugins-service"],"pid":13557,"message":"Plugin \"metricsEntities\" is disabled."}
[netadmin@BNH-ELK-LOG ~]$

```

---

<div class="post-metadata">

**Author:** ![gabal007](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabal007/32/101392_2.png) [@gabal007](https://discuss.elastic.co/u/gabal007)\
**Post date:** [March 3, 2022, 1:15pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/296334/5 "2022-03-03T13:15:04Z")

</div>

@jbudz what are your thoughts? 🙂

---

<div class="post-metadata">

**Author:** ![gabal007](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabal007/32/101392_2.png) [@gabal007](https://discuss.elastic.co/u/gabal007)\
**Post date:** [March 18, 2022, 1:58pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/296334/6 "2022-03-18T13:58:25Z")

</div>

ok, so here's what I've tried so far:  
in kibana.yml:  
server.port: 5601  
server.host: "0.0.0.0"

I changed the Elasticsearch username and pwd to the following:

Elasticsearch.username: "elastic"  
Elasticsearch.password: "changeme"

I activated the following firewall ports:

sudo firewall-cmd --permanent --zone=public --add-port=9200/tcp  
sudo firewall-cmd --permanent --zone=public --add-port=5601/tcp  
sudo firewall-cmd --reload

Not much has changed so far.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 15, 2022, 1:59pm UTC](https://discuss.elastic.co/t/kibana-service-failed-to-start/296334/7 "2022-04-15T13:59:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
