# Kibana起動時に「 Setup lifecycle of "apm" plugin wasn't completed in 30sec.」というエラーが出て起動できません。

**URL:** <https://discuss.elastic.co/t/kibana-setup-lifecycle-of-apm-plugin-wasnt-completed-in-30sec/221374>\
**Category:** 日本語による質問・議論はこちら\
**Created:** [February 28, 2020, 7:07am UTC](https://discuss.elastic.co/t/kibana-setup-lifecycle-of-apm-plugin-wasnt-completed-in-30sec/221374 "2020-02-28T07:07:18Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![tsgkdt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsgkdt/32/39151_2.png) [@tsgkdt](https://discuss.elastic.co/u/tsgkdt)\
**Post date:** [February 28, 2020, 1:17pm UTC](https://discuss.elastic.co/t/kibana-setup-lifecycle-of-apm-plugin-wasnt-completed-in-30sec/221374/2 "2020-02-28T13:17:37Z")

</div>

過去のバージョンでは動いていたのに、7.6.0だと動かなくなった、と言っている人が↓にいます。

> [@Kibana 7.6.0 not starting because cannot install APM plugin](https://discuss.elastic.co/t/kibana-7-6-0-not-starting-because-cannot-install-apm-plugin/219807/1):
>
> Hello. I'm working on upgrading our Elastic setup to version 7.6.0 and I'm having issues with Kibana startup. What I see in the logs is that Kibana is not able to install the "apm" plugin within the default 30 seconds (see logs below). Here are the logs: Feb 18 14:15:48 systemd[1]: Started Kibana. Feb 18 14:15:52 kibana[8900]: {"type":"log","@timestamp":"2020-02-18T14:15:52Z","tags":["info","plugins-service"],"pid":8900,"message":"Plugin \"case\" is disabled."} Feb 18 14:15:56 kibana[8900]: {"…

ここでは、discovery.seedおよびcluster.initial\_master\_nodeを修正すると動くようになった、  
と書いている人がいますが、  
まずはElasticsearch側のログでどのようなものが出ているか、これを確認するのが良さそうです。

こちらのElasticメンバーの方の投稿が参考になるかと思います。

> [@Kibana 7.6.0 not starting because cannot install APM plugin](https://discuss.elastic.co/t/kibana-7-6-0-not-starting-because-cannot-install-apm-plugin/219807/9):
>
> Error: Setup lifecycle of "apm" plugin wasn't completed in 30sec. Consider disabling the plugin and re-start. When Kibana starts a plugin it goes through several lifecycles, setup, start and finally stop. This error indicates that Kibana was unable to "setup" the APM plugin. The only way to get past this error is to disable the plugin (not possible because of the bug) or get the plugin to start working. Getting the plugin to work Can you paste your elasticsearch logs from when Kibana starts …

何かヒントが見つかれば幸いです。

---

_[View the full topic](https://discuss.elastic.co/t/kibana-setup-lifecycle-of-apm-plugin-wasnt-completed-in-30sec/221374)._
