# Kibana startup failing after upgrading to Alpha 2

**URL:** <https://discuss.elastic.co/t/kibana-startup-failing-after-upgrading-to-alpha-2/50602>\
**Category:** Kibana\
**Created:** [May 20, 2016, 9:38pm UTC](https://discuss.elastic.co/t/kibana-startup-failing-after-upgrading-to-alpha-2/50602 "2016-05-20T21:38:11Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mike\_Wurtz](https://avatars.discourse-cdn.com/v4/letter/m/c0e974/32.png) [@Mike\_Wurtz](https://discuss.elastic.co/u/Mike_Wurtz)\
**Post date:** [May 20, 2016, 9:38pm UTC](https://discuss.elastic.co/t/kibana-startup-failing-after-upgrading-to-alpha-2/50602/1 "2016-05-20T21:38:11Z")

</div>

From the kibana logs:

`log [21:34:55.708] [error][status][plugin:reporting] Status changed from uninitialized to red - Command failed: tar jxf /opt/kibana/installedPlugins/x-pack/.phantom/phantomjs-1.9.8-linux-x86_64.tar.bz2 tar (child): bzip2: Cannot exec: No such file or directory tar (child): Error is not recoverable: exiting now tar: Child returned status 2 tar: Error is not recoverable: exiting now`

The Kibana service is failing to start because of this.. I've verified that the file does exist.. Any help would be appreciated.

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [May 20, 2016, 11:22pm UTC](https://discuss.elastic.co/t/kibana-startup-failing-after-upgrading-to-alpha-2/50602/2 "2016-05-20T23:22:09Z")

</div>

Can you try:

1. Make sure you have the bzip2 executables installed on the machine:

- `which bzip2`
- `which bunzip2`

1. Check the file permissions on the file that the process is trying to read:  
`ls -la installedPlugins/x-pack/.phantom`  
That will also list the permissions of the parent directory, where the decompressed files will need to be created.

If `bzip` is not installed on the machine, it will need to be. If it is a permissions issue, the `installedPlugins` directory ownership will need to be recursively changed to the user that runs the Kibana process.

---

<div class="post-metadata">

**Author:** ![Mike\_Wurtz](https://avatars.discourse-cdn.com/v4/letter/m/c0e974/32.png) [@Mike\_Wurtz](https://discuss.elastic.co/u/Mike_Wurtz)\
**Post date:** [May 22, 2016, 6:43am UTC](https://discuss.elastic.co/t/kibana-startup-failing-after-upgrading-to-alpha-2/50602/3 "2016-05-22T06:43:59Z")

</div>

Server was missing bzip2.. Works now.. Thanks.

---

<div class="post-metadata">

**Author:** ![AJ\_2](https://avatars.discourse-cdn.com/v4/letter/a/ac8455/32.png) [@AJ\_2](https://discuss.elastic.co/u/AJ_2)\
**Post date:** [June 8, 2016, 1:34pm UTC](https://discuss.elastic.co/t/kibana-startup-failing-after-upgrading-to-alpha-2/50602/4 "2016-06-08T13:34:22Z")

</div>

Hi, I got a similar error on alpha3.

plugin:reporting  
[http://pastebin.com/2D0Q5n3h](http://pastebin.com/2D0Q5n3h)

```
/opt/kibana/installedPlugins/x-pack/.phantom$ ls -la
total 42564
drwxr-xr-x 2 root root 4096 Jun 8 14:58 .
drwxr-xr-x 6 root root 4096 Jun 8 14:58 ..
-rw-r--r-- 1 root root 0 Jun 8 14:58 .empty
-rw-r--r-- 1 root root 13517724 Jun 8 14:58 phantomjs-1.9.8-linux-i686.tar.bz2
-rw-r--r-- 1 root root 13163325 Jun 8 14:58 phantomjs-1.9.8-linux-x86_64.tar.bz2
-rw-r--r-- 1 root root 9408114 Jun 8 14:58 phantomjs-1.9.8-macosx.zip
-rw-r--r-- 1 root root 7467786 Jun 8 14:58 phantomjs-1.9.8-windows.zip
```

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [June 8, 2016, 3:56pm UTC](https://discuss.elastic.co/t/kibana-startup-failing-after-upgrading-to-alpha-2/50602/5 "2016-06-08T15:56:24Z")

</div>

This will be fixed in a future version of X-Pack, so that the Reporting plugin won't rely on a system-installed bzip2 on Linux.

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [June 8, 2016, 4:23pm UTC](https://discuss.elastic.co/t/kibana-startup-failing-after-upgrading-to-alpha-2/50602/6 "2016-06-08T16:23:29Z")

</div>

AJ\_2, your error looks to be a different type, a permissions error. That looks related to these issues:

> <https://github.com/elastic/kibana/issues/6730>

  

> <https://github.com/elastic/kibana/issues/7157>

---

<div class="post-metadata">

**Author:** ![AJ\_2](https://avatars.discourse-cdn.com/v4/letter/a/ac8455/32.png) [@AJ\_2](https://discuss.elastic.co/u/AJ_2)\
**Post date:** [June 8, 2016, 5:05pm UTC](https://discuss.elastic.co/t/kibana-startup-failing-after-upgrading-to-alpha-2/50602/7 "2016-06-08T17:05:59Z")

</div>

I'm playing a bit more with this and I figured out the problem with permissions might be broader.

I added: `logging.dest: /var/log/kibana.log` to kibana.yml. That prevents kibana from starting. I fails with a permition error: `Error: EACCES: permission denied, open '/var/log/kibana.log'`  
In case it is expected behavior that the log file should be owned by a kibana user it should state so in the comments. This also makes me wonder if any other configs are subjected to the same problems (pid files, certificates etc.).

I tried to run it "manually" with `sudo bin/kibana` and the permissions problems (reporting plugin, custom log file) went away. So I came to the conclusion that `sudo service kibana start` just runs it without the necessary permissions to actually work.

I've installed it as a deb package on a Ubuntu 16 OS.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:51pm UTC](https://discuss.elastic.co/t/kibana-startup-failing-after-upgrading-to-alpha-2/50602/8 "2017-07-06T13:51:08Z")

</div>


