# Kibana state become yellow after upgrade to version 7.16.2

**URL:** <https://discuss.elastic.co/t/kibana-state-become-yellow-after-upgrade-to-version-7-16-2/293242>\
**Category:** Kibana\
**Tags:** elastic-stack-monitoring\
**Created:** [December 31, 2021, 7:45am UTC](https://discuss.elastic.co/t/kibana-state-become-yellow-after-upgrade-to-version-7-16-2/293242 "2021-12-31T07:45:49Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ZiaulAfiq](https://avatars.discourse-cdn.com/v4/letter/z/22d042/32.png) [@ZiaulAfiq](https://discuss.elastic.co/u/ZiaulAfiq)\
**Post date:** [December 31, 2021, 7:45am UTC](https://discuss.elastic.co/t/kibana-state-become-yellow-after-upgrade-to-version-7-16-2/293242/1 "2021-12-31T07:45:49Z")

</div>

Greetings all!  
I have encountered with this problem when I upgrading my Kibana from version 7.15.2 to 7.16.2  
When looking at the status, some of the plugins shows yellow state. These are the plugins that are affected due to the upgrade.

 ![Kibana-Error](https://us1.discourse-cdn.com/elastic/original/3X/f/9/f95469ddfeb8217c6fc43d8d2daba43834349097.png)

 ![Kibana-Error-1](https://us1.discourse-cdn.com/elastic/original/3X/e/2/e2a0bb226b8749bc305e75f539632ccd20ff3156.png)

On the side note, I have also created a new kibana encryption key using `bin/kibana-plugin generate` to create a new savedObject key inside `kibana.yml`

Is there any explanation due to this Kibana behaviour?

---

<div class="post-metadata">

**Author:** ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)\
**Post date:** [December 31, 2021, 10:31am UTC](https://discuss.elastic.co/t/kibana-state-become-yellow-after-upgrade-to-version-7-16-2/293242/2 "2021-12-31T10:31:03Z")

</div>

Hello,

Is your Kibana functional and operational? Do you see anything in the logs?

Thanks,  
Bhavya

---

<div class="post-metadata">

**Author:** ![ZiaulAfiq](https://avatars.discourse-cdn.com/v4/letter/z/22d042/32.png) [@ZiaulAfiq](https://discuss.elastic.co/u/ZiaulAfiq)\
**Post date:** [December 31, 2021, 5:26pm UTC](https://discuss.elastic.co/t/kibana-state-become-yellow-after-upgrade-to-version-7-16-2/293242/3 "2021-12-31T17:26:08Z")

</div>

Hi @bhavyarm! Currently my Kibana is fully functional & operational but as for logs, these were shown in my console:

```auto
{"type":"log","@timestamp":"2021-12-31T15:59:46+08:00","tags":["error","plugins","encryptedSavedObjects"],"pid":5596,"message":"Failed to decrypt \"apiKey\" attribute: Unsupported state or unable to authenticate data"}

```

If I try to re-install the plugin using this command: `bin/kibana-plugin install apm`  
The output on the console shows no url was found.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 28, 2022, 5:26pm UTC](https://discuss.elastic.co/t/kibana-state-become-yellow-after-upgrade-to-version-7-16-2/293242/4 "2022-01-28T17:26:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
