# Kibana status is Yellow due to plugins degraded (after upgrade to version 8.8.2)

**URL:** <https://discuss.elastic.co/t/kibana-status-is-yellow-due-to-plugins-degraded-after-upgrade-to-version-8-8-2/342901>\
**Category:** Kibana\
**Created:** [September 13, 2023, 4:11am UTC](https://discuss.elastic.co/t/kibana-status-is-yellow-due-to-plugins-degraded-after-upgrade-to-version-8-8-2/342901 "2023-09-13T04:11:52Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![chethan\_m](https://avatars.discourse-cdn.com/v4/letter/c/3ec8ea/32.png) [@chethan\_m](https://discuss.elastic.co/u/chethan_m)\
**Post date:** [September 13, 2023, 4:11am UTC](https://discuss.elastic.co/t/kibana-status-is-yellow-due-to-plugins-degraded-after-upgrade-to-version-8-8-2/342901/1 "2023-09-13T04:11:52Z")

</div>

Hi,  
I just upgraded elasticseach/ kibana to 8.8.2. Cluster health is Green.  
But Kibana status is Yellow (when I navigate to http:///status )  
What is see is there are lot of plugins in yellow status with the message **degraded**

Can someone guide me how to resolve this issue ?

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/e/2/e2cdcb250cbb8626f1089c51a2ddf8a33fd2731d.png)

**One of Kibana Log at kubernetes pod level -**

```auto
[2023-09-13T03:37:25.766+00:00][ERROR][plugins.alerting.metrics.alert.threshold] Executing Rule sales-and-service-cloud-monitoring:metrics.alert.threshold:4156c8df-16e3-5385-93cd-5e53c3a4e96c has resulted in Error: Rule failed to execute because rule ran after it was disabled. - Error: Rule failed to execute because rule ran after it was disabled.
    at loadRule (/usr/share/kibana/node_modules/@kbn/alerting-plugin/server/task_runner/rule_loader.js:46:11)
    at TaskRunner.prepareToRun (/usr/share/kibana/node_modules/@kbn/alerting-plugin/server/task_runner/task_runner.js:447:12)
    at TaskRunnerTimer.runWithTimer (/usr/share/kibana/node_modules/@kbn/alerting-plugin/server/task_runner/task_runner_timer.js:49:20)
    at TaskRunner.run (/usr/share/kibana/node_modules/@kbn/alerting-plugin/server/task_runner/task_runner.js:554:30)
    at TaskManagerRunner.run (/usr/share/kibana/node_modules/@kbn/task-manager-plugin/server/task_running/task_runner.js:274:22)

```

I see similar issue reported earlier by other members, but no mention about solution.

> [@Kibana status shows yellow because plugins are degraded after upgrading from 7.9 to 7.16.3](https://discuss.elastic.co/t/kibana-status-shows-yellow-because-plugins-are-degraded-after-upgrading-from-7-9-to-7-16-3/300361):
>
> Hi. I have been looking for answers in various forums for this. I looked into individual plugins dependencies and looks like alerting plugin might be the cause for all this. But I am unable find a solution. There was a few errors in the log file Can you please help me with this. I need to find a workaround ASAP. Thanks

@ [bhavyarm](https://discuss.elastic.co/u/bhavyarm) can you please guide how the issue was resolved in your case ?

Thanks,  
Chethan

---

<div class="post-metadata">

**Author:** ![chethan\_m](https://avatars.discourse-cdn.com/v4/letter/c/3ec8ea/32.png) [@chethan\_m](https://discuss.elastic.co/u/chethan_m)\
**Post date:** [September 13, 2023, 5:33am UTC](https://discuss.elastic.co/t/kibana-status-is-yellow-due-to-plugins-degraded-after-upgrade-to-version-8-8-2/342901/2 "2023-09-13T05:33:18Z")

</div>

@ [francescouk](https://discuss.elastic.co/u/francescouk)  
You had a similar issue. How was that resovled ?

> [@Kibana Plugins Degraded](https://discuss.elastic.co/t/kibana-plugins-degraded/309748/2):
>
> Hi Francesco, Can you check your Elasticsearch cluster for any issues. One problem that can happen is that disk drives get above a high water mark and that makes indices turn to read-only mode. If you have monitoring enabled and if that's working, that would be a good place to check. If Kibana monitoring isn't enabled or isn't working because of those degraded plugins, you might have to use curl commands something like this (you may have to add -u username:password); curl -XGET "https://lo…

Can you please guide ?

Thanks,  
Chethan

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 11, 2023, 5:33am UTC](https://discuss.elastic.co/t/kibana-status-is-yellow-due-to-plugins-degraded-after-upgrade-to-version-8-8-2/342901/3 "2023-10-11T05:33:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
