# Kibana\_system user ID is unable to connect to elasticsearch

**URL:** https://discuss.elastic.co/t/kibana-system-user-id-is-unable-to-connect-to-elasticsearch/335623
**Category:** Kibana
**Created:** [June 9, 2023, 11:19am UTC](https://discuss.elastic.co/t/kibana-system-user-id-is-unable-to-connect-to-elasticsearch/335623 "2023-06-09T11:19:46Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![swchandu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/swchandu/32/95295_2.png) [@swchandu](https://discuss.elastic.co/u/swchandu)
#### Post date: [June 9, 2023, 11:19am UTC](https://discuss.elastic.co/t/kibana-system-user-id-is-unable-to-connect-to-elasticsearch/335623/1 "2023-06-09T11:19:46Z")

</div>

Hi,

I have created a new Elasticsearch cluster 8.8.0(on Linux) and tried to start kibana. But found this error for the first time.  
BTW, kibana\_system/new id's password is set already with APIs.

kibana.yml

server.port: 5601  
server.host: 0.0.0.0  
elasticsearch.username: "kib\_admin"  
elasticsearch.password: "kib\_admin"  
elasticsearch.hosts: [[https://srv.fqdn:9200](https://srv.fqdn:9200)]  
elasticsearch.ssl.verificationMode: none  
elasticsearch.requestTimeout: 30000  
xpack.actions.enabledActionTypes: ["\*"]  
xpack.encryptedSavedObjects.encryptionKey: xxxxxxxxxxxxxxxxxxxxxxxx  
xpack.reporting.encryptionKey: xxxxxxxxxxxxxxxxxxxxxx  
xpack.security.encryptionKey: xxxxxxxxxxxxxxxxxxxxxx  
xpack.reporting.kibanaServer.hostname: kibana.fqdn  
server.ssl.enabled: true  
server.ssl.certificate: /usr/share/kibana/config/node1.pem  
server.ssl.key: /usr/share/kibana/config/node1.key  
server.ssl.supportedProtocols: [TLSv1.2, TLSv1.3]  
xpack.security.cookieName: "somesid"  
server.securityResponseHeaders.strictTransportSecurity: "max-age=31536000"  
server.securityResponseHeaders.disableEmbedding: true  
csp.strict: true

Error:

[2023-06-09T10:50:52.848+00:00][FATAL][root] ResponseError: security\_exception  
Root causes:  
security\_exception: unable to authenticate user [kib\_admin] for REST request [/\_cluster/settings?include\_defaults=true&flat\_settings=true]  
at KibanaTransport.request (/usr/share/kibana/node\_modules/@elastic/transport/lib/Transport.js:479:27)  
at processTicksAndRejections (node:internal/process/task\_queues:96:5)  
at KibanaTransport.request (/usr/share/kibana/node\_modules/@kbn/core-elasticsearch-client-server-internal/src/create\_transport.js:51:16)  
at Cluster.getSettings (/usr/share/kibana/node\_modules/@elastic/elasticsearch/lib/api/api/cluster.js:157:16)  
at isInlineScriptingEnabled (/usr/share/kibana/node\_modules/@kbn/core-elasticsearch-server-internal/src/is\_scripting\_enabled.js:20:20)  
at ElasticsearchService.start (/usr/share/kibana/node\_modules/@kbn/core-elasticsearch-server-internal/src/elasticsearch\_service.js:115:32)  
at Server.start (/usr/share/kibana/node\_modules/@kbn/core-root-server-internal/src/server.js:339:32)  
at Root.start (/usr/share/kibana/node\_modules/@kbn/core-root-server-internal/src/root/index.js:64:14)  
at bootstrap (/usr/share/kibana/node\_modules/@kbn/core-root-server-internal/src/bootstrap.js:129:5)  
at Command. (/usr/share/kibana/src/cli/serve/serve.js:272:5)  
[2023-06-09T10:50:52.855+00:00][INFO][plugins-system.preboot] Stopping all plugins.  
[2023-06-09T10:50:52.856+00:00][INFO][plugins-system.standard] Stopping all plugins.  
[2023-06-09T10:50:52.857+00:00][INFO][plugins.monitoring.monitoring.kibana-monitoring] Monitoring stats collection is stopped  
[2023-06-09T10:50:52.860+00:00][ERROR][plugins.ruleRegistry] Error: Server is stopping; must stop all async operations  
at /usr/share/kibana/node\_modules/@kbn/alerting-plugin/server/alerts\_service/lib/install\_with\_timeout.js:40:18  
at processTicksAndRejections (node:internal/process/task\_queues:96:5)  
[2023-06-09T10:50:52.861+00:00][ERROR][plugins.ruleRegistry] Error: Failure during installation of common resources shared between all indices. Server is stopping; must stop all async operations

Is this method user ID/password authentication deprecated? Can someone suggest what I am doing wrong

Regards,

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [June 13, 2023, 1:10am UTC](https://discuss.elastic.co/t/kibana-system-user-id-is-unable-to-connect-to-elasticsearch/335623/2 "2023-06-13T01:10:16Z")

</div>

Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

Can you successfully curl Elasticsearch with the details you are defining in your Kibana config?

---

<div class="post-metadata">

### Author: ![swchandu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/swchandu/32/95295_2.png) [@swchandu](https://discuss.elastic.co/u/swchandu)
#### Post date: [June 13, 2023, 4:52am UTC](https://discuss.elastic.co/t/kibana-system-user-id-is-unable-to-connect-to-elasticsearch/335623/3 "2023-06-13T04:52:10Z")

</div>

Yup.  
{  
"name" : "SRV1",  
"cluster\_name" : "cluster1",  
"cluster\_uuid" : "4Efb8tJpSW6X8Gzipbm-yA",  
"version" : {  
"number" : "8.8.0",  
"build\_flavor" : "default",  
"build\_type" : "docker",  
"build\_hash" : "c01029875a091076ed42cdb3a41c10b1a9a5a20f",  
"build\_date" : "2023-05-23T17:16:07.179039820Z",  
"build\_snapshot" : false,  
"lucene\_version" : "9.6.0",  
"minimum\_wire\_compatibility\_version" : "7.17.0",  
"minimum\_index\_compatibility\_version" : "7.0.0"  
},  
"tagline" : "You Know, for Search"  
}

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 11, 2023, 4:52am UTC](https://discuss.elastic.co/t/kibana-system-user-id-is-unable-to-connect-to-elasticsearch/335623/4 "2023-07-11T04:52:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
