# Kibana The aggregations key is missing from the response ERROR

**URL:** <https://discuss.elastic.co/t/kibana-the-aggregations-key-is-missing-from-the-response-error/147717>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [September 7, 2018, 1:24pm UTC](https://discuss.elastic.co/t/kibana-the-aggregations-key-is-missing-from-the-response-error/147717 "2018-09-07T13:24:23Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![jabu](https://avatars.discourse-cdn.com/v4/letter/j/f4b2a3/32.png) [@jabu](https://discuss.elastic.co/u/jabu)\
**Post date:** [September 7, 2018, 1:24pm UTC](https://discuss.elastic.co/t/kibana-the-aggregations-key-is-missing-from-the-response-error/147717/1 "2018-09-07T13:24:23Z")

</div>

Hi i just followed this tutorial: [Starting with the Elasticsearch Platform and its Solutions | Elastic](https://www.elastic.co/guide/en/elastic-stack-get-started/current/get-started-elastic-stack.html)

To set up a little ELK-stack on my Ubuntu VM. I used metricbeats so that i could monitor my VM as practice.  
My Kibana dashboard is showing me:

> The request for this panel failed. The aggregations key is missing from the response

on all views, so no data is visible.

Any idea what could cause this?  
No Kibana logs whatsoever.

 ![kibanakak](https://us1.discourse-cdn.com/elastic/original/3X/a/2/a2febfafdd161234d0c481c7fd98e0cd6a1ef31b.png)

---

<div class="post-metadata">

**Author:** ![Mario\_Castro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mario_castro/32/35107_2.png) [@Mario\_Castro](https://discuss.elastic.co/u/Mario_Castro)\
**Post date:** [September 10, 2018, 8:32am UTC](https://discuss.elastic.co/t/kibana-the-aggregations-key-is-missing-from-the-response-error/147717/2 "2018-09-10T08:32:35Z")

</div>

Hi @jabu

I've just followed the tutorial step by step to try to reproduce the problem but it worked on my Arch system

I'd suggest to double check that you are running metricbeat as root. Also that you have enabled system module by running `sudo metricbeat modules enable system` and that you have done the setup too by using `sudo metricbeat setup -e`

---

<div class="post-metadata">

**Author:** ![jabu](https://avatars.discourse-cdn.com/v4/letter/j/f4b2a3/32.png) [@jabu](https://discuss.elastic.co/u/jabu)\
**Post date:** [September 10, 2018, 9:25am UTC](https://discuss.elastic.co/t/kibana-the-aggregations-key-is-missing-from-the-response-error/147717/3 "2018-09-10T09:25:59Z")

</div>

It's working now, i must've forgotten a step. Thanks for the help!

Problem solved

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 8, 2018, 9:25am UTC](https://discuss.elastic.co/t/kibana-the-aggregations-key-is-missing-from-the-response-error/147717/4 "2018-10-08T09:25:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
