# Kibana throws error while creating index pattern

**URL:** <https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932>\
**Category:** Logstash\
**Created:** [July 13, 2020, 9:05am UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932 "2020-07-13T09:05:14Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sai\_Avinash\_Duddupud](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sai_avinash_duddupud/32/48265_2.png) [@Sai\_Avinash\_Duddupud](https://discuss.elastic.co/u/Sai_Avinash_Duddupud)\
**Post date:** [July 13, 2020, 9:05am UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932/1 "2020-07-13T09:05:14Z")

</div>

I have setup logstash on **server1** which is sending data to elastic-search( **server2** ) so that I visualise the same in Kibana but when I am creating index patter it throws **Internal Server Error** as show in the **following image.**

Please suggest how to fix this?

[![enter image description here](https://i.stack.imgur.com/x2jUw.png)](https://i.stack.imgur.com/x2jUw.png)

---

<div class="post-metadata">

**Author:** ![flash1293](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/flash1293/32/41227_2.png) [@flash1293](https://discuss.elastic.co/u/flash1293)\
**Post date:** [July 13, 2020, 10:33am UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932/2 "2020-07-13T10:33:51Z")

</div>

Can you check the logs of the Kibana server? There should be more info in there.

---

<div class="post-metadata">

**Author:** ![Sai\_Avinash\_Duddupud](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sai_avinash_duddupud/32/48265_2.png) [@Sai\_Avinash\_Duddupud](https://discuss.elastic.co/u/Sai_Avinash_Duddupud)\
**Post date:** [July 13, 2020, 10:35am UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932/3 "2020-07-13T10:35:56Z")

</div>

@flash1293

The above error is due to the following erros in logstash logs

```auto
[INFO] 2020-07-13 07:29:08.401 [[main]>worker0] elasticsearch - retrying failed action with response code: 429 ({"type"=>"cluster_block_exception", "reason"=>"index [blend] blocked by: [TOO_MANY_REQUESTS/12/index read-only / allow delete (api)];"})
[INFO] 2020-07-13 07:29:08.402 [[main]>worker0] elasticsearch - retrying failed action with response code: 429 ({"type"=>"cluster_block_exception", "reason"=>"index [blend] blocked by: [TOO_MANY_REQUESTS/12/index read-only / allow delete (api)];"})
[INFO] 2020-07-13 07:29:08.402 [[main]>worker0] elasticsearch - Retrying individual bulk actions that failed or were rejected by the previous bulk request. {:count=>2}

```

and after some searching, I found [this](https://discuss.elastic.co/t/solved-forbidden-to-create-index-pattern-in-kibana-7-2/190947) link and used the below command and it worked well

```
curl -XPUT -H "Content-Type: application/json" https://[YOUR_ELASTICSEARCH_ENDPOINT]:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}'

```

But again after **10 min or so** , I started getting above errors in logstash and I hit the curl command again. this is happening very frequently.

Is there **any permanent fix for this otherwise I had to hit the curl command many times** every 20 min or so

---

<div class="post-metadata">

**Author:** ![flash1293](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/flash1293/32/41227_2.png) [@flash1293](https://discuss.elastic.co/u/flash1293)\
**Post date:** [July 13, 2020, 10:38am UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932/4 "2020-07-13T10:38:34Z")

</div>

If this is a logstash error, please post this question in the Logstash category.

---

<div class="post-metadata">

**Author:** ![Sai\_Avinash\_Duddupud](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sai_avinash_duddupud/32/48265_2.png) [@Sai\_Avinash\_Duddupud](https://discuss.elastic.co/u/Sai_Avinash_Duddupud)\
**Post date:** [July 13, 2020, 10:39am UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932/5 "2020-07-13T10:39:58Z")

</div>

Updated the tags...

---

<div class="post-metadata">

**Author:** ![Jenni](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jenni/32/29684_2.png) [@Jenni](https://discuss.elastic.co/u/Jenni)\
**Post date:** [July 13, 2020, 10:55am UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932/6 "2020-07-13T10:55:24Z")

</div>

Are you running out of disk space?

---

<div class="post-metadata">

**Author:** ![Sai\_Avinash\_Duddupud](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sai_avinash_duddupud/32/48265_2.png) [@Sai\_Avinash\_Duddupud](https://discuss.elastic.co/u/Sai_Avinash_Duddupud)\
**Post date:** [July 13, 2020, 1:44pm UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932/7 "2020-07-13T13:44:02Z")

</div>

yes, low disk space is the reason.... will increase it

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 10, 2020, 1:44pm UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932/8 "2020-08-10T13:44:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
