# Kibana throws error while creating index pattern

**URL:** <https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932>\
**Category:** Logstash\
**Created:** [July 13, 2020, 9:05am UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932 "2020-07-13T09:05:14Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![Sai\_Avinash\_Duddupud](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sai_avinash_duddupud/32/48265_2.png) [@Sai\_Avinash\_Duddupud](https://discuss.elastic.co/u/Sai_Avinash_Duddupud)\
**Post date:** [July 13, 2020, 10:35am UTC](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932/3 "2020-07-13T10:35:56Z")

</div>

@flash1293

The above error is due to the following erros in logstash logs

```auto
[INFO] 2020-07-13 07:29:08.401 [[main]>worker0] elasticsearch - retrying failed action with response code: 429 ({"type"=>"cluster_block_exception", "reason"=>"index [blend] blocked by: [TOO_MANY_REQUESTS/12/index read-only / allow delete (api)];"})
[INFO] 2020-07-13 07:29:08.402 [[main]>worker0] elasticsearch - retrying failed action with response code: 429 ({"type"=>"cluster_block_exception", "reason"=>"index [blend] blocked by: [TOO_MANY_REQUESTS/12/index read-only / allow delete (api)];"})
[INFO] 2020-07-13 07:29:08.402 [[main]>worker0] elasticsearch - Retrying individual bulk actions that failed or were rejected by the previous bulk request. {:count=>2}

```

and after some searching, I found [this](https://discuss.elastic.co/t/solved-forbidden-to-create-index-pattern-in-kibana-7-2/190947) link and used the below command and it worked well

```
curl -XPUT -H "Content-Type: application/json" https://[YOUR_ELASTICSEARCH_ENDPOINT]:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}'

```

But again after **10 min or so** , I started getting above errors in logstash and I hit the curl command again. this is happening very frequently.

Is there **any permanent fix for this otherwise I had to hit the curl command many times** every 20 min or so

---

_[View the full topic](https://discuss.elastic.co/t/kibana-throws-error-while-creating-index-pattern/240932)._
