# Kibana to Elastic search communication is ending up with failure

**URL:** https://discuss.elastic.co/t/kibana-to-elastic-search-communication-is-ending-up-with-failure/336438
**Category:** Kibana
**Created:** [June 20, 2023, 6:50am UTC](https://discuss.elastic.co/t/kibana-to-elastic-search-communication-is-ending-up-with-failure/336438 "2023-06-20T06:50:07Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![Deepaklal\_KB](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deepaklal_kb/32/122479_2.png) [@Deepaklal\_KB](https://discuss.elastic.co/u/Deepaklal_KB)
#### Post date: [June 20, 2023, 6:50am UTC](https://discuss.elastic.co/t/kibana-to-elastic-search-communication-is-ending-up-with-failure/336438/1 "2023-06-20T06:50:07Z")

</div>

Getting an error as ünable to get issuer certificate in kibana logs once after starting the service. I am using DigicertCA.crt file to communicate with mu Elastic server LB. Which is a SAN certificate. This is happening when verificationMode in Kibana as "certificate"or "full".

---

<div class="post-metadata">

### Author: ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)
#### Post date: [June 20, 2023, 8:46am UTC](https://discuss.elastic.co/t/kibana-to-elastic-search-communication-is-ending-up-with-failure/336438/2 "2023-06-20T08:46:57Z")

</div>

Hi @Deepaklal_KB,

Welcome to the community! It might be an issue with the signed certificate or configuration. I would recommend having a look at these issues and see if the fixes work for you:

1. [Kibana throws error “unable to get issuer certificate” while connecting to ElasticSearch](https://discuss.elastic.co/t/kibana-throws-error-unable-to-get-issuer-certificate-while-connecting-to-elasticsearch/119924)
2. [Kibana server is not ready yet, error : Unable to get issuer certificate - #2 by Yang\_Wang](https://discuss.elastic.co/t/kibana-server-is-not-ready-yet-error-unable-to-get-issuer-certificate/313218/2)

If those don't help, can you share your Kibana configuration and let us know how you are running Elasticsearch with the LB (Elastic Cloud Enterprise or ECK operator for example).

---

<div class="post-metadata">

### Author: ![Deepaklal\_KB](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deepaklal_kb/32/122479_2.png) [@Deepaklal\_KB](https://discuss.elastic.co/u/Deepaklal_KB)
#### Post date: [June 21, 2023, 3:47am UTC](https://discuss.elastic.co/t/kibana-to-elastic-search-communication-is-ending-up-with-failure/336438/3 "2023-06-21T03:47:53Z")

</div>

Hello @carly.richmond ,

No, both these solutions were not suitable in my case.  
Kibana.yml is shared below, In my case I have a Elasticsearch load balancer which is distributing the load between 3 nodes. Kibana is hitting that particular LB.

This connection I ma try to encrypt. by changing verificationmode to "full" or"certificate". That time I am getting the mentioned error.

One more input is , by hitting below URL with same certificate I am getting "Green" status from ES.

## Command

curl -v -u kibana --cacert /etc/kibana/certs/DigiCertCA.crt [https://prod.in.com:9200/\_cluster/health?pretty](https://prod.in.com:9200/_cluster/health?pretty) -u username:password

---

<div class="post-metadata">

### Author: ![Deepaklal\_KB](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deepaklal_kb/32/122479_2.png) [@Deepaklal\_KB](https://discuss.elastic.co/u/Deepaklal_KB)
#### Post date: [June 21, 2023, 3:56am UTC](https://discuss.elastic.co/t/kibana-to-elastic-search-communication-is-ending-up-with-failure/336438/4 "2023-06-21T03:56:27Z")

</div>

## Kibana.yml

```auto
# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "0.0.0.0"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# Specifies the public URL at which Kibana is available for end users. If
# `server.basePath` is configured this URL should end with the same basePath.
#server.publicBaseUrl: ""

# The maximum payload size in bytes for incoming server requests.
#server.maxPayload: 1048576

# The Kibana server's name. This is used for display purposes.
#server.name: "your-hostname"

# The URLs of the Elasticsearch instances to use for all your queries.

elasticsearch.hosts: ["https://prod.in.com:9200"]

elasticsearch.username: ${elasticsearch.username}
elasticsearch.password: ${elasticsearch.password}

server.ssl.enabled: true
server.ssl.certificate: /etc/kibana/deu-kibanalb_prod_db_com.crt
server.ssl.key: /etc/kibana/kibana.key #EditRequired

elasticsearch.ssl.certificateAuthorities: ["/etc/kibana/elastic/DigiCertCA.crt"] 

elasticsearch.ssl.verificationMode: full
path.data: /data/kibana/lib/kibana

```

---

<div class="post-metadata">

### Author: ![Deepaklal\_KB](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/deepaklal_kb/32/122479_2.png) [@Deepaklal\_KB](https://discuss.elastic.co/u/Deepaklal_KB)
#### Post date: [June 21, 2023, 5:12am UTC](https://discuss.elastic.co/t/kibana-to-elastic-search-communication-is-ending-up-with-failure/336438/6 "2023-06-21T05:12:18Z")

</div>

Note : Tried hitting one node of ES directly from Kibana.That also showing the same error.

---

<div class="post-metadata">

### Author: ![carly.richmond](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carly.richmond/32/104935_2.png) [@carly.richmond](https://discuss.elastic.co/u/carly.richmond)
#### Post date: [June 21, 2023, 9:42am UTC](https://discuss.elastic.co/t/kibana-to-elastic-search-communication-is-ending-up-with-failure/336438/7 "2023-06-21T09:42:23Z")

</div>

Do you have any intermediary certificates in the chain that you need to specify? This [Stack Overflow thread](https://stackoverflow.com/questions/72430152/elasticsearch-unable-to-get-issuer-certificate) might help if so.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 19, 2023, 9:42am UTC](https://discuss.elastic.co/t/kibana-to-elastic-search-communication-is-ending-up-with-failure/336438/8 "2023-07-19T09:42:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
