# Kibana unable to authenticate user \[elastic\]

**URL:** <https://discuss.elastic.co/t/kibana-unable-to-authenticate-user-elastic/325678>\
**Category:** Kibana\
**Tags:** elastic-stack-security, docker\
**Created:** [February 16, 2023, 3:11am UTC](https://discuss.elastic.co/t/kibana-unable-to-authenticate-user-elastic/325678 "2023-02-16T03:11:39Z")\
**Posts on this page:** 1\
**Showing post:** 2

<div class="post-metadata">

**Author:** ![chromus](https://avatars.discourse-cdn.com/v4/letter/c/ac91a4/32.png) [@chromus](https://discuss.elastic.co/u/chromus)\
**Post date:** [February 22, 2023, 10:46pm UTC](https://discuss.elastic.co/t/kibana-unable-to-authenticate-user-elastic/325678/2 "2023-02-22T22:46:03Z")

</div>

Found the solution myself thanks to:

> [@Authentication fails on a new node in a secure cluster](https://discuss.elastic.co/t/authentication-fails-on-a-new-node-in-a-secure-cluster/252517):
>
> Hello, I have an Elasticsearch cluster with 2 nodes, on which I enabled xpack security a while ago (TLS on both transport and HTTP + local authentication). I want to add a new node to the cluster, I configured the node with the transport and HTTP settings, I added the node in the discovery list on all the nodes. The node starts correctly but I cannot authenticate on it: curl https://SOC-V-DEV-ESNODE03:9200/\_xpack/security/\_authenticate?pretty -u elastic -k Enter host password for user 'elast…

I just needed to add the line:

```auto
- ELASTIC_PASSWORD=${ELASTIC_PASSWORD}

```

to node 2 and 3.

---

_[View the full topic](https://discuss.elastic.co/t/kibana-unable-to-authenticate-user-elastic/325678)._
