# Kibana unable to connect to elatsicsearch

**URL:** https://discuss.elastic.co/t/kibana-unable-to-connect-to-elatsicsearch/148673
**Category:** Elasticsearch
**Created:** [September 14, 2018, 7:16pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-elatsicsearch/148673 "2018-09-14T19:16:34Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![rmadoori](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@rmadoori](https://discuss.elastic.co/u/rmadoori)
#### Post date: [September 14, 2018, 7:16pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-elatsicsearch/148673/1 "2018-09-14T19:16:34Z")

</div>

Hi,

I am running Kibana with https

kibana.yml: |  
server:  
name: "elk-stack-example"  
host: 0.0.0.0  
port: 5601  
elasticsearch.url: "[http://es-master:9200](http://es-master:9200)"  
elasticsearch.requestTimeout: 180000  
server.ssl.certificate: /usr/share/kibana/certs/kibana.cert.pem  
server.ssl.key: /usr/share/kibana/certs/kibana.key.pem  
server.ssl.keyPassphrase: kibana  
server.ssl.enabled: true

kibana is stuck with below message  
{"type":"log","@timestamp":"2018-09-14T19:08:17Z","tags":["listening","info"],"pid":1,"message":"Server running at [https://0.0.0.0:5601](https://0.0.0.0:5601)"}

{"type":"log","@timestamp":"2018-09-14T19:08:18Z","tags":["status","plugin:elasticsearch@6.3.0","info"],"pid":1,"state":"green","message":"Status changed from yellow to green - Ready","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}

below conf with http endppoint works fine

kibana.yml: |  
server:  
name: "elk-stack-example"  
host: 0.0.0.0  
port: 5601  
elasticsearch.url: "[http://es-master:9200](http://es-master:9200)"

---

<div class="post-metadata">

### Author: ![rmadoori](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@rmadoori](https://discuss.elastic.co/u/rmadoori)
#### Post date: [September 14, 2018, 7:31pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-elatsicsearch/148673/2 "2018-09-14T19:31:36Z")

</div>

log [19:19:42.401] [error][status][plugin:elasticsearch@6.3.0] Status changed from yellow to red - Request Timeout after 3000ms  
error [19:20:59.391] [error][client][connection] Error: socket hang up  
at TLSSocket. (\_tls\_wrap.js:876:25)  
at emitOne (events.js:121:20)  
at TLSSocket.emit (events.js:211:7)  
at \_handle.close (net.js:567:12)  
at Socket.done (\_tls\_wrap.js:356:7)  
at Object.onceWrapper (events.js:315:30)  
at emitOne (events.js:121:20)  
at Socket.emit (events.js:211:7)  
at TCP.\_handle.close [as \_onclose] (net.js:567:12)  
error [19:20:59.396] [error][client][connection] Error: socket hang up  
at TLSSocket. (\_tls\_wrap.js:876:25)  
at emitOne (events.js:121:20)  
at TLSSocket.emit (events.js:211:7)  
at \_handle.close (net.js:567:12)  
at Socket.done (\_tls\_wrap.js:356:7)  
at Object.onceWrapper (events.js:315:30)  
at emitOne (events.js:121:20)  
at Socket.emit (events.js:211:7)  
at TCP.\_handle.close [as \_onclose] (net.js:567:12)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 12, 2018, 7:31pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-elatsicsearch/148673/3 "2018-10-12T19:31:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
