# Kibana unable to connect to local Elasticsearch: plugin:elasticsearch: Service Unavailable

**URL:** https://discuss.elastic.co/t/kibana-unable-to-connect-to-local-elasticsearch-plugin-elasticsearch-service-unavailable/38761
**Category:** Kibana
**Created:** [January 8, 2016, 9:01pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-local-elasticsearch-plugin-elasticsearch-service-unavailable/38761 "2016-01-08T21:01:14Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![jnpetty](https://avatars.discourse-cdn.com/v4/letter/j/ecc23a/32.png) [@jnpetty](https://discuss.elastic.co/u/jnpetty)
#### Post date: [January 8, 2016, 9:01pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-local-elasticsearch-plugin-elasticsearch-service-unavailable/38761/1 "2016-01-08T21:01:14Z")

</div>

I have an instance of Kibana that I am trying to connect to a Elasticsearch cluster. The Kibana server has a non-master and non-data instance of Elasticsearch configured as connected to the cluster. Here is the output of my ES cluster health:

```
  "cluster_name" : "Elasticsearch-Cluster-1",
  "status" : "green",
  "timed_out" : false,
  "number_of_nodes" : 4,
  "number_of_data_nodes" : 3,
  "active_primary_shards" : 2,
  "active_shards" : 4,
  "relocating_shards" : 0,
  "initializing_shards" : 0,
  "unassigned_shards" : 0,
  "delayed_unassigned_shards" : 0,
  "number_of_pending_tasks" : 0,
  "number_of_in_flight_fetch" : 0,
  "task_max_waiting_in_queue_millis" : 0,
  "active_shards_percent_as_number" : 100.0

```

As you can see there are 4 nodes, only 3 of them are data nodes. The fourth is my Kibana server, so it is connecting to the cluster just fine. In all four nodes of the ES configuration I have bind address setup as:

`network.host: _non_loopback:ipv4_`

In the Kibana configuration I have elasticsearch.url setup as the IP of my Kibana server:

`elasticsearch.url: "http://10.10.100.65:9200"`

Prior to changing the above setting to what you see I was getting an error saying `"Unable to connect to http://localhost:9200"`. Now the error just says `plugin:elasticsearch Service Unavailable`

Its not a firewall issue as all 4 node in the cluster have 9200/TCP and 9300/TCP open. I have confirmed this with an NMAP scan.

Anyone have any thoughts?

---

<div class="post-metadata">

### Author: ![jnpetty](https://avatars.discourse-cdn.com/v4/letter/j/ecc23a/32.png) [@jnpetty](https://discuss.elastic.co/u/jnpetty)
#### Post date: [January 8, 2016, 10:29pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-local-elasticsearch-plugin-elasticsearch-service-unavailable/38761/2 "2016-01-08T22:29:00Z")

</div>

If I point Kibana to one of the other 3 ES nodes in the cluster everything works perfectly. I am not sure why Kibana is unable to connect to the ES that is configured locally.

---

<div class="post-metadata">

### Author: ![jnpetty](https://avatars.discourse-cdn.com/v4/letter/j/ecc23a/32.png) [@jnpetty](https://discuss.elastic.co/u/jnpetty)
#### Post date: [January 10, 2016, 2:31am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-local-elasticsearch-plugin-elasticsearch-service-unavailable/38761/3 "2016-01-10T02:31:13Z")

</div>

Anyone have any input to offer? I really need some help with this. Thanks!

---

<div class="post-metadata">

### Author: ![nikitag1992](https://avatars.discourse-cdn.com/v4/letter/n/71c47a/32.png) [@nikitag1992](https://discuss.elastic.co/u/nikitag1992)
#### Post date: [May 2, 2016, 8:01am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-local-elasticsearch-plugin-elasticsearch-service-unavailable/38761/4 "2016-05-02T08:01:22Z")

</div>

Hey, Any resolution found?

---

<div class="post-metadata">

### Author: ![jnpetty](https://avatars.discourse-cdn.com/v4/letter/j/ecc23a/32.png) [@jnpetty](https://discuss.elastic.co/u/jnpetty)
#### Post date: [May 10, 2016, 8:08pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-local-elasticsearch-plugin-elasticsearch-service-unavailable/38761/5 "2016-05-10T20:08:34Z")

</div>

Negative

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:53pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-local-elasticsearch-plugin-elasticsearch-service-unavailable/38761/6 "2017-07-06T13:53:44Z")

</div>


