# Kibana unable to connect to package registry after upgrade to 8.8.1

**URL:** <https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317>\
**Category:** Kibana\
**Tags:** fleet\
**Created:** [June 19, 2023, 3:04am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317 "2023-06-19T03:04:42Z")\
**Posts on this page:** 18\
**Page:** 1

<div class="post-metadata">

**Author:** ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)\
**Post date:** [June 19, 2023, 3:04am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/1 "2023-06-19T03:04:42Z")

</div>

Hi all  
I have a problems with kibana after upgrading from version 8.5.2 to version 8.8.1  
All thing work normally but the intergration keep giving me this error

`Kibana cannot connect to the Elastic Package Registry, which provides Elastic Agent integrations`

upon searching through the log i noticed that when ever i try to access the intergration kibana give me this error log:

```auto
Invalid top-level package manifest: one or more fields missing of name, version, description, title, format_version, owner

```

All fleet and kibana and elastic are all 8.8.1 so i really dont know how to fix this error  
I've tried the air-garped sollution and still give me the same error  
Can anyone help me fix this issue.

Thanks for your time.

---

<div class="post-metadata">

**Author:** ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)\
**Post date:** [June 19, 2023, 3:23am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/2 "2023-06-19T03:23:02Z")

</div>

Further investigation show me some of my problems  
when i curl the packet from [epr.elastic.co](http://epr.elastic.co) then return me all the field then i noticed that the field format\_version is not there.  
On my test server intergration run fine so i asume that the problems is when i upgrade from 8.5.2 to 8.8.1.  
It seems that the version change also remove the format version field from registry.  
How to i fix this issue?

---

<div class="post-metadata">

**Author:** ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)\
**Post date:** [June 19, 2023, 6:17am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/3 "2023-06-19T06:17:13Z")

</div>

I recently hit a similar issue. Finally the culprit was the endpoint package. Uninstalling it and reinstalling solved it. Do you have the endpoint package installed? Are you able to uninstall it?

Unfortunately Fleet does not really log any good error. I also never fully got to the ground of the error. One of my assumptions was that it had to do with my test setups but seems this is not the case here.

Do you have the beta package flag enabled?

---

<div class="post-metadata">

**Author:** ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)\
**Post date:** [June 19, 2023, 9:11am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/4 "2023-06-19T09:11:39Z")

</div>

i've turn on/off the beta package, still not working

i 've tried to uninstall all current used intergration and kibana still cannot connect to the package registry.

Interestingly when i access the intergration using the url i can still use them like normal.  
Not really sure what is the problems here.

---

<div class="post-metadata">

**Author:** ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)\
**Post date:** [June 19, 2023, 9:43am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/5 "2023-06-19T09:43:26Z")

</div>

> [@lusynda](#):
>
> kibana still cannot connect to the package registry.

When exactly do you see the error? If you go to the Fleet page or the integrations page? You shared 2 different errors above. Maybe the two are not related.

Lets dive into the two separately:

```auto
Kibana cannot connect to the Elastic Package Registry, which provides Elastic Agent integrations

```

I assume that is the one that you see in the integrations page.

```auto
Invalid top level packages ...

```

This is the one you saw in the log files. Do you also see it when you navigate to Fleet?

Going back to the "cannot connect" error. Can you share the curl command you did run? Have you changed anything in your kibana.yml ? Not now, but maybe in the past that could have an effect now?

If you could share the kibana log file, this would be helpful. If you don't want to put it out in public, feel free to share it in a private message.

---

<div class="post-metadata">

**Author:** ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)\
**Post date:** [June 19, 2023, 10:19am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/6 "2023-06-19T10:19:43Z")

</div>

> [@ruflin](#):
>
> When exactly do you see the error?

I see this error right after i upgrade elastic to version 8.8.1

> [@ruflin](#):
>
> Going back to the "cannot connect" error. Can you share the curl command you did run? Have you changed anything in your kibana.yml ? Not now, but maybe in the past that could have an effect now?

The curl i run to test `curl http://127.0.0.1:8080/search?kibana.version=8.8.1`  
it output a json data list all package like this one:

```auto
{
    "name": "pfsense",
    "title": "pfSense",
    "version": "1.7.0",
    "release": "ga",
    "description": "Collect logs from pfSense and OPNsense with Elastic Agent.",
    "type": "integration",
    "download": "/epr/pfsense/pfsense-1.7.0.zip",
    "path": "/package/pfsense/1.7.0",
    "icons": [
      {
        "src": "/img/pfsense.svg",
        "path": "/package/pfsense/1.7.0/img/pfsense.svg",
        "title": "pfsense",
        "size": "512x143",
        "type": "image/svg+xml"
      }
    ],
    "policy_templates": [
      {
        "name": "pfsense",
        "title": "pfSense logs",
        "description": "Collect logs from pfSense systems"
      }
    ],
    "conditions": {
      "kibana": {
        "version": "^8.1.0"
      }
    },
    "owner": {
      "github": "elastic/security-external-integrations"
    },
    "categories": [
      "network",
      "security",
      "firewall_security"
    ],
    "signature_path": "/epr/pfsense/pfsense-1.7.0.zip.sig"
  }

```

since the field format\_version does not exsists, i assume that it is the problems.  
Whenever i try to access the intergration tab, that error appear on the logs.

> [@ruflin](#):
>
> Have you changed anything in your kibana.yml ? Not now, but maybe in the past that could have an effect now?

When i do the upgrade i did not change anything, only after the error appear i change the config to point the registry server to local one.

> [@ruflin](#):
>
> If you could share the kibana log file, this would be helpful. If you don't want to put it out in public, feel free to share it in a private message.

Can i share the log related to the fleet server only since there is a ton of logs relating to other thing in kibana as well.

---

<div class="post-metadata">

**Author:** ![Julien\_Lind](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julien_lind/32/94291_2.png) [@Julien\_Lind](https://discuss.elastic.co/u/Julien_Lind)\
**Post date:** [June 20, 2023, 7:14am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/7 "2023-06-20T07:14:12Z")

</div>

> [@lusynda](#):
>
> When i do the upgrade i did not change anything, only after the error appear i change the config to point the registry server to local one.

So now your kibana instance can connect to a local EPR running under the 8.8.1 version but It was not working with the official [epr.elastic.co](http://epr.elastic.co) right? Have you got the kibana logs with this error?

---

<div class="post-metadata">

**Author:** ![JillG](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jillg/32/122488_2.png) [@JillG](https://discuss.elastic.co/u/JillG)\
**Post date:** [June 20, 2023, 8:31am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/8 "2023-06-20T08:31:13Z")

</div>

Hi, can you also clarify the following:

> Interestingly when i access the intergration using the url i can still use them like normal.

What exactly do you mean by this? Can you provide details about what you did and the outcome?

---

<div class="post-metadata">

**Author:** ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)\
**Post date:** [June 20, 2023, 8:48am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/9 "2023-06-20T08:48:19Z")

</div>

> [@JillG](#):
>
> What exactly do you mean by this? Can you provide details about what you did and the outcome?

i access the integration through its url /app/integrations/detail/nginx-1.15.0/policies  
after that i can still update, install, reinstall, uninstall, add it to policies, just like normal.  
But i cannot view it through the integration panel in kibana.

---

<div class="post-metadata">

**Author:** ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)\
**Post date:** [June 20, 2023, 8:50am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/10 "2023-06-20T08:50:28Z")

</div>

> [@Julien\_Lind](#):
>
> So now your kibana instance can connect to a local EPR running under the 8.8.1 version but It was not working with the official [epr.elastic.co](http://epr.elastic.co) right? Have you got the kibana logs with this error?

Let me clarify what i said, both onprem and official [epr.elatic.co](http://epr.elatic.co) not work for me.  
i still give me the not connected to elastic package registry.  
The only error i get when i access the integration page is this:

```auto
Invalid top-level package manifest: one or more fields missing of name, version, description, title, format_version, owner

```

---

<div class="post-metadata">

**Author:** ![JillG](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jillg/32/122488_2.png) [@JillG](https://discuss.elastic.co/u/JillG)\
**Post date:** [June 20, 2023, 9:25am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/11 "2023-06-20T09:25:16Z")

</div>

So to be extra clear:

- You can access e.g. app/integrations/detail/nginx-1.15.0/overview in the browser and install the integration using the UI, correct?
- You cannot access app/integrations/browse in the browser, rather you see the "Kibana cannot connect to the Elastic Package Registry, which provides Elastic Agent integrations" error message in the UI, correct?

---

<div class="post-metadata">

**Author:** ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)\
**Post date:** [June 20, 2023, 9:51am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/12 "2023-06-20T09:51:18Z")

</div>

Yes that is the current problems

---

<div class="post-metadata">

**Author:** ![JillG](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jillg/32/122488_2.png) [@JillG](https://discuss.elastic.co/u/JillG)\
**Post date:** [June 20, 2023, 2:21pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/13 "2023-06-20T14:21:28Z")

</div>

Thanks for confirming. Can you please also confirm the following:

About this error:

```auto
Invalid top-level package manifest: one or more fields missing of name, version, description, title, format_version, owner" error

```

Does this error show up in Kibana logs whenever you try to load the page at app/integrations/browse in the browser, i.e. it matches the other error you see in the UI? Or are they not exactly correlated? I believe this was @ruflin was asking above:

> When exactly do you see the error? If you go to the Fleet page or the integrations page?

Also, have you identified the specific request that fails on loading app/integrations/browse (e.g. from the Network tab in the browser)?

---

<div class="post-metadata">

**Author:** ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)\
**Post date:** [June 21, 2023, 2:58am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/14 "2023-06-21T02:58:51Z")

</div>

> [@JillG](#):
>
> Does this error show up in Kibana logs whenever you try to load the page at app/integrations/browse in the browser, i.e. it matches the other error you see in the UI?

The error appear exactly when i use the app/integrations/browse in the browser.

> [@JillG](#):
>
> Also, have you identified the specific request that fails on loading app/integrations/browse (e.g. from the Network tab in the browser)?

In the network tab i check that the request from /api/fleet/epm/packages return 400 code and thí:

```auto
{
    "statusCode": 400,
    "error": "Bad Request",
    "message": "Invalid top-level package manifest: one or more fields missing of name, version, description, title, format_version, owner"
}

```

---

<div class="post-metadata">

**Author:** ![JillG](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jillg/32/122488_2.png) [@JillG](https://discuss.elastic.co/u/JillG)\
**Post date:** [June 22, 2023, 1:21pm UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/15 "2023-06-22T13:21:15Z")

</div>

Do you still see the error with all integrations uninstalled?

To make sure, you can check that there are no installed packages by running the query

```auto
GET .kibana_ingest/_search?q=type:epm-packages

```

which will list installed packages. It would be good to confirm that the issue persist if there are no installed packages.

Can you also confirm whether you had or still have Endpoint (Elastic Defend) installed?

Finally, assuming the error does not happen with no installed packages, can you list your installed packages to see if we can track the issue to a specific package?

Thanks

---

<div class="post-metadata">

**Author:** ![lusynda](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lusynda/32/53557_2.png) [@lusynda](https://discuss.elastic.co/u/lusynda)\
**Post date:** [June 26, 2023, 8:40am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/16 "2023-06-26T08:40:36Z")

</div>

> [@JillG](#):
>
> `GET .kibana_ingest/_search?q=type:epm-packages`

your query is a live saver for me,  
apparently there is a integration call cyberark that is no longer available on the new registry and is installed in my elastic.  
After uninstall it the intergration run fine without any other issue.

Thanks all for your support

---

<div class="post-metadata">

**Author:** ![JillG](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jillg/32/122488_2.png) [@JillG](https://discuss.elastic.co/u/JillG)\
**Post date:** [June 26, 2023, 8:44am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/17 "2023-06-26T08:44:26Z")

</div>

Fantastic, thanks for confirming!

I made a small change to the server error message to report the package name in the future.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 24, 2023, 8:45am UTC](https://discuss.elastic.co/t/kibana-unable-to-connect-to-package-registry-after-upgrade-to-8-8-1/336317/18 "2023-07-24T08:45:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
