# Kibana unable to retrieve connection

**URL:** <https://discuss.elastic.co/t/kibana-unable-to-retrieve-connection/133001>\
**Category:** Kibana\
**Created:** [May 23, 2018, 1:36pm UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-connection/133001 "2018-05-23T13:36:41Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![KeninHouston](https://avatars.discourse-cdn.com/v4/letter/k/54ee81/32.png) [@KeninHouston](https://discuss.elastic.co/u/KeninHouston)\
**Post date:** [May 23, 2018, 1:36pm UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-connection/133001/1 "2018-05-23T13:36:41Z")

</div>

Hi,

I have set up an ElasticSearch cluster which is using x-pack security. I have setup the initial user passwords, elastic and kibana. From the Kibana server, I can connect to the ElasticSearch cluster using the kibana username and password thus:

curl -k -u kibana:username [https://owadata:9200](https://owadata:9200)

but when I try and connect to kibana I get no answer:

curl -k -u kibana:username [https://kibanaserver:5601](https://kibanaserver:5601)

The kibana.yml file has the following:

server.port: 5601  
server.host: admin  
server.name: admin  
elasticsearch.url: "[https://owadata:9200](https://owadata:9200)"  
kibana.index: ".kibana"  
kibana.defaultAppId: "home"  
elasticsearch.username: "kibana"  
elasticsearch.password: "passwordvalue"  
logging.dest: /var/log/kibana.log  
logging.silent: false

The value of passwordvalue is correct

In the log file, I get the following messages:

{"type":"log","@timestamp":"2018-05-23T13:35:51Z","tags":["license","warning","xpack"],"pid":2170,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. Error: No Living connections"}  
{"type":"log","@timestamp":"2018-05-23T13:35:52Z","tags":["warning","elasticsearch","admin"],"pid":2170,"message":"Unable to revive connection: [https://owadata:9200/](https://owadata:9200/)"}  
{"type":"log","@timestamp":"2018-05-23T13:35:52Z","tags":["warning","elasticsearch","admin"],"pid":2170,"message":"No living connections"}  
{"type":"log","@timestamp":"2018-05-23T13:35:55Z","tags":["warning","elasticsearch","admin"],"pid":2170,"message":"Unable to revive connection: [https://owadata:9200/](https://owadata:9200/)"}  
{"type":"log","@timestamp":"2018-05-23T13:35:55Z","tags":["warning","elasticsearch","admin"],"pid":2170,"message":"No living connections"}  
{"type":"log","@timestamp":"2018-05-23T13:35:57Z","tags":["warning","elasticsearch","admin"],"pid":2170,"message":"Unable to revive connection: [https://owadata:9200/](https://owadata:9200/)"}  
{"type":"log","@timestamp":"2018-05-23T13:35:57Z","tags":["warning","elasticsearch","admin"],"pid":2170,"message":"No living connections"}  
{"type":"log","@timestamp":"2018-05-23T13:36:00Z","tags":["warning","elasticsearch","admin"],"pid":2170,"message":"Unable to revive connection: [https://owadata:9200/](https://owadata:9200/)"}  
{"type":"log","@timestamp":"2018-05-23T13:36:00Z","tags":["warning","elasticsearch","admin"],"pid":2170,"message":"No living connections"}

I have applied the correct license to the elasticsearch cluster

Any ideas?

---

<div class="post-metadata">

**Author:** ![Stacey\_Gammon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stacey_gammon/32/14025_2.png) [@Stacey\_Gammon](https://discuss.elastic.co/u/Stacey_Gammon)\
**Post date:** [May 23, 2018, 2:08pm UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-connection/133001/2 "2018-05-23T14:08:01Z")

</div>

Are you sure elasticsearch is up and running? The logs indicate that kibana is failing to connect with it. It would be a different error message if the license or credentials were wrong.

Can you navigate to `https://owadata:9200/` in the browser and connect to it?

Do you have ssl settings configured?  
[https://www.elastic.co/guide/en/kibana/current/production.html#enabling-ssl](https://www.elastic.co/guide/en/kibana/current/production.html#enabling-ssl)

---

<div class="post-metadata">

**Author:** ![KeninHouston](https://avatars.discourse-cdn.com/v4/letter/k/54ee81/32.png) [@KeninHouston](https://discuss.elastic.co/u/KeninHouston)\
**Post date:** [May 23, 2018, 5:49pm UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-connection/133001/3 "2018-05-23T17:49:13Z")

</div>

Hi Stacey,

Thanks for the info. I've got it working now. I hadn't specified the ca and certificate for the elastic search cluster.

Regards,  
Kenneth

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 20, 2018, 5:49pm UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-connection/133001/4 "2018-06-20T17:49:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
