# Kibana Unable to retrieve version information from Elasticsearch nodes. socket hang up

**URL:** <https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528>\
**Category:** Kibana\
**Created:** [April 28, 2022, 2:38pm UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528 "2022-04-28T14:38:24Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![Roshan1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/roshan1/32/102370_2.png) [@Roshan1](https://discuss.elastic.co/u/Roshan1)\
**Post date:** [April 28, 2022, 2:38pm UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528/1 "2022-04-28T14:38:24Z")

</div>

Dear Team,

kindly advise why error occurs when starting Kibana?

```auto
da46c1"}}
{"ecs":{"version":"8.0.0"},"@timestamp":"2022-04-28T18:37:07.516+04:00","message":"Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 10.242.1.117:55900, Remote: 10.242.1.117:9200","log":{"level":"ERROR","logger":"elasticsearch-service"},"process":{"pid":725},"trace":{"id":"5cf278f8304fc40f9e6804aadd2c09b0"},"transaction":{"id":"2fd52efe15da46c1"}}
{"ecs":{"version":"8.0.0"},"@timestamp":"2022-04-28T18:37:10.009+04:00","message":"Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 10.242.1.117:55908, Remote: 10.242.1.117:9200","log":{"level":"ERROR","logger":"elasticsearch-service"},"process":{"pid":725},"trace":{"id":"5cf278f8304fc40f9e6804aadd2c09b0"},"transaction":{"id":"2fd52efe15da46c1"}}
{"ecs":{"version":"8.0.0"},"@timestamp":"2022-04-28T18:37:12.593+04:00","message":"Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 10.242.1.117:55916, Remote: 10.242.1.117:9200","log":{"level":"ERROR","logger":"elasticsearch-service"},"process":{"pid":725},"trace":{"id":"5cf278f8304fc40f9e6804aadd2c09b0"},"transaction":{"id":"2fd52efe15da46c1"}}
{"ecs":{"version":"8.0.0"},"@timestamp":"2022-04-28T18:37:15.039+04:00","message":"Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 10.242.1.117:55924, Remote: 10.242.1.117:9200","log":{"level":"ERROR","logger":"elasticsearch-service"},"process":{"pid":725},"trace":{"id":"5cf278f8304fc40f9e6804aadd2c09b0"},"transaction":{"id":"2fd52efe15da46c1"}}
{"ecs":{"version":"8.0.0"},"@timestamp":"2022-04-28T18:37:17.589+04:00","message":"Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 10.242.1.117:55932, Remote: 10.242.1.117:9200","log":{"level":"ERROR","logger":"elasticsearch-service"},"process":{"pid":725},"trace":{"id":"5cf278f8304fc40f9e6804aadd2c09b0"},"transaction":{"id":"2fd52efe15da46c1"}}

```

When accessing ES on browser I am being prompted for username and password.

version 8.0

Kindly advise.

Roshan

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 28, 2022, 11:34pm UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528/2 "2022-04-28T23:34:32Z")

</div>

Can you access Elasticsearch yourself?

---

<div class="post-metadata">

**Author:** ![Roshan1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/roshan1/32/102370_2.png) [@Roshan1](https://discuss.elastic.co/u/Roshan1)\
**Post date:** [May 2, 2022, 9:16am UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528/3 "2022-05-02T09:16:44Z")

</div>

Yes  
[elastic@rb-in-prod-esearch-01 Elasticsearch]$ curl -u elastic:JXk68mXZ6\*XZOyeZ -k [https://10.242.1.119:9200/](https://10.242.1.119:9200/)  
{  
"name" : "rb-in-prod-esearch-02",  
"cluster\_name" : "elasticmt",  
"cluster\_uuid" : "J3NV6OU\_SR-FrlMEIxdn9g",  
"version" : {  
"number" : "8.1.3",  
"build\_flavor" : "default",  
"build\_type" : "rpm",  
"build\_hash" : "39afaa3c0fe7db4869a161985e240bd7182d7a07",  
"build\_date" : "2022-04-19T08:13:25.444693396Z",  
"build\_snapshot" : false,  
"lucene\_version" : "9.0.0",  
"minimum\_wire\_compatibility\_version" : "7.17.0",  
"minimum\_index\_compatibility\_version" : "7.0.0"  
},  
"tagline" : "You Know, for Search"  
}

---

<div class="post-metadata">

**Author:** ![Roshan1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/roshan1/32/102370_2.png) [@Roshan1](https://discuss.elastic.co/u/Roshan1)\
**Post date:** [May 2, 2022, 9:17am UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528/4 "2022-05-02T09:17:57Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/6/3/639bc4bed524c42c3f6b5a74f2e536efaff370b3.png)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 3, 2022, 12:24am UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528/5 "2022-05-03T00:24:02Z")

</div>

> [@Roshan1](#):
>
> [https://10.242.1.119:9200/](https://10.242.1.119:9200/)

This is where you queried Elasticsearch directly.

> [@Roshan1](#):
>
> `Remote: 10.242.1.117:9200"`

This is what you have configured in Kibana. They do not match?

---

<div class="post-metadata">

**Author:** ![Roshan1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/roshan1/32/102370_2.png) [@Roshan1](https://discuss.elastic.co/u/Roshan1)\
**Post date:** [May 3, 2022, 2:52am UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528/6 "2022-05-03T02:52:55Z")

</div>

Elasticsearch is installed on 3 nodes. Kibana is installed on the master node of ES. For 1 node I am able to access.

![image](https://us1.discourse-cdn.com/elastic/original/3X/f/8/f8bc0e07f65b8ceafe45d5ca99728890f8a161c8.png)

Elasticsearch.hosts: ["[https://10.242.1.117:9200](https://10.242.1.117:9200)","[https://10.242.1.118:9200](https://10.242.1.118:9200)","[https://10.242.1.119:9200](https://10.242.1.119:9200)"]

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 3, 2022, 3:42am UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528/7 "2022-05-03T03:42:21Z")

</div>

Can you curl Elasticsearch from the Kibana host?

---

<div class="post-metadata">

**Author:** ![Roshan1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/roshan1/32/102370_2.png) [@Roshan1](https://discuss.elastic.co/u/Roshan1)\
**Post date:** [May 4, 2022, 4:45am UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528/8 "2022-05-04T04:45:09Z")

</div>

Yes I can curl.  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/6/3/639bc4bed524c42c3f6b5a74f2e536efaff370b3.png)

Please find below Kibana yml entry:

> server.publicBaseUrl: "[https://10.242.1.117:5601](https://10.242.1.117:5601)"
> 
> # The maximum payload size in bytes for incoming server requests.
> 
> #server.maxPayload: 1048576
> 
> # The Kibana server's name. This is used for display purposes.
> 
> #server.name: "your-hostname"
> 
> # =================== System: Kibana Server (Optional) ===================
> 
> # Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
> 
> # These settings enable SSL for outgoing requests from the Kibana server to the browser.
> 
> #server.ssl.enabled: false  
> #server.ssl.certificate: /path/to/your/server.crt  
> #server.ssl.key: /path/to/your/server.key
> 
> # =================== System: Elasticsearch ===================
> 
> # The URLs of the Elasticsearch instances to use for all your queries.
> 
> #elasticsearch.hosts: ["[http://localhost:9200](http://localhost:9200)"]  
> elasticsearch.hosts: ["[https://10.242.1.117:9200](https://10.242.1.117:9200/)","[https://10.242.1.118:9200](https://10.242.1.118:9200/)","[https://10.242.1.119:9200](https://10.242.1.119:9200/)"]
> 
> # If your Elasticsearch is protected with basic authentication, these settings provide
> 
> # the username and password that the Kibana server uses to perform maintenance on the Kibana
> 
> # index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
> 
> # is proxied through the Kibana server.
> 
> #elasticsearch.username: "kibana\_system"  
> #elasticsearch.password: "pass"  
> #elasticsearch.username: "elastic"  
> #elasticsearch.password: "JXk6ma=T8mXZ6\*XZOyeZ"
> 
> # Kibana can also authenticate to Elasticsearch via "service account tokens".
> 
> # Service account tokens are Bearer style tokens that replace the traditional username/password based configuration.
> 
> # Use this token instead of a username/password.
> 
> elasticsearch.serviceAccountToken: "eyJ2ZXIiOiI4LjEuMyIsImFkciI6WyIxMC4yNDIuMS4xMTc6OTIwMCJdLCJmZ3IiOiJlMTFmNmI2MTNmYmQwZGUwODIzYmZlZWYwYTk1ZmFlMjg4YWQwM2UzNzAzNTk3ODU3ODk5NGE4NWNkODQ3ZjNlIiwia2V5IjoiSnJfN2c0QUJZR1pPd21xUHJWNGg6b25UM25WVjBSS2E4MF9rdEd6dThUdyJ9"

Kindly advise if entries correct?

---

<div class="post-metadata">

**Author:** ![Roshan1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/roshan1/32/102370_2.png) [@Roshan1](https://discuss.elastic.co/u/Roshan1)\
**Post date:** [May 4, 2022, 4:46am UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528/9 "2022-05-04T04:46:46Z")

</div>

[elastic@rb-in-prod-kibana-01 kibana]$ curl -X GET "[https://10.242.1.117:9200/\_cat/health?v=true&pretty](https://10.242.1.117:9200/_cat/health?v=true&pretty)"  
curl: (60) Peer's certificate issuer has been marked as not trusted by the user.  
More details here: [curl - SSL CA Certificates](http://curl.haxx.se/docs/sslcerts.html)

curl performs SSL certificate verification by default, using a "bundle"  
of Certificate Authority (CA) public keys (CA certs). If the default  
bundle file isn't adequate, you can specify an alternate file  
using the --cacert option.  
If this HTTPS server uses a certificate signed by a CA represented in  
the bundle, the certificate verification probably failed due to a  
problem with the certificate (it might be expired, or the name might  
not match the domain name in the URL).  
If you'd like to turn off curl's verification of the certificate, use  
the -k (or --insecure) option.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 1, 2022, 4:46am UTC](https://discuss.elastic.co/t/kibana-unable-to-retrieve-version-information-from-elasticsearch-nodes-socket-hang-up/303528/10 "2022-06-01T04:46:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
