# Kibana upgrade fails because of rest.action.multi.allow\_explicit\_index

**URL:** <https://discuss.elastic.co/t/kibana-upgrade-fails-because-of-rest-action-multi-allow-explicit-index/196387>\
**Category:** Kibana\
**Created:** [August 22, 2019, 6:38pm UTC](https://discuss.elastic.co/t/kibana-upgrade-fails-because-of-rest-action-multi-allow-explicit-index/196387 "2019-08-22T18:38:45Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![arsenmk](https://avatars.discourse-cdn.com/v4/letter/a/b5a626/32.png) [@arsenmk](https://discuss.elastic.co/u/arsenmk)\
**Post date:** [August 22, 2019, 6:38pm UTC](https://discuss.elastic.co/t/kibana-upgrade-fails-because-of-rest-action-multi-allow-explicit-index/196387/1 "2019-08-22T18:38:45Z")

</div>

When upgrading ES and Kibana from 5.6 to 6.7, Kibana does not start up, because the migration of configuration index (.kibana) fails. The reason is `rest.action.multi.allow_explicit_index = false` setting.

I found a fix of this, which is removing the index name from the index api payload and putting in the URL, i.e. removing this line : [https://github.com/elastic/kibana/blob/59e632afe5423c872411c6b2885c410e353e507c/src/core/server/saved\_objects/migrations/core/elastic\_index.ts#L118](https://github.com/elastic/kibana/blob/59e632afe5423c872411c6b2885c410e353e507c/src/core/server/saved_objects/migrations/core/elastic_index.ts#L118), and adding `index: index,` between lines 113 and 114. I verified this fix works fine for me, but I wonder if there is any special reason the index name is kept in the payload, not in the URL.

---

<div class="post-metadata">

**Author:** ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)\
**Post date:** [August 22, 2019, 11:00pm UTC](https://discuss.elastic.co/t/kibana-upgrade-fails-because-of-rest-action-multi-allow-explicit-index/196387/2 "2019-08-22T23:00:11Z")

</div>

It shouldn't be necessary to pass the index in the url since the index is also passed in the body of the \_bulk request.  
From the [Bulk documentation](https://www.elastic.co/guide/en/elasticsearch/reference/6.7/docs-bulk.html)

> The endpoints are `/_bulk` , `/{index}/_bulk` , and `{index}/{type}/_bulk` . When the index or the index/type are provided, they will be used by default on bulk items that don’t provide them explicitly.

I'm not quite sure why it failed for you though but I'm glad you got it working!

---

<div class="post-metadata">

**Author:** ![arsenmk](https://avatars.discourse-cdn.com/v4/letter/a/b5a626/32.png) [@arsenmk](https://discuss.elastic.co/u/arsenmk)\
**Post date:** [August 26, 2019, 11:36pm UTC](https://discuss.elastic.co/t/kibana-upgrade-fails-because-of-rest-action-multi-allow-explicit-index/196387/3 "2019-08-26T23:36:36Z")

</div>

I think the [documentation](https://www.elastic.co/guide/en/elasticsearch/reference/current/url-access-control.html) of that setting clearly says why it is necessary. My question was different though, so it's still unanswered.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 23, 2019, 11:36pm UTC](https://discuss.elastic.co/t/kibana-upgrade-fails-because-of-rest-action-multi-allow-explicit-index/196387/4 "2019-09-23T23:36:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
