# Kibana upgrade to 8.9 from 7.17.12 security\_exception reindex

**URL:** https://discuss.elastic.co/t/kibana-upgrade-to-8-9-from-7-17-12-security-exception-reindex/340284
**Category:** Kibana
**Created:** [August 7, 2023, 2:46pm UTC](https://discuss.elastic.co/t/kibana-upgrade-to-8-9-from-7-17-12-security-exception-reindex/340284 "2023-08-07T14:46:00Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Hywelj](https://avatars.discourse-cdn.com/v4/letter/h/50afbb/32.png) [@Hywelj](https://discuss.elastic.co/u/Hywelj)
#### Post date: [August 7, 2023, 2:46pm UTC](https://discuss.elastic.co/t/kibana-upgrade-to-8-9-from-7-17-12-security-exception-reindex/340284/1 "2023-08-07T14:46:00Z")

</div>

So I have upgraded my elasticsearch cluster from 7.17.12 to 8.9 and my cluster is now up and running and in a green health state. When I start 8.9 Kibana I get the following error for multiple `.kibana*` indices

```auto
[INFO][savedobjects-service][.kibana] CREATE_REINDEX_TEML -> CREATE_REINDEX_TEMP
[ERROR][savedobjects-service][.kibana] Action failed with 'security_exception Root causes: security_exception: action[indices:admin/block/add] is unauthorized for user [XXX] with effective roles [superuser] on restricted indices [.kibana_7.17.12_001], this action is granted by the index privileges [manage,all]'.

```

I have tried reducing the hard disk usage to below thresholds as implied here: [Locked Out of Kibana Superuser Can't Modify Index Settings](https://discuss.elastic.co/t/locked-out-of-kibana-superuser-cant-modify-index-settings/311424) but that hasn't done anything.

I've also looked into giving the specific index permissions in the `roles.yml` file (the `allow_restricted_indices` permission?) as the error complains about but I cannot figure out how to apply it to a user in the `role_mapping.yml` (as I'm not using AD, just a simple username/password) and I'm not allowed to modify the superuser role on it's own. I'm not sure how to fix this as I've always used kibana to interact with the cluster and kibana will not start.

I'm also open to completely resetting/deleting the kibana part if needed, I haven't extensively used it yet.

---

<div class="post-metadata">

### Author: ![azasypkin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/azasypkin/32/42216_2.png) [@azasypkin](https://discuss.elastic.co/u/azasypkin)
#### Post date: [August 14, 2023, 10:21am UTC](https://discuss.elastic.co/t/kibana-upgrade-to-8-9-from-7-17-12-security-exception-reindex/340284/2 "2023-08-14T10:21:10Z")

</div>

> [@Hywelj](#):
>
> I'm not sure how to fix this as I've always used kibana to interact with the cluster and kibana will not start.

Do you use `kibana_system` as the `elasticsearch.username` in `kibana.yml`? Or do you have some special custom user for the Kibana internal system user?

--  
Oleg

---

<div class="post-metadata">

### Author: ![chinmoy\_padhi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chinmoy_padhi/32/68568_2.png) [@chinmoy\_padhi](https://discuss.elastic.co/u/chinmoy_padhi)
#### Post date: [August 14, 2023, 3:24pm UTC](https://discuss.elastic.co/t/kibana-upgrade-to-8-9-from-7-17-12-security-exception-reindex/340284/3 "2023-08-14T15:24:40Z")

</div>

Does your Kibana and elasticsearch are on same version? I mean after upgrade are they both in v8.9  
I always follow this link as thumbrule whenever I go for any Elasticstack related upgrade

> **[Support Matrix](https://www.elastic.co/support/matrix#matrix_compatibility)**

---

<div class="post-metadata">

### Author: ![Hywelj](https://avatars.discourse-cdn.com/v4/letter/h/50afbb/32.png) [@Hywelj](https://discuss.elastic.co/u/Hywelj)
#### Post date: [September 4, 2023, 10:08am UTC](https://discuss.elastic.co/t/kibana-upgrade-to-8-9-from-7-17-12-security-exception-reindex/340284/4 "2023-09-04T10:08:59Z")

</div>

I used some of the steps in this post: [Resolve migration failures | Kibana Guide [master] | Elastic](https://www.elastic.co/guide/en/kibana/master/resolve-migrations-failures.html#_corrupt_saved_objects)

to create a role with the `allow_restricted_indices` permissions `true` on all `kibana*` indices, then applied the role to my superuser. Having a superuser without all permissions, yet using the superuser account to give itself full permissions, is honestly one of the most counterintuitive things I have ever encountered.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 2, 2023, 10:09am UTC](https://discuss.elastic.co/t/kibana-upgrade-to-8-9-from-7-17-12-security-exception-reindex/340284/5 "2023-10-02T10:09:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
