# Kibana URL not accessible

**URL:** https://discuss.elastic.co/t/kibana-url-not-accessible/149060
**Category:** Kibana
**Created:** [September 19, 2018, 6:05am UTC](https://discuss.elastic.co/t/kibana-url-not-accessible/149060 "2018-09-19T06:05:50Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![priyanka1](https://avatars.discourse-cdn.com/v4/letter/p/3ab097/32.png) [@priyanka1](https://discuss.elastic.co/u/priyanka1)
#### Post date: [September 19, 2018, 6:05am UTC](https://discuss.elastic.co/t/kibana-url-not-accessible/149060/1 "2018-09-19T06:05:50Z")

</div>

I am using 6.4 version for kibana ,elasticsearch and logstash .  
installed in three different AWS VM's with OS : ubuntu 16.04

My kibana.yml looks like this:

```auto
 #Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
 #The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
#server.host: "18.205.37.14"
server.host: "0.0.0.0"

#Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
 #from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# This setting was effectively always `false` before Kibana 6.3 and will
# default to `true` starting in Kibana 7.0.
#server.rewriteBasePath: false

# The maximum payload size in bytes for incoming server requests.
#server.maxPayloadBytes: 1048576

# The Kibana server's name. This is used for display purposes.
#server.name: "your-hostname"

# The URL of the Elasticsearch instance to use for all your queries.
elasticsearch.url: "http://0.0.0.0:9200"

# When this setting's value is true Kibana uses the hostname specified in the server.host
# setting. When the value of this setting is false, Kibana uses the hostname of the host
# that connects to this Kibana instance.
#elasticsearch.preserveHost: true

# Kibana uses an index in Elasticsearch to store saved searches, visualizations and
# dashboards. Kibana creates a new index if the index doesn't already exist.
#kibana.index: ".kibana"

# The default application to load.
#kibana.defaultAppId: "home"

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which

```

in kibana logs

```auto
 {"type":"log","@timestamp":"2018-09-19T05:42:56Z","tags":["license","warning","xpack"],"pid":1769,"message":"License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. Error: Request Timeout after 30000ms"}

 2018-09-19 05:59:51 ERROR Health ping failed with error - NoCredentialProviders: no valid providers in chain. Deprecated.

```

I am a new bee to ELK please put some light on my topic ,it will be really helpfull

---

<div class="post-metadata">

### Author: ![lukas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lukas/32/6812_2.png) [@lukas](https://discuss.elastic.co/u/lukas)
#### Post date: [September 19, 2018, 3:18pm UTC](https://discuss.elastic.co/t/kibana-url-not-accessible/149060/2 "2018-09-19T15:18:13Z")

</div>

Are you able to reach your Elasticsearch instance? What was the process you used to install X-Pack?

---

<div class="post-metadata">

### Author: ![priyanka1](https://avatars.discourse-cdn.com/v4/letter/p/3ab097/32.png) [@priyanka1](https://discuss.elastic.co/u/priyanka1)
#### Post date: [September 20, 2018, 6:03am UTC](https://discuss.elastic.co/t/kibana-url-not-accessible/149060/3 "2018-09-20T06:03:13Z")

</div>

I installed elastic search by process mention on the link :  
[https://logz.io/blog/elasticsearch-tutorial/](https://logz.io/blog/elasticsearch-tutorial/)  
kibana is getting binded to port 5601 with host 0.0.0.0 but with my specific public IP kibana gets started but not binding with IP and i get this error in logs  
{ Error: listen EADDRNOTAVAIL 12.208.33.19:5601

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 18, 2018, 6:03am UTC](https://discuss.elastic.co/t/kibana-url-not-accessible/149060/4 "2018-10-18T06:03:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
