# Kibana URL uses a Single host to serve all request

**URL:** https://discuss.elastic.co/t/kibana-url-uses-a-single-host-to-serve-all-request/353003
**Category:** Kibana
**Created:** [February 11, 2024, 7:36am UTC](https://discuss.elastic.co/t/kibana-url-uses-a-single-host-to-serve-all-request/353003 "2024-02-11T07:36:10Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![upadhyayaaman](https://avatars.discourse-cdn.com/v4/letter/u/3be4f8/32.png) [@upadhyayaaman](https://discuss.elastic.co/u/upadhyayaaman)
#### Post date: [February 11, 2024, 7:36am UTC](https://discuss.elastic.co/t/kibana-url-uses-a-single-host-to-serve-all-request/353003/1 "2024-02-11T07:36:10Z")

</div>

Hi All,

We have 3 nodes in the cluster with 1 primary and 2 replicas.  
For DR activities we perform below steps :

1. We are setting number of replica to 1 and then Exclude 1st node from cluster in single DC , while other 2 nodes in 2nd DC are included in cluster.
2. shutdown 1st node and perform validation on DC2 nodes kibana console.

Now the issue we are facing is that :  
When we do simple GET /\_cluster/health from other 2 nodes in cluster they throw the error as below on console.

{  
"statusCode": 500,  
"error": "Internal Server Error",  
"message": "An internal server error occurred"  
}

Error on server logs :  
{"type":"error","@timestamp":"2024-02-11T07:10:48Z","tags":,"pid":22807,"level":"error","error":{"message":"Cannot throw non-error object","name":"Error","stack":"Error: Cannot throw non-error object\n at module.exports.internals.Manager.execute (/\*/napsysrecs/kibana-7.5.0-linux-x86\_64/node\_modules/hapi/lib/toolkit.js:42:33)\n at process.\_tickCallback (internal/process/next\_tick.js:68:7)"},"url":{"protocol":null,"slashes":null,"auth":null,"host":null,"port":null,"hostname":null,"hash":null,"search":"?path=%2F\_cluster%2Fhealth&method=GET","query":{"path":"/\_cluster/health","method":"GET"},"pathname":"/api/console/proxy","path":"/api/console/proxy?path=%2F\_cluster%2Fhealth&method=GET","href":"/api/console/proxy?path=%2F\_cluster%2Fhealth&method=GET"},"message":"Cannot throw non-error object"}

Shouldn't the other 2 nodes serve the console requests when 1 node is down and new request should go to 2nd DC ?

The curl url on 2nd DC is still pointing to 1st DC host which is down.  
If I copy the command as curl from console it shows 1st DC host.  
So we are bit clueless at the moment. Kindly help how to use Kibana in such scenario ☹

---

<div class="post-metadata">

### Author: ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)
#### Post date: [February 15, 2024, 3:52pm UTC](https://discuss.elastic.co/t/kibana-url-uses-a-single-host-to-serve-all-request/353003/2 "2024-02-15T15:52:26Z")

</div>

Do you have [`elasticsearch.hosts` in your Kibana config](https://www.elastic.co/guide/en/kibana/current/settings.html#elasticsearch-hosts) pointing to all three nodes?

---

<div class="post-metadata">

### Author: ![upadhyayaaman](https://avatars.discourse-cdn.com/v4/letter/u/3be4f8/32.png) [@upadhyayaaman](https://discuss.elastic.co/u/upadhyayaaman)
#### Post date: [February 16, 2024, 12:33pm UTC](https://discuss.elastic.co/t/kibana-url-uses-a-single-host-to-serve-all-request/353003/3 "2024-02-16T12:33:30Z")

</div>

Yes the kibana config file has all 3 servers within it  
elasticsearch.hosts: ["server1:9200","server2:9200","server3:9200"]

I have been advised to try below in kibana config

| elasticsearch.sniffInterval: | Time in milliseconds between requests to check Elasticsearch for an updated list of nodes. Default: false |
| --- | --- |
| elasticsearch.sniffOnStart: | Attempt to find other Elasticsearch nodes on startup. Default: false |
| elasticsearch.sniffOnConnectionFault: | Update the list of Elasticsearch nodes immediately following a connection fault. Default: false |

---

<div class="post-metadata">

### Author: ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)
#### Post date: [February 26, 2024, 4:17pm UTC](https://discuss.elastic.co/t/kibana-url-uses-a-single-host-to-serve-all-request/353003/4 "2024-02-26T16:17:09Z")

</div>

Apologies for the delayed response. It looks like your Kibana is running on 7.5. I searched around for a similar error and found [this](https://github.com/elastic/kibana/issues/58456). Based on that issue, I believe this was a bug that was fixed in 7.6. Upgrading to 7.6 (or even better 7.17) should resolve this error.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 25, 2024, 4:17pm UTC](https://discuss.elastic.co/t/kibana-url-uses-a-single-host-to-serve-all-request/353003/5 "2024-03-25T16:17:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
