# Kibana v7.16.1 login issue. Not able to login (ResponseError: version\_conflict\_engine\_exception)

**URL:** <https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670>\
**Category:** Kibana\
**Created:** [July 1, 2022, 2:31pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670 "2022-07-01T14:31:17Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [July 1, 2022, 2:31pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/1 "2022-07-01T14:31:17Z")

</div>

![Elastic_login_error](https://us1.discourse-cdn.com/elastic/original/3X/d/9/d9fabecb9562c4c6e8d42c221cd8a2fe60108548.png)

Hello,

We are on v7.16.1 of Kibana/Elastic and facing issues with Kibana login all of a sudden. It was working fine around couple of hours back When checked in the logs seeing below exceptions.

{"type":"log","@timestamp":"2022-07-01T12:01:16+00:00","tags":["error","plugins","security","session","index"],"pid":115029,"message":"Failed to create session value: version\_conflict\_engine\_exception: [version\_conflict\_engine\_exception] Reason: [F8GE4AZDdmPIGpePXKJ/T4fzvV2jwC5FQdz1N4mPseo=]: version conflict, document already exists (current version [1])"}  
{"type":"log","@timestamp":"2022-07-01T12:01:16+00:00","tags":["error","http"],"pid":115029,"message":"ResponseError: version\_conflict\_engine\_exception: [version\_conflict\_engine\_exception] Reason: [F8GE4AZDdmPIGpePXKJ/T4fzvV2jwC5FQdz1N4mPseo=]: version conflict, document already exists (current version [1])\n at onBody (/usr/share/kibana/node\_modules/@elastic/elasticsearch/lib/Transport.js:367:23)\n at IncomingMessage.onEnd (/usr/share/kibana/node\_modules/@elastic/elasticsearch/lib/Transport.js:291:11)\n at IncomingMessage.emit (node:events:402:35)\n at endReadableNT (node:internal/streams/readable:1343:12)\n at processTicksAndRejections (node:internal/process/task\_queues:83:21) {\n meta: {\n body: { error: [Object], status: 409 },\n statusCode: 409,\n headers: {\n 'x-elastic-product': 'Elasticsearch',\n 'content-type': 'application/json; charset=UTF-8',\n 'content-length': '547'\n },\n meta: {\n context: null,\n request: [Object],\n name: 'elasticsearch-js',\n connection: [Object],\n attempts: 1,\n aborted: false\n }\n }\n}"}  
{"type":"error","@timestamp":"2022-07-01T11:59:46+00:00","tags":,"pid":115029,"level":"error","error":{"message":"Internal Server Error","name":"Error","stack":"Error: Internal Server Error\n at HapiResponseAdapter.toInternalError (/usr/share/kibana/src/core/server/http/router/response\_adapter.js:61:19)\n at Router.handle (/usr/share/kibana/src/core/server/http/router/router.js:172:34)\n at runMicrotasks ()\n at processTicksAndRejections (node:internal/process/task\_queues:96:5)\n at handler (/usr/share/kibana/src/core/server/http/router/router.js:124:50)\n at exports.Manager.execute (/usr/share/kibana/node\_modules/@hapi/hapi/lib/toolkit.js:60:28)\n at Object.internals.handler (/usr/share/kibana/node\_modules/@hapi/hapi/lib/handler.js:46:20)\n at exports.execute (/usr/share/kibana/node\_modules/@hapi/hapi/lib/handler.js:31:20)\n at Request.\_lifecycle (/usr/share/kibana/node\_modules/@hapi/hapi/lib/request.js:371:32)\n at Request.\_execute (/usr/share/kibana/node\_modules/@hapi/hapi/lib/request.js:281:9)"},"url":"http://\<Kibana\_Host\>:\<Kibana\_Port\>/internal/security/login","message":"Internal Server Error"}  
{"type":"log","@timestamp":"2022-07-01T12:01:18+00:00","tags":["error","plugins","taskManager"],"pid":115029,"message":"Failed to poll for work: Error: work has timed out"}

Attached the login error screenshot as well. Did any one faced the similar issue and if yes, pleas post the solution to resolve this.

Cheers.

---

<div class="post-metadata">

**Author:** ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)\
**Post date:** [July 5, 2022, 4:51pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/2 "2022-07-05T16:51:50Z")

</div>

How are you creating your index pattern and did you also create an index pattern template?

@Pierre_Gayvallet how do we fix this?

Thanks,  
Bhavya

---

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [July 7, 2022, 10:39am UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/3 "2022-07-07T10:39:14Z")

</div>

@bhavyarm

Yes, We have created index templates and gave the index patterns to apply to that template. Also, We are using Data Streams instead of indices.

Any inputs on resolving this is much appreciated. Thanks.

---

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [July 28, 2022, 12:19pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/4 "2022-07-28T12:19:00Z")

</div>

@bhavyarm Any update on the issue?

---

<div class="post-metadata">

**Author:** ![ropc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ropc/32/47022_2.png) [@ropc](https://discuss.elastic.co/u/ropc)\
**Post date:** [July 31, 2022, 1:54pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/5 "2022-07-31T13:54:32Z")

</div>

@Avinash_09 - Did you happen to disable `index.refresh_interval` (i.e value = `-1`). We have seen similar errors in the past where the refresh interval was disabled on the `.security-tokens-7` , `.security-7` or `.kibana_security_session_1` indices and this would result into similar issues. I would recommend to check these indices settings (c.f `GET .kibana_security_session_1/_settings`, etc.)

---

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [August 10, 2022, 5:42pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/6 "2022-08-10T17:42:09Z")

</div>

Hi @ropc ,

No, We haven't disabled any refresh interval settings on these indices in our environment. We have recently upgraded the Elastic stack to 8.3.3 to overcome this issue.

But, Post upgrade, When checked about this indices, For .kibana\_security\_session\_1, .security-7 indices the refresh interval is with 1s and there is no index named .security-tokens-7. Getting below message in dev-tools:  
'''  
"type": "index\_not\_found\_exception",  
"reason": "no such index [.security-tokens-7]"  
'''  
What could be the next steps to resolve this issue? Can re-install of kibana nodes and joining them to existing elastic cluster would help? If yes, Should we need to follow any pre-steps before re-install of kibana to avoid any data loss w.r.t kibana related indices.

Regards,  
Avinash

---

<div class="post-metadata">

**Author:** ![ropc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ropc/32/47022_2.png) [@ropc](https://discuss.elastic.co/u/ropc)\
**Post date:** [August 11, 2022, 8:32am UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/7 "2022-08-11T08:32:49Z")

</div>

> No, We haven't disabled any refresh interval settings on these indices in our environment. We have recently upgraded the Elastic stack to 8.3.3 to overcome this issue.

I am glad this is working after the upgrade.

> there is no index named .security-tokens-7. Getting below message in dev-tools

The `.security-tokens-7` index will only exists if you have authentication realms where access tokens need to be stored (e.g SAML authentication realm).

---

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [August 11, 2022, 8:50am UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/8 "2022-08-11T08:50:21Z")

</div>

Hi @ropc,

Thanks for the quick reply. But, Post upgrade also we are still seeing the issue intermittently when accessing with kibana internal URL. Along with that, We are having new issue when accessing the Kibana via proxy/public URL.

Below is the error message:

## Please upgrade your browser

This Elastic installation has strict security requirements enabled that your current browser does not meet

PFA screenshot for the same.

 ![Kibana](https://us1.discourse-cdn.com/elastic/original/3X/e/5/e54ccdddfdb8ba990197cdf17614a1558f43d027.png)

Can you please help us here.

Regards,  
Avinash

---

<div class="post-metadata">

**Author:** ![ropc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ropc/32/47022_2.png) [@ropc](https://discuss.elastic.co/u/ropc)\
**Post date:** [August 11, 2022, 9:00am UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/9 "2022-08-11T09:00:07Z")

</div>

> Post upgrade also we are still seeing the issue intermittently when accessing with kibana internal URL

Are you referring to the same error: `version_conflict_engine_exception`? Do you happen to have multiple Kibana instances running?

> We are having new issue when accessing the Kibana via proxy/public URL.

It may be related to [Content Security Policy (CSP)](https://www.elastic.co/guide/en/kibana/current/Security-production-considerations.html#csp-strict-mode) and/or some outdated browsers. You may want to check this.

---

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [August 11, 2022, 9:06am UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/10 "2022-08-11T09:06:59Z")

</div>

Yes @ropc,

To your question 1: Yes, I am referring the same error. Yes, We have 2 kibana instances running for this cluster. Any other places to check on this issue?

Thanks for info on point 2. I will check on Content Security Policy (CSP) settings and see if the browser outdated issue gets resolved.

Regards,  
Avinash

---

<div class="post-metadata">

**Author:** ![ropc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ropc/32/47022_2.png) [@ropc](https://discuss.elastic.co/u/ropc)\
**Post date:** [August 11, 2022, 9:30am UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/11 "2022-08-11T09:30:17Z")

</div>

> To your question 1: Yes, I am referring the same error. Yes, We have 2 kibana instances running for this cluster. Any other places to check on this issue?

Is this proxy used as a load-balancer as well? Perhaps you may want to check the following documentation:

- [Load balancing across multiple Kibana instances](https://www.elastic.co/guide/en/kibana/current/production.html#load-balancing-kibana)
- [Accessing multiple load-balanced Kibana clusters](https://www.elastic.co/guide/en/kibana/current/production.html#accessing-load-balanced-kibana)

---

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [August 11, 2022, 1:00pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/12 "2022-08-11T13:00:20Z")

</div>

Hi @ropc,

Yes, Proxy is used as load balancer. We have followed the necessary steps as per documentation. But, Will cross check on them and get back.

w.r.t browser issue (Content Security Policy), even after applying the settings still we see the same info message on browser.

## Please upgrade your browser

This Elastic installation has strict security requirements enabled that your current browser does not meet.

PFA Screenshot for the same.

 ![Kibana](https://us1.discourse-cdn.com/elastic/original/3X/e/5/e54ccdddfdb8ba990197cdf17614a1558f43d027.png)

Also, I could see below error journal logs. Is there anything to do with this error?

Aug 11 12:55:52 dev5083 kibana[97108]: [2022-08-11T12:55:52.888+00:00][ERROR][plugins.taskManager] Failed to poll for work: Error: work has timed out

---

<div class="post-metadata">

**Author:** ![ropc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ropc/32/47022_2.png) [@ropc](https://discuss.elastic.co/u/ropc)\
**Post date:** [August 11, 2022, 1:15pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/13 "2022-08-11T13:15:33Z")

</div>

1. What is the current setting in Kibana for `csp.strict` and are you facing this issue on all browsers? Which browser / browser version are you using?

2. Have you tried to bypass the proxy and check if the same problem happens?

---

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [August 11, 2022, 1:26pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/14 "2022-08-11T13:26:19Z")

</div>

> [@ropc](#):
>
> What is the current setting in Kibana for `csp.strict` and are you facing this issue on all browsers? Which browser / browser version are you using?

csp.strict: true is the current setting in Kibana. Yes, I am facing issue on all browsers. I have tried on below browsers and their versions are mentioned as well.

Chrome Version: 104.0.5112.81 (Official Build) (64-bit)  
Firefox Version: 103.0.2 (64-bit)  
Microsoft Edge version: Version 104.0.1293.47 (Official build) (64-bit)

> [@ropc](#):
>
> Have you tried to bypass the proxy and check if the same problem happens?

Yes, We tried bypassing the proxy and no problem is noticed when bypassing the proxy.

Regards,  
Avinash

---

<div class="post-metadata">

**Author:** ![ropc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ropc/32/47022_2.png) [@ropc](https://discuss.elastic.co/u/ropc)\
**Post date:** [August 11, 2022, 1:38pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/15 "2022-08-11T13:38:54Z")

</div>

If bypassing the proxy works, then it must be something related to the proxy and its configuration. This is not really my expertise but I can ask around...

Which proxy are you using?

---

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [August 11, 2022, 1:46pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/16 "2022-08-11T13:46:57Z")

</div>

@ropc, Thanks for the update. We suspect the same. We are using Apache httpd as proxy server. Can you check and update us w.r.t the changes need to be done on Proxy server to fix this issue?

---

<div class="post-metadata">

**Author:** ![ropc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ropc/32/47022_2.png) [@ropc](https://discuss.elastic.co/u/ropc)\
**Post date:** [August 14, 2022, 12:23pm UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/17 "2022-08-14T12:23:40Z")

</div>

@Avinash_09 - One thing I can think about is the Apache httpd server overriding the `Content-Security-Policy` header. It is a wild guess but you may want to check with your IT team if any headers are being overridden at the proxy level.

---

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [August 17, 2022, 3:50am UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/18 "2022-08-17T03:50:45Z")

</div>

Hi @ropc , Thank you very much for your time. We have made the changes at our proxy with our IT Team and now Public URL login issue is resolved.

Regards,  
Avinash

---

<div class="post-metadata">

**Author:** ![Avinash\_09](https://avatars.discourse-cdn.com/v4/letter/a/4af34b/32.png) [@Avinash\_09](https://discuss.elastic.co/u/Avinash_09)\
**Post date:** [August 23, 2022, 8:39am UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/19 "2022-08-23T08:39:59Z")

</div>

Hi @ropc ,

We are again now seeing the kibana login issue with below error. PFA below screenshot for the same

 ![kibana-8.3.3_login_issue](https://us1.discourse-cdn.com/elastic/original/3X/1/5/15c4ec9deb3bdd80f99a87de78370a3166675781.png)

Unable to find any related errors in kibana logs. Below is one of the error noticed in kibana logs:

{"type":"log","@timestamp":"2022-08-22T13:59:49+00:00","tags":["error","plugins","dataEnhanced","data\_enhanced"],"pid":49237,"message":"TimeoutError: Request timed out\n at ClientRequest.onTimeout (/usr/share/kibana/node\_modules/@elastic/elasticsearch/lib/Connection.js:110:16)\n at ClientRequest.emit (node:events:526:28)\n at TLSSocket.emitRequestTimeout (node:\_http\_client:758:9)\n at Object.onceWrapper (node:events:645:28)\n at TLSSocket.emit (node:events:538:35)\n at TLSSocket.Socket.\_onTimeout (node:net:501:8)\n at listOnTimeout (node:internal/timers:559:17)\n at processTimers (node:internal/timers:502:7) {\n meta: {\n body: null,\n statusCode: null,\n headers: null,\n meta: {\n context: null,\n request: [Object],\n name: 'elasticsearch-js',\n connection: [Object],\n attempts: 0,\n aborted: false\n }\n },\n isBoom: true,\n isServer: true,\n data: null,\n output: {\n statusCode: 503,\n payload: {\n statusCode: 503,\n error: 'Service Unavailable',\n message: 'Request timed out'\n },\n headers: {}\n },\n [Symbol(SavedObjectsClientErrorCode)]: 'SavedObjectsClient/esUnavailable'\n}"}

Not sure this is related to login issue or not.

Regards,  
Avinash

---

<div class="post-metadata">

**Author:** ![ropc](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ropc/32/47022_2.png) [@ropc](https://discuss.elastic.co/u/ropc)\
**Post date:** [August 23, 2022, 10:01am UTC](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670/20 "2022-08-23T10:01:02Z")

</div>

@Avinash_09 - I am not sure as well - you would need to cross-reference the Kibana logs with the authentication issue. If this issue is reproducible, a HAR file capturing the issue along with the Kibana logs would usually help. However, it will be best if you can get this issue reviewed by our Support team (if you do have a subscription with us).

[Next page](https://discuss.elastic.co/t/kibana-v7-16-1-login-issue-not-able-to-login-responseerror-version-conflict-engine-exception/308670.md?page=2)
