# Kibana webserver error (docker version)

**URL:** https://discuss.elastic.co/t/kibana-webserver-error-docker-version/100036
**Category:** Kibana
**Created:** [September 11, 2017, 11:16am UTC](https://discuss.elastic.co/t/kibana-webserver-error-docker-version/100036 "2017-09-11T11:16:09Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![maor](https://avatars.discourse-cdn.com/v4/letter/m/9de053/32.png) [@maor](https://discuss.elastic.co/u/maor)
#### Post date: [September 11, 2017, 11:16am UTC](https://discuss.elastic.co/t/kibana-webserver-error-docker-version/100036/1 "2017-09-11T11:16:09Z")

</div>

Hey all.  
First of all, I'd like to thank you for this board. It helped me a lot resolving the errors while deploying ELK.

I've gotten into a problem and I can't find it's solution on the internet.

I've started filebeat, logstash and elasticsearch to a point I got the logs to elasticsearch indexed well.  
My problem now is with kibana. I've used the following docker version of kibana:

> FROM [docker.elastic.co/kibana/kibana:5.5.2](http://docker.elastic.co/kibana/kibana:5.5.2)  
> ADD kibana.yml /etc/kibana/kibana.yml  
> WORKDIR ["/opt/kibana"]  
> ENTRYPOINT ["/bin/bash"]

My kibana.yml file is:

> elasticsearch.url: "[http://ip:9200](http://ip:9200)"  
> elasticsearch.username: "elastic"  
> elasticsearch.password: "changeme"  
> logging.verbose: "true"

I run the container with the following command:

> docker run -it --name kibana -p 5601:5601 kibana:stat

And inside the container I use the following command:

> /opt/kibana/bin/kibana -c /etc/kibana/kibana.yml

My problem is that I don't see any errors in the log (only security warnings such as random key generation), I also get

> log [11:08:49.681] [info][listening] Server running at [http://localhost:5601](http://localhost:5601)  
> log [11:08:49.683] [info][status][ui settings] Status changed from uninitialized to green - Ready

But when I attempt to browse to the specific ip:5601 - I get a `ERR_CONNECTION_REFUSED`.

When I use curl inside the container, I get no output:

> bash-4.2$ curl [http://localhost:5601](http://localhost:5601)  
> bash-4.2$

And outside the container:

> [user@host~]$ curl [http://localhost:5601](http://localhost:5601)  
> curl: (56) Recv failure: Connection reset by peer

I don't think its a networking issue since I run an es host as a container on the same host and browsing ip:9200 works just fine.

Any ideas why I can't browse into the kibana web server? why I don't get any output from kibana webapp?

Thanks!

---

<div class="post-metadata">

### Author: ![maor](https://avatars.discourse-cdn.com/v4/letter/m/9de053/32.png) [@maor](https://discuss.elastic.co/u/maor)
#### Post date: [September 13, 2017, 10:29am UTC](https://discuss.elastic.co/t/kibana-webserver-error-docker-version/100036/2 "2017-09-13T10:29:31Z")

</div>

Solved using Kibana 5.6.  
Thanks.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 11, 2017, 10:30am UTC](https://discuss.elastic.co/t/kibana-webserver-error-docker-version/100036/3 "2017-10-11T10:30:09Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
