# Kibana with Nginx have intermittent Kibana did not load properly. Check the server output for more information errors

**URL:** <https://discuss.elastic.co/t/kibana-with-nginx-have-intermittent-kibana-did-not-load-properly-check-the-server-output-for-more-information-errors/146889>\
**Category:** Kibana\
**Created:** [August 31, 2018, 3:32pm UTC](https://discuss.elastic.co/t/kibana-with-nginx-have-intermittent-kibana-did-not-load-properly-check-the-server-output-for-more-information-errors/146889 "2018-08-31T15:32:06Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![myerasi](https://avatars.discourse-cdn.com/v4/letter/m/6bbea6/32.png) [@myerasi](https://discuss.elastic.co/u/myerasi)\
**Post date:** [August 31, 2018, 3:32pm UTC](https://discuss.elastic.co/t/kibana-with-nginx-have-intermittent-kibana-did-not-load-properly-check-the-server-output-for-more-information-errors/146889/1 "2018-08-31T15:32:06Z")

</div>

ES, Logstash, Kibana Version: 6.2.4

We are running Kibana behind nginx. Once we launch the page, we receive the dialog box to enter the credentials and post submitting, we are receiving the "kibana did not load properly" error message. And this error is intermittent. We have looked at Kibana logs and found nothing.

Also, we have x-pack basic license installed. And have defined the following settings in kibana.yml:  
xpack.security.enabled: false  
xpack.monitoring.report\_stats: false  
xpack.apm.ui.enabled: false

This sort of behavior is creating bad impression of the QOS provided.

I am sure that we missing some minor thing.

Any help in this would be appreciable.

---

<div class="post-metadata">

**Author:** ![christophilus](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christophilus/32/42991_2.png) [@christophilus](https://discuss.elastic.co/u/christophilus)\
**Post date:** [August 31, 2018, 6:08pm UTC](https://discuss.elastic.co/t/kibana-with-nginx-have-intermittent-kibana-did-not-load-properly-check-the-server-output-for-more-information-errors/146889/2 "2018-08-31T18:08:27Z")

</div>

Hi Myerasi,

I think you need to have `xpack.security.enabled: true`, in which case you'll be presented with the usual Kibana login screen.

See the docs here: [Security settings in Kibana | Kibana Guide [8.11] | Elastic](https://www.elastic.co/guide/en/kibana/current/security-settings-kb.html), specifically:

> Do not set this to `false` .

Best,  
Chris

---

<div class="post-metadata">

**Author:** ![myerasi](https://avatars.discourse-cdn.com/v4/letter/m/6bbea6/32.png) [@myerasi](https://discuss.elastic.co/u/myerasi)\
**Post date:** [August 31, 2018, 7:53pm UTC](https://discuss.elastic.co/t/kibana-with-nginx-have-intermittent-kibana-did-not-load-properly-check-the-server-output-for-more-information-errors/146889/3 "2018-08-31T19:53:24Z")

</div>

HI Chris,

Thanks for the reply. I should have mentioned this earlier. We are using x-pack basic license and thus set it to false. Correct me if I am wrong.

---

<div class="post-metadata">

**Author:** ![myerasi](https://avatars.discourse-cdn.com/v4/letter/m/6bbea6/32.png) [@myerasi](https://discuss.elastic.co/u/myerasi)\
**Post date:** [September 4, 2018, 5:51pm UTC](https://discuss.elastic.co/t/kibana-with-nginx-have-intermittent-kibana-did-not-load-properly-check-the-server-output-for-more-information-errors/146889/4 "2018-09-04T17:51:38Z")

</div>

Chris/someone,

Can you guys have a look at this issue please. We have launched our Elasticstack and it is ingesting production logs now. So, we would like to get this resolved ASAP to rule out the negative impression among the users.

Thanks,  
Mahen

---

<div class="post-metadata">

**Author:** ![myerasi](https://avatars.discourse-cdn.com/v4/letter/m/6bbea6/32.png) [@myerasi](https://discuss.elastic.co/u/myerasi)\
**Post date:** [September 6, 2018, 10:24pm UTC](https://discuss.elastic.co/t/kibana-with-nginx-have-intermittent-kibana-did-not-load-properly-check-the-server-output-for-more-information-errors/146889/5 "2018-09-06T22:24:33Z")

</div>

Any suggestion/direction on this would be of great help.

Thanks,  
Mahen

---

<div class="post-metadata">

**Author:** ![KBuev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kbuev/32/20620_2.png) [@KBuev](https://discuss.elastic.co/u/KBuev)\
**Post date:** [September 9, 2018, 8:46am UTC](https://discuss.elastic.co/t/kibana-with-nginx-have-intermittent-kibana-did-not-load-properly-check-the-server-output-for-more-information-errors/146889/6 "2018-09-09T08:46:56Z")

</div>

Since you're running Kibana behind Nginx, you should check its (Nginx's) logs and see if there are any errors being logged when you get the "kibana did not load properly" message.  
You should also try bypassing Nginx and working with your Kibana instance directly: that way you'll know if this has anything to do with Nginx at all.

---

<div class="post-metadata">

**Author:** ![myerasi](https://avatars.discourse-cdn.com/v4/letter/m/6bbea6/32.png) [@myerasi](https://discuss.elastic.co/u/myerasi)\
**Post date:** [September 21, 2018, 3:44pm UTC](https://discuss.elastic.co/t/kibana-with-nginx-have-intermittent-kibana-did-not-load-properly-check-the-server-output-for-more-information-errors/146889/7 "2018-09-21T15:44:31Z")

</div>

Thanks for the response KBuev. The issue was with one of the LDAP server (which resides in a different data center) network connectivity. We had two LDAP authentications defined in nginx config. Deleting the config for the problematic LDAP server in the nginx configuration has fixed the issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 19, 2018, 3:44pm UTC](https://discuss.elastic.co/t/kibana-with-nginx-have-intermittent-kibana-did-not-load-properly-check-the-server-output-for-more-information-errors/146889/8 "2018-10-19T15:44:39Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
