# Kibana with Shield SSL

**URL:** https://discuss.elastic.co/t/kibana-with-shield-ssl/62218
**Category:** Kibana
**Created:** [October 4, 2016, 8:15pm UTC](https://discuss.elastic.co/t/kibana-with-shield-ssl/62218 "2016-10-04T20:15:25Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![imHarshj](https://avatars.discourse-cdn.com/v4/letter/i/e495f1/32.png) [@imHarshj](https://discuss.elastic.co/u/imHarshj)
#### Post date: [October 4, 2016, 8:15pm UTC](https://discuss.elastic.co/t/kibana-with-shield-ssl/62218/1 "2016-10-04T20:15:25Z")

</div>

Hello,  
Trying to enable Kibana to work with Shield. I'm getting this error in the log:  
FATAL { [Error: EACCES: permission denied, open '/etc/.../file.key

Similar to this thread:

> [@Kibana Service Fails when SSL Cert Enabled](https://discuss.elastic.co/t/kibana-service-fails-when-ssl-cert-enabled/59417/2):
>
> It looks like you're on the right track, the error seems to indicate an issue opening the file. Kibana packages using systemd run as the user 'kibana' Can you make sure permissions on your certificates allow for read access to the file as either user or group kibana? If you chown kibana /etc/letsencrypt/live/api.domain.com/privkey.pem for example are you able to start the server?

Using Shield 4.6  
Appreciate the help.

EDIT:  
Solved it!  
It seems that the documentation doesn't mention WHERE to put the .key and .crt for kibana.  
I was using the directions on this page. [Using Kibana with Shield | Shield [2.4] | Elastic](https://www.elastic.co/guide/en/shield/current/kibana.html)  
Skipping step 5, I first went to step 6 and installed Shield in Kibana. THEN i moved the generated .key/.crt to the /opt/kibana/installedPlugins/shield/ directory. This solved the "Permission Denied" issue on the key.

---

<div class="post-metadata">

### Author: ![tylersmalley](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tylersmalley/32/8833_2.png) [@tylersmalley](https://discuss.elastic.co/u/tylersmalley)
#### Post date: [October 5, 2016, 9:05am UTC](https://discuss.elastic.co/t/kibana-with-shield-ssl/62218/2 "2016-10-05T09:05:28Z")

</div>

What are the permissions of file.key? `ls -al /etc/.../file.key`

How are you starting Kibana and as what user?

---

<div class="post-metadata">

### Author: ![imHarshj](https://avatars.discourse-cdn.com/v4/letter/i/e495f1/32.png) [@imHarshj](https://discuss.elastic.co/u/imHarshj)
#### Post date: [October 5, 2016, 1:08pm UTC](https://discuss.elastic.co/t/kibana-with-shield-ssl/62218/3 "2016-10-05T13:08:55Z")

</div>

It has root permissions and I've tried a range of permissions from default to all rwx access. and I'm using sudo to start kibana.

---

<div class="post-metadata">

### Author: ![imHarshj](https://avatars.discourse-cdn.com/v4/letter/i/e495f1/32.png) [@imHarshj](https://discuss.elastic.co/u/imHarshj)
#### Post date: [October 5, 2016, 2:36pm UTC](https://discuss.elastic.co/t/kibana-with-shield-ssl/62218/4 "2016-10-05T14:36:44Z")

</div>

Thanks Tyler.  
You got me thinking about kibana not being able to access a directory so I moved the key/crt to within Kibana's directory. and that solved it. See Edit in my post.

Harsh

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:37pm UTC](https://discuss.elastic.co/t/kibana-with-shield-ssl/62218/5 "2017-07-06T13:37:31Z")

</div>


